Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Software and Operating SystemPre-Installed Lenovo Software and Applications
All Forum Topics
Options

23 Posts

09-20-2009

California

85 Signins

760 Page Views

  • Posts: 23
  • Registered: ‎09-20-2009
  • Location: California
  • Views: 760
  • Message 1 of 48

anyone having trouble with updater 5?

2012-09-25, 17:49 PM

Just seems to hang after the updater 5 screen then do nothing.  server is still running under device manager.  I'm running T61 windows 7 with all updates.

Reply
Options

946 Posts

01-17-2010

United States of America

1188 Signins

9856 Page Views

  • Posts: 946
  • Registered: ‎01-17-2010
  • Location: United States of America
  • Views: 9856
  • Message 2 of 48

Re: anyone having trouble with updater 5?

2012-09-25, 21:40 PM

Can you make your log file available (via yousendit or dropbox, etc.)?  It will be located here for 64bit: C:\Program Files (x86)\Lenovo\System Update\logs 

 

or here for 32 bit:  C:\Program Files\Lenovo\System Update\logs

 

Look for the most current tvsu_log_xxxxxxxx.txt

 

I'm running v5 on Win7 64-bit and am not seeing such an issue.

Reply
Options

23 Posts

09-20-2009

California

85 Signins

760 Page Views

  • Posts: 23
  • Registered: ‎09-20-2009
  • Location: California
  • Views: 760
  • Message 3 of 48

Re: anyone having trouble with updater 5?

2012-09-25, 22:36 PM

 

here is the log. thank you

 

Info    2012-09-25 , 10:43:26
    at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command)
    Message: The current user is a Vista Administrator, the request will be handled by suservice -System context-

Severe    2012-09-25 , 10:43:26
    at Tvsu.Service.Client.CommandLauncher.Main(String[] args)
    Message: Error launching command
    Exception:
        Message: Object reference not set to an instance of an object.
        Type: System.NullReferenceException
           at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command)
   at Tvsu.Service.Client.CommandLauncher.Main(String[] args)

Reply
Options

14 Posts

05-13-2009

Canada

22 Signins

82 Page Views

  • Posts: 14
  • Registered: ‎05-13-2009
  • Location: Canada
  • Views: 82
  • Message 4 of 48

Re: anyone having trouble with updater 5?

2012-09-26, 0:50 AM

I'm running Windows 7 Pro (32-bit) on a T61, and am experiencing the same issue with System Update 5. I click to go into System Update 5, the splash screen comes up, and then it stays there until maybe 10-15 seconds. Then nothing. Everything on my system is up to date.

 

Here's the log:

 

Info    2012-09-25 , 06:19:01
    at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command)
    Message: The current user is a Vista Administrator, the request will be handled by suservice -System context-

Severe    2012-09-25 , 06:19:01
    at Tvsu.Service.Client.CommandLauncher.Main(String[] args)
    Message: Error launching command
    Exception:
        Message: Object reference not set to an instance of an object.
        Type: System.NullReferenceException
           at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command)
   at Tvsu.Service.Client.CommandLauncher.Main(String[] args)

 

Thanks in advance for looking into this.

Reply
Options

57 Posts

05-11-2008

United States of America

248 Signins

2068 Page Views

  • Posts: 57
  • Registered: ‎05-11-2008
  • Location: United States of America
  • Views: 2068
  • Message 5 of 48

Re: anyone having trouble with updater 5?

2012-09-26, 3:44 AM

I'm having the same problem on three machines:

T-510, win 7, professional 64 bit.

T-410, win 7, professional  32 bit

R-61, win 7 ultimate, 32 bit

The splash screen appears for a minute or so, then disappears.  Then, nothing.

 

 

Reply
Options

5 Posts

09-15-2009

Vienna

7 Signins

80 Page Views

  • Posts: 5
  • Registered: ‎09-15-2009
  • Location: Vienna
  • Views: 80
  • Message 6 of 48

Re: anyone having trouble with updater 5?

2012-09-26, 4:28 AM

Same problem after automatic update to version 5 on a T420 using Windows 7 Ultimate x64.

Starting, splas window appears for a few minutes and then nothing!

 

Content of tvsu_exe.log:

TSS(L) 1: 23:15:42:0517 tvsu.cpp(1825): Installdir: C:\Program Files (x86)\Lenovo\System Update
TSS(L) 1: 23:15:42:0579 tvsu.cpp(1754): Installdir: C:\Program Files (x86)\Lenovo\System Update
TSS(L) 1: 23:15:42:0579 tvsu.cpp(1775): szCmd: C:\Program Files (x86)\Lenovo\System Update\TvsuCommandLauncher.exe
TSS(L) 1: 23:15:42:0673 tvsu.cpp(579): StartTvsukernel : admin
TSS(L) 1: 23:15:42:0673 tvsu.cpp(586): Begin InvokeUacSdkViaService
TSS(L) 1: 23:15:42:0689 tvsu.cpp(431): Installdir: C:\Program Files (x86)\Lenovo\System Update
TSS(L) 1: 23:15:42:0689 tvsu.cpp(466): szCmd: C:\Program Files (x86)\Lenovo\System Update\TvsuCommandLauncher.exe

 

Content of service_log.txt:

Info 2012-09-25 , 11:15:42
at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command)
Message: The current user is a Vista Administrator, the request will be handled by suservice -System context-

Severe 2012-09-25 , 11:15:42
at Tvsu.Service.Client.CommandLauncher.Main(String[] args)
Message: Error launching command
Exception:
Message: Object reference not set to an instance of an object.
Type: System.NullReferenceException
at Tvsu.Service.Client.CommandLauncher.ExecuteCommandLine(String command)
at Tvsu.Service.Client.CommandLauncher.Main(String[] args)

 

Reply
Options

7263 Posts

10-29-2009

United States of America

17930 Signins

168610 Page Views

  • Posts: 7263
  • Registered: ‎10-29-2009
  • Location: United States of America
  • Views: 168610
  • Message 7 of 48

Re: anyone having trouble with updater 5?

2012-09-26, 14:06 PM

Can you guys having this problem please run a command prompt as admin and then do the following:

 

"sc qtriggerinfo suservice"

 

I expect the result to be something like:

 

[SC] QueryServiceConfig2 SUCCESS

SERVICE_NAME: suservice

START SERVICE
CUSTOM : e993c128-7fa6-490d-8630-f7975f6eb543 [ETW PROVIDER UUID]
STOP SERVICE
CUSTOM : 37b18cf1-e5aa-4f85-9016-b0303fafa921 [ETW PROVIDER UUID]

 

But please let me know if you are seeing something different.

Reply
Options

57 Posts

05-11-2008

United States of America

248 Signins

2068 Page Views

  • Posts: 57
  • Registered: ‎05-11-2008
  • Location: United States of America
  • Views: 2068
  • Message 8 of 48

Re: anyone having trouble with updater 5?

2012-09-26, 16:36 PM

Hi -- I get back a prompt that says "The specified service does not exist as an installed service."

 

Also this might be useful: In C:\program files\lenovo\system update, there's a log file, StartServiceLogger.Txt that contains the following:

 

9:47:05 PM Tuesday, September 25, 2012
Check if IsServiceAlreadyInstalled: SuService
-----------------------------------------------------------------
9:47:05 PM Tuesday, September 25, 2012
schSCManager handle: 2592544
-----------------------------------------------------------------
9:47:05 PM Tuesday, September 25, 2012
schService: 0
-----------------------------------------------------------------
9:47:05 PM Tuesday, September 25, 2012
pInfo.FileName: C:\Windows\Microsoft.NET\Framework\v1.1.4322\installUtil.exe
-----------------------------------------------------------------
9:47:05 PM Tuesday, September 25, 2012
pInfo.Arguments: "C:\Program Files\Lenovo\System Update\SuService.exe"
-----------------------------------------------------------------
9:47:06 PM Tuesday, September 25, 2012
Install service outPut: -1
-----------------------------------------------------------------
9:47:06 PM Tuesday, September 25, 2012
Install service failed
-----------------------------------------------------------------

Reply
Options

24 Posts

10-22-2011

philadelphia pa

34 Signins

99 Page Views

  • Posts: 24
  • Registered: ‎10-22-2011
  • Location: philadelphia pa
  • Views: 99
  • Message 9 of 48

System Update Version 5 download link?

2012-09-26, 17:26 PM

I am offered SU 5 on other thinkpads when I run the older version--4.03.

 

Is there a direct download link available?

 

I cannot find it via search on the site...

Reply
Options

7263 Posts

10-29-2009

United States of America

17930 Signins

168610 Page Views

  • Posts: 7263
  • Registered: ‎10-29-2009
  • Location: United States of America
  • Views: 168610
  • Message 10 of 48

Re: anyone having trouble with updater 5?

2012-09-26, 17:56 PM

Bruce443,

 

Can you please check within services.msc to see if "System Update" is listed as shown?

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms