English Community

Software and Operating SystemPre-Installed Lenovo Software and Applications
All Forum Topics
Options

6 Posts

12-12-2017

DE

12 Signins

85 Page Views

  • Posts: 6
  • Registered: ‎12-12-2017
  • Location: DE
  • Views: 85
  • Message 1 of 2

Lenovo Energy Manager is extremly slow and keeps freezing

2017-12-12, 12:27 PM

Hello Lenovo Community,

I have a Lenovo W550s on a Win 7 Home Premium SP1 64 bit running Lenovo Energy Manager 6.68.14.

The Energy Manager itself is pretty cool, but it is extremely slow and lags and freezes all the tims (maybe because it has so many fancy design features and animations?).

Sometimes, especially when in energy saving mode, it takes 2 minutes to start the manager which is a mess because every programm still runs smooth exept the Lenovo software.

Tried updating the software and resetting all energy modes, didn't help.

Is there a way to speed it up or would the Lenovo developpers mind focusing on form and not on design? I think it's the reason most of the ThinkPad users bought a Lenovo and not a pink Dell notebook ;)

Best Regards,

matthias_

 

P.S. Also I realized that when running in high performance mode, the laptop is significantly slower than when the performance bar is just a little lower of the highest performance. No clue where that comes from.

Solved! See the solution
Reply
Options

6 Posts

12-12-2017

DE

12 Signins

85 Page Views

  • Posts: 6
  • Registered: ‎12-12-2017
  • Location: DE
  • Views: 85
  • Message 2 of 2

Re: Lenovo Energy Manager is extremly slow and keeps freezing

2019-05-21, 8:29 AM

Hi all,

 

I had a similar issue and posted a solution here:

https://forums.lenovo.com/t5/ThinkPad-P-and-W-Series-Mobile/W550s-horrible-performance/m-p/4434423/highlight/true#M80625

It doesn't involve tweaking things in Throttle stop, but basically just disabling the "intelligent cooling"in the "Active Protection System".

 

In case the link won't work some day, heres my reply:

 

Thank you so much @sdu! You gave the hint to the solution that works for me :D :D :D

I have been messing around with extremely slow CPU performance after every hibernation startup - I almost couldn't move my mouse sometimes and it took me about 2 minutes to open the Power Manager.

I identified this using "Throttle stop" which shows the limits and the task manger showed almost constantly 100% while power manager capped the CPU speed at 40-60 %.

 

What worked for me (Lenovo W550s Win7 Home Premium 64bit SP1) is very simple:

- open the "Active Protection System"

- click the "intelligent cooling" tab

- disable "enable intelligent cooling"

 

Disable it, it is not intelligent, it's stupid - it's a trap ;)
 

Before I realized this was the problem I found a workaround. If the proposed solution doesn't work, this might be a pretty annoying, though life-saving workaround:

- every time your CPU throttles, open the power manager

- click on "Advanced" button

- in the active mode (maximum performance or video playback in my case), extend the system settings and select "Turbo" for maximum CPU speed (even if maximum Turbo was selected previously).

- click apply

- then, select "Maximum Turbo" for maximum CPU speed again

- click apply

- CPU speed will go up on 100 % immediately and CPU load will drop to < 30 % or so

0 person found this solution to be helpful.

This helped me too

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete