Showing results for 
Search instead for 
Do you mean 
Paper Tape
Posts: 3
Registered: ‎04-20-2011
Location: San Francisco
Message 1 of 4 (3,673 Views)

Rescue & Recovery and MBR fix do not work

I have a T61P running XP Pro. After updating the BIOS, and other programs with Lenovo Update, Rescue and Recovery 4.20.0511.00,  the initial problem was that the ThinkVantage button would not get into R&R at pre-Boot. Called Tech service and was recommended to use MIGR-62978 (MBR Fix) and MIGR-54483 (R&R Repair).


I first ran the R&R fix, first trying the "repair" option. After that, when booting, only the Lenovo marquee, then black screen with cursor in upper left hand corner. Tried the "Replace" option with the same result.


Then I ran the MBR fix, which I received the "Read Current Drive Error 65535" "Safeguard Easy was not found on this computer This program did not make any changes.


This all after 4 calls to Tech support, and was told that my only option was to use the repair disks that will come in a day or two and basically wipe the drive and start fresh, then loading my week old backup from my NAS.


I did look at the solution stating to boot from a Windows CD, Hit "R" to go to the recovery console, and repair the MBR from there. I am reticent to do this in fear of messing up the hidden partition and R&R which has a month old backup on a USB drive.


Please help with any insights as to getting my T61p going again.


I have learned much from the forum, and now I need some help.


Kind Regards

Paper Tape
Posts: 3
Registered: ‎04-20-2011
Location: San Francisco
Message 2 of 4 (3,659 Views)

Re: Rescue & Recovery and MBR fix do not work



When running the MBR fix, I get an error of "Filters returned and empty menu"


I appreciate all your help

Posts: 2,524
Registered: ‎03-19-2009
Location: DE
Message 3 of 4 (3,622 Views)

Re: Rescue & Recovery and MBR fix do not work

[ Edited ]

Poor Lenovo service:

MIGR-62978 is dedicated to be used, if you are in an endless loop entering the R&R recovery-partiton. See :


MIGR-54483 is the right one. It enables the ThinkVantage-Button and F11 to enter the R&R recovery-partition:


After booting from CD/Floppy select "Write new MBR"



On my thinkpads i leave the ThinkVantage-button disabled. Instead of re-enabling i keep a bootable USB-stick in my pocket with a bootable gparted on it.

To enable the revovery-partition I boot gparted and set the recovery partition "active" and "visible" (if "hidden"). After rebooting the HDD R&R boots automatically.

My home-forum:
Wiki: Deutsches ThinkPad-Wiki English ThinkWiki
My ThinkPad-Collection
Coffee must be like women's eyes: deep black & shiny. ThinkPads have to be like men's feet: deep black & matte!
Paper Tape
Posts: 3
Registered: ‎04-20-2011
Location: San Francisco
Message 4 of 4 (3,611 Views)

Re: Rescue & Recovery and MBR fix do not work

Thanks for the reply.


I did try those MIGR programs and they did not work; I then used my Acronis backup and selected to restore the MBR only, and that got the machine up and running.


I think that the R&R may be corrupted and want to uninstall and reinstall R&R, but am unsure as to reinstall Ver 4.20.1511 and apply the fixes to that version, or go to 4.2.1016 or directly to Ver 4.3_017.


I found that there may be a conflict with the client security solution and don't know if I need to uninstall that and then reinstall it again.


I appreciate your suggestions if you have them, as I am now unsure if calling Tech Support will provide a good solution.


Kind Regards,



Top kudoed Authors