Showing results for 
Search instead for 
Do you mean 
Reply
Paper Tape
Posts: 4
Registered: ‎05-08-2015
Location: United Kingdom
Message 1 of 9 (3,116 Views)

Rescue & Recovery cannot restore from backup files it finds when starting

[ Edited ]

I have had a system problem recently on my Lenovo machine, and have had to re-image it. When I try to restore from my backups using Rescue and Recovery (R&R), they prove inaccessible. How do I access these backups?

Details of the options selected in R&R are attached, as a screen image of the settings dialog.

Running R&R, the backups (on an external USB HDD) are visible and can be chosen as expected. When the machine reboots into the Restore workspace, after a warning not to switch off the power, it results in the error message "The restore failed because the backup was not found in the specified location". Accepting this reboots the machine back into Windows. This occurs irrespective of the options selected during startup of R&R.  When appropriate I select USB External Storage Device in setup, and select a backup from those listed.

I have also attempted to update all the Lenovo utilites, including R&R. The option "Get new updates" errors while downloading package information Lenovo Help Centre (1 of 1) at the 30% mark with the error "Exception Not Expected was encountered!".

Capture.PNG 

Bit Torrent
Posts: 3,465
Registered: ‎11-22-2011
Location: US
Message 2 of 9 (3,082 Views)

Re: Rescue & Recovery cannot restore from backup files it finds when starting

You state:

I have also attempted to update all the Lenovo utilites, including R&R. The option "Get new updates" errors while downloading package information Lenovo Help Centre (1 of 1) at the 30% mark with the error "Exception Not Expected was encountered!".

===

Send system update fail logs to Lenovo for analysis. 

logs location:

 C:\ProgramData\Lenovo\SystemUpdate\logs

 

Zip up that entire folder and email it to  lenovoforums@yahoo.com .

 

Paper Tape
Posts: 4
Registered: ‎05-08-2015
Location: United Kingdom
Message 3 of 9 (3,063 Views)

Re: Rescue & Recovery cannot restore from backup files it finds when starting

There is no such location on my computer. There is a C:\ProgramData\Lenovo\ directory with a tvt_userinfo.ini file and subdirectories for Client Security Solution (which contains a cspContainers.dat file); LenovoTvtTools; MessageCentrePlus; and Themes, none of which contain any logs. The only log relating to System Update is in the Program (x86) directory which is in textual form, and seems only to be concerned with starting the service.

Bit Torrent
Posts: 3,465
Registered: ‎11-22-2011
Location: US
Message 4 of 9 (2,987 Views)

Re: Rescue & Recovery cannot restore from backup files it finds when starting

[ Edited ]

As far as the System update issue, you should see:

lenovo folder.PNG

If the SystemUpdate folder does not appear, it could be SU is uninstalled. Control panel, programs and features will verify if SU is installed.  Do you use a registry cleaner, such as CCcleaner?

The other log in pf(x86) is normal.

normal.PNG

 

  Open a new post about SU failure. RNR does not use SU at all.  

==

You requested a restore from a RNR backup.  Was this request from the windows RNR or via PF11 standalone RNR?

My view backups on windows RNR shows:

view backups.PNG

When you order up a restore from windows RNR,it will reboot to standalone RNR with a reorder file.

If the USB is not connected for any reason, the reorder will fail.

Try the restore from USB, using standalone RNR. If standalone RNR cannot find the USB it will tell you or not offer it at all. The windows RNR runs off of registry entries.  Standalone runs off the actual /rrbackups folder on device, if found (USB),

Paper Tape
Posts: 4
Registered: ‎05-08-2015
Location: United Kingdom
Message 5 of 9 (2,941 Views)

Re: Rescue & Recovery cannot restore from backup files it finds when starting

[ Edited ]

I set out a summary of the current position and additional information I have derived from work on this problem. I am still seeking a solution to the problem, as the backup I am trying to restore contains reference material and work products from the last 40 years. I have retrieved approx 16% of data from the system backup. In addition I want to have a backup capability moving forward, and at present I do not feel I can rely on Rescue and Recovery (R&R) as it is still presenting problems and apparently generating other issues.

Problem
1. I previously mentioned as part of the problem, that System Update appeared not to be working. I have resolved this issue by downloading and installing the latest version of System Update.

2. The problem I had was that having restored the system to factory defaults, I attempted to restore a backup of my system from an external USB drive. Entering R&R from Windows shows me the backups on the drive; allows me to select backups, and request a restore. R&R then reboots into the R&R workspace, and at this point apparently loses sight of the USB drive. It reports there are no backups available, and does not list the USB drive as an avaialable resource.

3. The current position is that R&R will recognise, from within Windows, drive Backup, and allow me to select individual files to restore. It then does not reboot into its own workspace, and starts recovering files. This is a very slow process, currently running, and takes about 1 hour for each 2% (of the 15%) of files recovered - at this rate a full system restore will take about 30 days of continuous running to complete.

System setup
1. My machine had HDD and a CD/DVD reader/writer on purchase. The HDD, with a main partition (C:\) labelled Windows7_OS, also has a recovery partition Q:\, labelled Lenovo_recovery.
2. I replaced the CD/DVD writer with a second hard disk, (D:\) which was initially labelled New Drive, and later renamed 2nd System Drive. I have retained the CD/DVD and have used it in the work described below.
3. I have an external USB CD/DVD writer. I have a number of restore disks, most of which are Windown boot discs, but one is a R&R recovery disc. Unfortuately I have labelled them all the same, so it is a chore to find out which is which.
4. The drive with my backups on it, labelled Backup (F: usually), has a full backup of my system (both drives C:\ and D:\) on it held within R&R. It also has R&R recovery media on it. It also has a full Windows backup of my system, together with a windows boot disc. These latter are backups of the computer since I started the recovery work.
5. I have two additional drives, one a USB external drive (E:\) labelled Media Backup; and one a IEEE 1394 external drive (G:\) labelled FreeAgent Drive. These are not relevant at all to the problem, or attempted solutions, but are significant only because their presence or absence can change the drive mappings. They both contain copies of data files, mostly, but not exclusively from post the R&R problem.

Problem and Solution History
1. Some time ago Windows backup and restore stopped working for reasons unknown and uninvestigated. R&R used to perform backups. No secondary backups taken, because they had been Windows backups.
2. Problems with a database with a duplicate record in it prompted some work involving changing drive labels (on 2nd System Drive) back to original name and back again. Somewhere in this process I managed to corrupt some aspect of the boot process - the system would boot, but not into a usable state. Most aspects of computer use were disabled, including mouse movements, some but not all keystrokes, shortcut keys, etc. I attempted to remedy the position by restoring factory defaults, and then restoring from my backups.
3. PROBLEM DETECTED.
4. Hardware solutions attempted:
a. Toggling the BIOS setting which provides power to USB ports to both possible settings, and attempting to reboot into the R&R workspace.
b. Attempting to boot from:
Windows7_OS
Backup (uncertain as to whether it actually booted from this drive)
Internal DVD Drive
USB DVD Drive
c. Ditto b, but first changing the boot order in BIOS to put the appropriate drive first in the boot order.
d. Ditto c, but removing all alternative devices from the boot list order.
None of these measures made any difference to the problem.
5. Started rebuilding and reconfiguring the system. Installed some software programs lost in the Factory Default restore. Downloading Windows updates, and backing up what data was available from 2nd System Drive.
6. Latest version of Lenovo tools, System Update and R&R, downloaded and installed. System Update now working. Lenovo updates applied. Further Microsoft and Lenovo updates downloaded and installed.
7. Incidental problem found:
a. Intel driver update for Intel(R) Centrino(R) Advanced-N 6200 AGN refuses to install in spite of multiple attempts. Each attempt left the machine in a state which was not usable, and needed a restore to a system restore point.
b. In installing latest version of R&R received the following warning:
"This program has detected that you have two disc drives installed. This version will only back up drive c: Use another tool (Windows recovery) to back up your second drive."
c: Download of the Lenovo tools and running Lenove update resulted in installation of surplus programs that are actively getting in the way of investigating drive access problems: Reachit and Shareit. In addition there was a (mostly harmless) installation of Solution Centre, without a corresponding removal of Think Vantage toolbox.
8. Attempting to create recovery media on CD-R with R&R gave the error message (repeatedly): Something like "Could not write to disc; disc may be unusable; please try with another disc". Subsequent attempts to create recovery media led to message:
Resources needed by this application are already in use: Pleae retry after the other application completes. This was on system start, with only system bootup spplications running. There were obviously some effects from this as the Snipping Tool (attempting to capture error messages) seemed to focus on drive D:\ and was refusing to write images it had captured. System restore points used to unravel the issue.
9. Running R&R from within Windows no longer reboots into its own workspace if I select "restore individual files". It runs and is recovering files. This is currently running and is the basis for my time estimates above.

Bit Torrent
Posts: 3,465
Registered: ‎11-22-2011
Location: US
Message 6 of 9 (2,895 Views)

Re: Rescue & Recovery cannot restore from backup files it finds when starting

A lot of issues going on.  Many Lenovo post address each issue. Intel, System update, create Recovery media to USB.

For now, I will address your rescue and recovery issues. It seems your system was running fine, until a database had duplicate records in it, and you wanted to use RNR to restore to a backup on your USB. 

 

Then you tried a factory recovery, which show many issues.

 

If I understand your request, you want to restore your system to some time in the past, using a RNR backup. Be it last week or 2 months ago. Something that works.

=== 

RNR will back up all partitions on the C drive HDD.  It will never backup another HDD.  The 2 drives warning has been around for a while. If C and D were on the C drive HDD, it will work via RNR.

 

Single file restore runs on the windows RNR only.  It does not need to reboot into standalone RNR, (pf11 at boot time).

This is good. At least the RNR version on windows can find and restore from your USB /rrbackups, 5 min or 30 hours. It works.

==

Restoring to factory installs a RNR version at that time. That version probably does not match the version on your USB. If you booted factory version RNR with USB version, you could expect not found messages.

===

On your windows system today, please state the version installed.  Boot via pf11, and state the version installed.

You cannot create recovery media and rescue media on the same device. Your lucky if anything boots on the USB (other posts),

 

For the most part, the standaone version of RNR must match the /rrbackups on USB.  

=

How did you restore to factory defaults? pf11 via rnr workspace or external cd/dvd?

Are you the origional owner of the machine?

   

Bit Torrent
Posts: 3,465
Registered: ‎11-22-2011
Location: US
Message 7 of 9 (2,874 Views)

Re: Rescue & Recovery cannot restore from backup files it finds when starting

I ran across this in the RNR release notes.

 

Consideration 34
----------------
The USB 3.0 driver automatically installed to your computer when you launch the Rescue and Recovery program for the first time might not be compatible with the PDA. Therefore, the USB 3.0 connectors might not work in the PDA.
To restore your operating system from an external USB device where you have backed up the operating system, connect the device to a USB 2.0 connector in the PDA first.

Paper Tape
Posts: 4
Registered: ‎05-08-2015
Location: United Kingdom
Message 8 of 9 (2,858 Views)

Re: Rescue

Thanks to pointers and responses from @sclexman I have now sorted out
the problem. Until his first post I was unaware that there were two
versions of R&R, and even after this, initially I was under the
impression that one version was the Windows version, and the second
version was the R&R workspace that the Windows version booted into. This
is not the case. In addition I have done, or attempted to do a number of
things he says are not possible. I had backed up both C: and D:
(separate hard discs) to the R&R backup. In addition I had attempted to
create recovery media and rescue media onto the same device.

The steps I had to go through to resolve this case were:
1. Download and install all Windows updates available after date
appllicable to Factory Reset.
2. Download and install the latest version of Rescue & Recovery.
3. Create a R&R recovery disc on CD/DVD using the latest R&R.
4. Boot from the recovery disc, ensuring that the CD/DVD is the first
boot device.
5. During bootup press the ThinkVantage button to boot into the
standalone R&R.
6. Perform R&R from the standalone version, recover complete system from
USB HDD.

A simple process in the end, but I have been through many byways,
problems and issues before finding the information needed to resolve
this major problem.

Bit Torrent
Posts: 3,465
Registered: ‎11-22-2011
Location: US
Message 9 of 9 (2,839 Views)

Re: Rescue

[ Edited ]

Glad you were able to get your system restored from a RNR backup on the USB.  Goiing backup  to a factory restore just made the issues worse.  Taking a factory restore current has many issues, which you have documented.

FYI:

 RNR is composed of two components.  Rescue relates to restoring your system from a backup in /rrbackups folder.

Recovery relates to resetting your system back to factory ship.

 

Rescue and recovery workspace.  I call it standalone RNR, it is also known as PDA - predesktop area.

It is located in SYS_drv on Lenovo shipped systems.  It can be located on the C drive, if RNR is installed on non-Lenovo shipped system. You can access standalone RNR via PF11 at boot up time.  On certain machines, you can access it via the blue Thinkvantage button (which will reboot the system like PF11).

You can also run create RESCUE media, which you did, creating a bootable PDA. 

 

During a RNR install, it will update the windows platform AND it will update the PDA.(Inside SYS_drv, or standalone RNR folder(s) on C drive.

I have RNR 4.52.0017 installed.

Windows RNR shows:  4.52.0017.00

PDA rnr shows           :  4.50.1017.00    <<<<This is a bug It should say 4.52.1017.00 

0017 is windows, 1017 is pda  The package internal name is Z939ZAB1017US00.TVT 

Look in Swtools/readyapps/RNR folder for the internal name. Bottom line, pda is displaying wrong version. 

==

In your situation, when you installed latest RNR, your PDA accessed via PF11 or Thinkvantage blue button should have found your backups on the USB.  My guess is the USB 2.0 vs USB 3.0 port issue.

You also created the PDA on a CD using the Create Rescue media.  This is exactly the same a what is inside the PDA on the C drive HDD.   If you booted PF11, or booted the CD both should have worked.

===

Recovery media is a separate system. You can create it on CD or USB .  It just boots up and erases the C drive HDD, add files, and reboots to do a factory recovery.

===

If you create Rescue media or recovery media on USB, you should DOS clean the usb, set the partition active, then proceed.  If you do not clean, set partition active, the USB will NOT boot!!!

Create Rescue will add data to the USB, and try to make it bootable.  Then rrbackups can be taken.

If it wont boot, try using the PDA version via PF11 or Rescue CD, both will access rrbackups on USB.

Create Recovery will erase everything on the USB, and try to make it bootable. If it wont boot, it wont work.

Do not use a loved USB with data on it for create recovery.  (Other users found this out the hard way and not happy at all). It does give you a warning message, your USB will be erased.

===

If you have a Lenovo shipped system, the factory recovery system is inside the (Q) drive.  You would boot into the PDA.  Standalone RNR will run.  You would request a system restore.  If standalone RNR finds the Q drive, it will also offer a Factory recovery.

==

http://support.lenovo.com/us/en/documents/ht002724

 

My experience with my USB-HDD: Until I did the dos commands in the above article, Create Rescue would run, but not boot.  I have a desktop machine and only USB 2.0 ports.

 

Top kudoed Authors