Showing results for 
Search instead for 
Do you mean 
Blue Screen Again
Posts: 4
Registered: ‎07-21-2010
Location: Norway
Message 1 of 8 (6,008 Views)

Rescue and recovery do not recognize backup un USB disk



I am trying to restore files from a backup on a USB drive, but the recovery program does not show any backups on the drive. Is there anything to do about this?


A bit more background: A few weeks ago I started a full backup to a USB disk. This was the first backup I did to that particular disk. Next morning the laptop was constantly rebooting, reaching a blue screen, and rebooting again.


I was going away for a while, and did not have time to do more than swear, grab the laptop, and go to the airport. While away I got help to identify some bad sectors on the drive, and did a factory reinstall from the recovery partition so I could use the computer on my trip.


Now that I try to get files from that last backup I did, the Rescue and Recovery system does not show any files on the USB disk in question. Looking at the disk in Explorer there is a folder called "RRBackups\C\O\" which contains about 70 GB of files named data0, data1 and so on. I don't know if the backup had time to complete before the blue-screen thing manifested - but based on the amount of disk space used by the backup at least most of my files are in that backup. If only I could access them ...


Does anybody have any suggestions?


Oh, and this is an R61, running Windows XP.

Retired SuperMod
Posts: 9,293
Registered: ‎11-27-2007
Location: SK
Message 2 of 8 (6,006 Views)

Re: Rescue and recovery do not recognize backup un USB disk

[ Edited ]

pnahoj, welcome to the forum,


had you updated R&R at some point before you ran the backup? It may be possible that your backup was made with a newer version than the one that is now loaded.


Are you attaching the usb drive before booting or hot plugging it? Ensure it is attached before booting; my experience says this works, hot plugging doesn't.




Please remember to come back and mark the post that you feel solved your question as the solution, it earns the member + points

Did you find a post helpfull? You can thank the member by clicking on the star to the left awarding them Kudos

Please add your type, model number and OS to your signature, it helps to help you.

Forum Search Option

T430 2347-G7U W8 x64, Yoga 10 HD+, Tablet 1838-2BG, T61p 6460-67G W7 x64, T43p 2668-G2G XP, T23 2647-9LG XP, plus a few more.

FYI Unsolicited Personal Messages will be ignored.

de.gif  Deutsche Community   es.gif  Comunidad en Español  uk.gif  English Community ru.gif Русскоязычное Сообщество

PepperonI blog 

Blue Screen Again
Posts: 4
Registered: ‎07-21-2010
Location: Norway
Message 3 of 8 (5,986 Views)

Re: Rescue and recovery do not recognize backup un USB disk

I don't remember ever updating R&R previously. Just to make sure I updated it now, and it didn't help. (The ThinkVantage System Update log says I have installed "ThinkVantage Rescue and Recovery Update" version 4.10.0214.00 and "Rescue and Recovery patch to optimize space allocation of backups" version 1.3.)


I've tried both plugging the drive in before booting, and while the machine is up, with no difference.



Punch Card
Posts: 29
Registered: ‎08-01-2009
Location: Australia
Message 4 of 8 (5,911 Views)

Re: Rescue and recovery do not recognize backup un USB disk

Hi pnahoj,


As per my suggestion to Dino in a previous post, here is a link to all versions of R&R you might like to try. You may have used a different version for backup to the one that is now on your system. I don't think R&R is very backward compatible. 


All the bes;t, hopefully you can get your files back.

Blue Screen Again
Posts: 4
Registered: ‎07-21-2010
Location: Norway
Message 5 of 8 (5,905 Views)

Re: Rescue and recovery do not recognize backup un USB disk



Thank you for the tip, Candive. I guess I should try all the old versions.


I think it's rather odd if R&R is not backward-compatible, though. I can understand that there might be issues with forward compatibility, i.e. that backups made with a new version can be unreadable with old software. But then I should be fine with the newest version. Lack of compatibility the other way, that old backups becomes unreadable with an update of the backup software, is something that will cause issues for a lot of users and which also should be easy to avoid. I doubt Lenovo would make an error like that.


And I think I have found that my problem is something else, and I fear that I will have to bite the dust in this case.


I did another backup and checked what files it generates. In this successful backup directory, there are three files named HashFile, Info and TOCFile that have "last modified"-timestamps as the time when the backup finished.

The directory that is not recognized have the same files, but the "last modified"-stamp is the time the backup was started.

I guess these files contain metadata about the backup, and that R&R writes the final version of the files only after the copying is complete. And it appears that in my case the laptop crashed before the backup completed and the metadata-files got written out, and therefore the backup is worthless.



Punch Card
Posts: 29
Registered: ‎08-01-2009
Location: Australia
Message 6 of 8 (5,875 Views)

Re: Rescue and recovery do not recognize backup un USB disk

Hi pnahoj,


I agree with you regarding backward compatibility. Newer versions of R&R should be backward compatible. Your response is logical and sound.  I personally have not tested the compatibility of the different versions of R&R but based on the posts by DINO and Herik ; they suggest this is not the case.


Sorry to hear that the backup was incomplete. It just demonstrates how important this process is; if not the most important process when it comes to computers. Hardware can be replaced; data, not necessarily so...


All the best!

Blue Screen Again
Posts: 1
Registered: ‎01-17-2011
Message 7 of 8 (5,208 Views)

Re: Rescue and recovery do not recognize backup un USB disk

I too had problems with getting to a RR backup on a USB drive. With a lot of luck, I managed to recover my files though; although I don't quite understand what happened, I hope it might help someone in a similar situation.


I am now using Rescue and Recovery v. 4.31 on Windows 7 on R400.


First I made a full backup from Windows XP and then installed Windows 7 (I wanted a clean install, so I formatted the disk in the process.) I expected to be able to either open the backup in the new OS and recover particular files, but that was not the case. Also I couldn't boot into the RR environment. After a lot of googling, I was rather desparate and basically by mistake hit the "Back up now" button in the simplified RR - I had previously set the back up location to the USB hard drive.


I hit cancel almost immediately, but the progress bar would remain on the screen for a while - and then RR showed that it was copying files into "preboot" folder on the USB drive. I figured out that it might be possible to boot from the USB drive, so that was the next thing I did.


(It took me a while to make the laptop boot from the USB drive - I reckon the problem was it wouldn't be fully on by the time the system was searching for boot locations. I had to somehow enter the BIOS, change the boot order and save and exit so that the computer wouldn't completely shut down and the USB drive would remain on)


I succesfully booted from the USB drive (at least I believe so, I don't think I would somehow magically boot from the hard drive, the boot order was changed. Plus I think the problem with the hard drive RR boot is caused by the MBR problem referred to at caused by migrating from XP to 7).


Don't get confused by the fact it will show "Windows loading files ... starting Windows...", you will boot into RR4 environment.



- go to advanced RR

- check "rescue files" - you won't be able to see your backup there

- go to "restore your system"

- choose "restore my entire hard drive"

- when asked to locate your backup, tick "list all the backups created for other systems" and find yours on the USB drive - only view it in the list, don't continue with this process, press cancel

- go back to "rescue files" et voila! the backup is suddenly there


I have now successfully recovered most of my documents, I am going to recover some 80 GB left of music and pictures now.


I hope this will help and sorry for the post not being very concise. I believe this is a very weird procedure... I wasn't able to find the "list all the backups created for other systems" option in the RR when in Windows. I took pictures of the procedure with my camera as I was obviously not able to take any screenshots. Let me know if you would like me to post them.

Paper Tape
Posts: 1
Registered: ‎02-10-2011
Location: UK
Message 8 of 8 (5,068 Views)

Re: Rescue and recovery do not recognize backup un USB disk

I can confirm that the Lenovo Rescue and Recovery is not version compatible.


I have a USB drive which has RR backups from an R61 running Vista and R50p running XP.


When I try to add an RR from an N500 running Vista SP1, it takes about 2 hours to run showing the backup progress and showing the USB activity light.


At the end of the backup, the Lenovo Rescue and Recovery does not show the backup in the backups list.


Maybe I am being too optomistic expecting to hold backups from more than one Lenovo on the same USB drive.


I thought I would never say this, but the Windows backup and restore looks to be the better bet to have valid backups in my one USB drive scenario.


I don't want to have to buy a separate USB dive for each laptop.


Anybody else tried to do what I am trying to do?








Top kudoed Authors