cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
errrozz_-_-
Paper Tape
Posts: 4
Location: Australia
Views: 5,329
Message 1 of 19

System Update not working on Windows 8

Hello,

 

When I launch System Update 5.03.0008 I can see the application's icon in the system's task bar but the application itself doesn't show up. If I right-click the icon and select Close I can see the normal System Update message window asking if I'm sure I want to quit.

 

I tried uninstalling (including deleting the remnants from Program Files directory) and reinstalling the software but to no avail.

 

It worked for some time on this system but now it's broken.

 

How can I fix this issue?

 

Thanks in advance.

 

errrozz_-_-
Paper Tape
Posts: 4
Location: Australia
Views: 5,264
Message 2 of 19

Screenshot

Hi, if anyone could share their thoughts that would be great, thanks.

 

This is a screenshot of my issue:

 

Link to image

 

What you see here is what happens after I launch System Update and then right-click the task bar icon to close.

As you can see the System Update window is visible using the application preview funcion in Windows (hover mouse over task bar icon) however the window itself isn't visible, only the Are You Sure message box is visibile.

 

Hope this helps troubleshooting this issue.

 

Moderator note: images totalling more than 50k converted to links per forum rules:  Lenovo Community Participation Rules

sclexman
Bit Torrent
Posts: 3,897
Location: US
Views: 5,205
Message 3 of 19

Re: Screenshot

Look in C:\program files(x86)\Lenovo\System Update\logs\tsvu_log_*****timestamp***.txt.

Post the last 100 lines of this log.  This log is not easy to decipher.  It appears your SU got stuck It got past the splash screen and got to the WELCOME TO SU primary panel, which is in the task icon bar, but not visible on your desktop.  

 

Side Note: when my SU primary panel displays, it will not minimize if i click the Icon in the taskbar.  It will mimimize if i use the minus sign on the primary panel. I am running 5.3.008 on win7.

==

You state: I tried uninstalling (including deleting the remnants from Program Files directory) and reinstalling the software but to no avail

 

Did you have a previous version  of SU on your system prior to 5.3.0008? If so, what release was it? Did you uninstall via control panel, -or- did you launch SU, and it said new release available and it offered to do the install.

You should not have had to delete remenants (file folders) manually.  Sounds like the unistall of old version did not work correctly.

 

Check out the following link and the one embedded within it:

http://forums.lenovo.com/t5/ThinkVantage-Technologies/Can-t-re-install-System-Update-5-0-3-Always-ge...

 

This involves a problem during  SU uninstall, which leaves the SU service installed in windows services pointing to a blank folder.   The workaround is to delete SU service,then install new SU.  This may or may not be your situation.

ScottChapman
Paper Tape
Posts: 54
Location: United States
Views: 5,143
Message 4 of 19

Re: Screenshot

Yup. Have the same problem with latest SU. here's my log, all looks good. by all indications I should be seeing the dialog on my screen, but it just isn't there. rebooted, reinstalled no luck...

 

[Lenovo System Update build: 2013-10-31 5.03.0008] 12/22/2013 10:47:55 AM

Info 2013-12-22 , 10:47:55
at Tvsu.Environment.EnvironmentManager..ctor()
Message: Starting Environment Manager...

Info 2013-12-22 , 10:47:55
at Tvsu.Nls.NlsResources..ctor()
Message: Starting the instance of NLS@Runtime

Info 2013-12-22 , 10:47:55
at Tvsu.Nls.NlsResources..ctor()
Message:
The active language is: EN
The default language is: EN
The OS language is: EN
The language loaded type is: OS

Severe 2013-12-22 , 10:47:55
at Tvsu.Sdk.SuSdk.StartApplication()
Message: Application runs with the framework: 4.0.30319.1008

Info 2013-12-22 , 10:47:55
at Tvsu.Engine.DataBase.InitializeDataBase()
Message: Initializing the DataBase from file: updates.ser

Info 2013-12-22 , 10:47:55
at Tvsu.Sdk.SuSdk.StartApplication()
Message: Starting the Application

Info 2013-12-22 , 10:47:55
at Tvsukernel.Logic.GUIController.StartGUI(Boolean showsplash)
Message: Starting GUI...

Info 2013-12-22 , 10:47:56
at Tvsukernel.Logic.GUIController.StartGUI(Boolean showsplash)
Message: MainFrame created successfully

Info 2013-12-22 , 10:47:56
at Tvsukernel.Logic.GUIController.StartGUI(Boolean showsplash)
Message: GUI -- Welcome screen

Info 2013-12-22 , 10:47:56
at Tvsukernel.Logic.GUIController.BackToMain()
Message: Setting Welcome screen...

Info 2013-12-22 , 10:47:56
at Tvsukernel.FlowScreens.MainFrame.SetScreen(String screen, RoutedEventHandler[] eh)
Message: Loading Welcome screen on Action pane.

ScottChapman
Paper Tape
Posts: 54
Location: United States
Views: 5,134
Message 5 of 19

Re: Screenshot

Just a quick update, I am running Windows 7 pro 64-bit

sclexman
Bit Torrent
Posts: 3,897
Location: US
Views: 5,125
Message 6 of 19

Re: Screenshot

The next few lines should state:

Info 2013-12-15 , 09:36:20  at Tvsukernel.FlowScreens.MainFrame.SetScreen(String screen, RoutedEventHandler[] eh)  Message: Loading Welcome screen on Action pane.

Info 2013-12-15 , 09:36:26  at Tvsukernel.Logic.GUIController.SearchUpdates(Object sender, EventArgs args)  Message: Starting the Search process...

Info 2013-12-15 , 09:36:27  at Tvsukernel.FlowScreens.MainFrame.SetScreen(String screen, RoutedEventHandler[] eh)  Message: Loading Search screen on Action pane.

Info 2013-12-15 , 09:36:27  at Tvsukernel.Logic.ProgressThread.InitSearch()  Message: GUI -- Reporting progress for the Search

Info 2013-12-15 , 09:36:27  at Tvsu.Sdk.SuSdk.GetSystemProperties()  Message: Get the System Properties

Info 2013-12-15 , 09:36:27  at Tvsu.Engine.Task.Task.StartExecution()  Message: PreTask

Info 2013-12-15 , 09:36:27  at Tvsu.Engine.Task.Task.StartExecution()  Message: Start

Info 2013-12-15 , 09:36:27  at Tvsu.Engine.Task.Task.Start()  Message: Starting the task

Info 2013-12-15 , 09:36:27  at Tvsu.Engine.Task.Task.Start()  Message: The current process is:HelloProcess

Info 2013-12-15 , 09:36:27  at Tvsu.Engine.Task.Task.Start()  Message: Executing the PreProcess HelloProcess

Info 2013-12-15 , 09:36:27  at Tvsu.Engine.Task.Task.Start()  Message: Executing the StartProcess HelloProcess

==

It is trying to access the internet to find a Lenovo server to find updates.  Check your a/v software to make sure SU can access the internet. Also, control panel, admin tools, services.  Check for an entry titled System Update. Do properties on this task to make sure the Path to executable exists. (this is an uninstall issue with older SU versions). If the path is blank or non existent, delete the service, and uninstall/reinstall SU.  I can give you a link to this SU delete process.

ScottChapman
Paper Tape
Posts: 54
Location: United States
Views: 5,111
Message 7 of 19

Re: Screenshot

I am definately on the network, and if I hover my mouse over the icon in my toolbar it shows a mini-image of the window. I just can't actually see the real one...

ScottChapman
Paper Tape
Posts: 54
Location: United States
Views: 5,105
Message 8 of 19

Re: Screenshot

Tried uninstalling my Symantec AV software, no difference.

tblackburn
What's DOS?
Posts: 2
Location: Denver
Views: 5,083
Message 9 of 19

Re: Screenshot

FYI, I have the exact same issue with Windows 8.1 as described by "ScottChapman". I upgraded from Windows 8 and System Update was working fine prior to the update. I've uninstalled every single Lenovo or ThinkVantage software and tried uninstalling/reinstalling System Update many, many times.

 

System Update starts but I can't see the window. My only option is to right-click the icon in the taskbar and "close".

 

I have been looking for a solution for months now. I upgraded to Windows 8.1 back in October and System Update has not worked since that point.

errrozz_-_-
Paper Tape
Posts: 4
Location: Australia
Views: 5,053
Message 10 of 19

Glad I'm not the only one having this issue.   I had a lo...

Glad I'm not the only one having this issue.

 

I had a look at my log and it doesn't seem to contain much info. There are only Info messages there. So I decided to launch the application and see if that would get anything interesting to appear in the log. To my surprise the application simply worked! What in the name...???

 

Top Kudoed Authors