Showing results for 
Search instead for 
Do you mean 
Blue Screen Again
Posts: 7
Registered: ‎10-21-2009
Location: UK
Message 1 of 4 (8,069 Views)

T61 Lenovo Rescue and Recovery BSOD



I've got a problem booting into the Lenovo Rescue and Recovery partition.


System is a T61 (64665DG) with Rescue and Recovery 4.21.1016.00


I receive the following BSOD message:

A problem has been detected and windows has been shut down to prevent damage.

If this is the first time you've seen this Stop error screen, restart your computer. If this screen appears again, follow these steps:

Check for viruses on your computer. Remove any newly installed hard drives or hard drive controllers. Check your hard drive to make sure it is properly configured and terminated. Run CHKDSK /F to check for hard drive corruption, and then restart your computer.

Technical information:

***STOP: 0x0000007B (0xF78D6528,0xC0000034,0x00000000,0x00000000)

It seems to be a problem with the AHCI controller not being supported. When I switch the SATA Controller Mode from AHCI to Compatibility in the BIOS it then successfully boots into the Rescue and Recovery environment.


Why is it missing the correct AHCI driver? It used to work fine with the older version of Rescue and Recovery in AHCI mode. Is there a fix available for the Rescue and Recovery software to allow you to run it without having to put the SATA controller in AHCI mode?



Blue Screen Again
Posts: 2
Registered: ‎07-22-2008
Location: Athens - Greece
Message 2 of 4 (8,037 Views)

Re: T61 Lenovo Rescue and Recovery BSOD


I have the same problem.

When i bought my Lenovo T61p the SATA Controller Mode is set to ACHI.

When i went to reset to factory defaults for first time i couldn't. As i wrote in article  change this value to compatible and i was able to reset to factory defaults my Lenovo from R&R. After that i didn't change this value to AHCI. I use my laptop from then with all updates. Lenovo & Windows updates.

Now, when i try to select AHCI mode i recieve the same BSOD message with indie.

My problem is exactly that i cannot boot neither the OS. (WIN XP)

When i change the value to Compatibility i can boot the OS but i cannot boot in the R&R session.

To do that i use Create Recovery Media.



Lenovo T61p ThinkPad - Quadro FX 570M - 4GB Ram - Intel C2D T7500
Retired Moderator
Posts: 3,220
Registered: ‎07-31-2008
Location: Pakistan
Message 3 of 4 (8,025 Views)

Re: T61 Lenovo Rescue and Recovery BSOD

Maybe you guys are missing this driver:- Be sure to read quite a long instructions given below download link.


Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Blue Screen Again
Posts: 7
Registered: ‎10-21-2009
Location: UK
Message 4 of 4 (7,993 Views)

Re: T61 Lenovo Rescue and Recovery BSOD (solved)

Thanks both for your replies. The inability for it to boot the Rescue and Recovery partition in AHCI mode persuaded me to examine the contents of the partition for anything obvious amiss. Using Linux I was able to mount the FAT partition and have a nose around. In the /minint/system32 directory it's got a number of sub-directories for the Intel Iastor driver - that used to access the HD in AHCI mode. I couldn't find any reference to that in txtsetup.sif and the winpeoem.sif file was empty. After some Googling I found out that you can easily load additional mass storage drivers using winpeoem.sif.


IBM have a program called rrutil.exe that allows you to access the RnR partition from within Windows, it's part of the Rescue and Recovery Administrator Tools.


To modify winpeoem.sif first install the RnR admin tools and open a command prompt window in the install location - C:\SWTOOLS\TOOLS\Z652_Admin016. Make sure the C:\Temp directory exists and is EMPTY - this is very important. You then need to create a "getlist.txt" file:

echo \minint\system32\winpeoem.sif > getlist.txt

retrieve the file from the RnR partition

rrutil.exe -g getlist.txt C:\Temp


notepad C:\Temp\minint\system32\winpeoem.sif

and paste in

signature="$Windows NT$"


 upload the changes with (this will write everything from Temp to the RnR partition!)

rrutil.exe -p C:\Temp

Or you could just modify /minint/system32/winpeoem.sif directly in Linux without messing about with the rrutil.exe.


With this small modification to winpeoem.sif I was able to successfully boot into the Lenovo Rescue and Recovery partition with AHCI mode enabled. I haven't tried reinstalling windows xp with this fix.



Top kudoed Authors