Showing results for 
Search instead for 
Did you mean: 
Paper Tape
Posts: 1
Registered: ‎01-31-2009
Location: United States
Views: 2,964
Message 1 of 5

TVSU terminates abnormally (31-Jan-09)

Two days or so ThinkPad System Update 3.14 was running.  Today it is not.  It errors during the splash screen (almost immediately) with a Windows error dialog box (I can't attach a JPEG, so I typed it out):


Window Title: Microsoft Visual C++ Runtime Library[X in red circle] Runtime Error!
Program C:\Program Files\Lenovo\System Update\tvsu.exe
The application has requested the Runtime to terminate in an
unusual way.
Please contact the application support team for more information

This is a Windows Vista Ultimate T61, fully updated (Windows and Lenovo) as of a day or so ago, and now it is malfunctioning. 


Separately and distinctly, this happened several months ago on an R40 and I never fixed it.  When I first discovered that problem, I tried deleting TVSU and reinstalling, but on that computer it behaved as before. 

Community Moderator
Community Moderator
Posts: 3,913
Registered: ‎01-05-2008
Location: DE
Views: 2,926
Message 2 of 5

Re: TVSU terminates abnormally (31-Jan-09)

Hello Hilfenmir,



it might be a problem with some software installed on your system. The same behavior on two different models, seems strange.

Also the two day´s running TVSU aim to this conclusion.

Please check your installed software, MS updates and NET Versions.


@LenovoForums on Twitter!
Try the forum search, before first posting: Forum Search Option
Please insert your type, model (not S/N) number and used OS in your posts.
I´m a volunteer here using ThinkPad X1 Carbon 5th Gen. Silver Edition, ThinkPad 13, Yoga 900, ThinkPad T430s, IdeaCentre B540.
TIP: If your computer runs satisfactorily now, it may not be necessary to update the system.

English English Community      Deutsche Deutsche Community      Español Comunidad en Español

Posts: 351
Registered: ‎10-19-2008
Location: US
Views: 2,433
Message 3 of 5

Re: TVSU terminates abnormally (31-Jan-09)

I'm now having the same problem w/ my 2757-cto and a fresh, clean install of Win7 x64 Pro. (W700, 17" Screen, Nvidia 3700, 4 GB, Q9300 CPU, Bluray Disk, Dual Hitachi HTS72050A9A364 500 GB drives, Fingerprint Reader, Color Calibrator.)


The system reports that .NET 3.51 is installed and active. 


I've tried the following, to no avail:


1)  Downloaded and installed C++ runtime for x64 systems.

2)  Downloaded and installed C++ runtime for x86 systems.

3)  Tried to install .NET executable packages from Microsoft, but they wouldn't not install -- 3.51 already present.

4)  Manually downloaded and installed Lenovo System Manager and most of the other patches, then tried tvsu.

5)  Tried to used Lenovo's PC Doctor to obtain and install tvsu, but it points to the 3.14 version (which won't install).

6)  Updated BIOS to 2.09-1.07


Nothing helps.


On the same system with a different boot disk containing a triple boot of Vista x64, Win 7 x32 and Win7 x64, tvsu had no problems when booted to any of the OSs.


Needless to say, this is most frustrating!  Any assistance would be gratefully appreciated.


Thanks all.





P70, Xeon 1505 CPU, 64 GB ECC RAM, Samsung 970 Pro 1 TB + 512 GB NVMe Drives, 1 TB HDD, DVD-RW, 4 K Display, NVIDIA Quadro M4000
W700 model 2757-CTO (8 GB RAM, Crucial MX-100 SSD + Hitachi TravelStar 1 TB 7200 RPM Drives, Bluray R/W, NVIDIA Quadro FX3700M, WUXGA); Windows 7 Ultimate SP-1, W700 Mini-Dock
Former Employee
Posts: 1,591
Registered: ‎07-17-2009
Location: Slovakia
Views: 2,405
Message 4 of 5

Re: TVSU terminates abnormally (31-Jan-09)


I can only agree with "Agotthelf", as I have experienced such situation in the past and it was in my situation an AV software, that was blocking all applicaitons, that requested internet access.

Maybe you can try to uninstall TVSU, make sure that also it's deleted from %programfiles% and then install it back.

Let us know your results.



Serial Port
Posts: 61
Registered: ‎12-18-2008
Location: Pittsburgh
Views: 2,284
Message 5 of 5

Re: TVSU terminates abnormally (31-Jan-09)

I also had this problem recently.I installed Windows 7 few days ago and TVSU worked fine at that time. After few days of using and installing new software, TVSU is dead now.

I tried installed TVSU again without success.

x200 Tablet, 4GB RAM, Pen/Hand Touch Screen
Windows 7 Pro x64

Check out current deals!

Shop current deals

Top Kudoed Authors