Showing results for 
Search instead for 
Do you mean 
What's DOS?
Posts: 3
Registered: ‎04-05-2008
Location: Atlanta,GA
Message 1 of 4 (3,813 Views)

Unable to use System Update

I have tried using System Update several times, from the date the system was new and was unable to successfully update my system. The program connects and states that several updates are available and then I allow it ot download all the packages. However, it then fails on the install of each and every package.


I have tried reinstalling the application by downloading it from the lenovo site, but then that fails to properly install as well. I get a series of error messages that I have saved in a Word document with screen captures of the dialog boxes, but unfortuantely can not attach. Here are two fo the messages:


First: header: InstallUtil.exe Common Language Runtime Debugging Services

                        Application has generated an exception that could not be handled.


Process id=0xfcc (4044), Thread id=0xff8 (4088)


Click OK to terminate, cancel to debug the application


Last: header: System Update Installer Information


Error 1722: There is a problem with this WIndows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action StartSuService.EXE, location: ...\startsuservice.exe



There are a series of other messages in between, including a terminal window that opens up as part of the batch file/package and other exceptions are generated that could not be handled with different process and thread ids.


I do hope someone can help. I have tried removing, rebooting and then reinstalling the application and each and every time this is what I get.


Please help!

Paper Tape
Posts: 1
Registered: ‎09-08-2008
Location: Malaysia
Message 2 of 4 (3,694 Views)

Re: Unable to use System Update

I am using Windows Vista on R61i. I got the same error as you. I uninstalled and installed the System Update but did not work. 

Out of chance, I am using Google's Chrome and it shows "Microsoft .NET status : Unable to determinewhich prompted me to check the version. In fact, I only have .NET Framework 1.1.

Strangely, using IE, it shows "Microsoft .NET status : Installed".


After I deleted the .NET Framework 1.1 and installed .NET Framework 3.5, it works ! 


Please try that out. 

What's DOS?
Posts: 1
Registered: ‎11-09-2008
Location: Virginia, USA
Message 3 of 4 (3,350 Views)

Re: Unable to use System Update

I had a similar problem with XP SP3..."Microsoft .NET status : Unable to determine" when on Lenovo site. I fixed it by going to Control Panel, Add/Remove Programs, finding .NET 2.0 SP1 and .NET 3.0 SP1, selecting each in turn, and selecting the "Change" button, which apparently reinstalls the .NET software from saved files on one's computer--no download necessary (and no install CD's required, either).


Hope this helps somebody else.

Paper Tape
Posts: 3
Registered: ‎04-20-2010
Location: Santa Monica
Message 4 of 4 (1,758 Views)

Re: Unable to use System Update

Just updated Dot Net to 3.5 SP1 and it the install finally worked.

Top kudoed Authors