Showing results for 
Search instead for 
Did you mean: 
What's DOS?
Posts: 1
Registered: ‎05-14-2019
Location: RO
Views: 384
Message 161 of 161

Re: Vantage has encountered a problem Windows 1809

@maxdurian wrote:

@vega109 wrote:

I upgrade to 1809 again and try the methods mentioned above to manual install the DeviceMetadata file into a folder in my leptop, but all in vain. No file extracted to folder except ec4d5fdd-aa12-400f-83e2-7b0ea6023eb7.devicemetadata-ms being copied to the DeviceMetadataStore folder.


Feel very frustrated.


Therefore, I rolled back to 1803 again and lenovo vantage ran smoothly.

vega-san, i think your case as the same with mine..

the metadata is not extracted. i think it is because dxpserver.exe /c is not working? it is stuck/hang? those install_metadata.bat will extract the "ms" file into a folder.

because the metadata folder is not created. I uninstalled the device from device manager. and that I think force the creation of new metadata (in 1809). I can use vantage then.

I suggest you to try the followings (worst case you still can go back to 1803 again hehe!)

1. backup your folder 1803 DeviceMetadataStore & DeviceMetadataCache (backup 1)

2. upgrade to 1809. again backup DeviceMetadataStore & DeviceMetadataCache (backup 2)

3. copy backup 1 to 1809 same folders

4. reboot.

5. run vantage.

some people works using this method.

if not work

1. delete all contents of DeviceMetadataStore & DeviceMetadataCache (1809) left the ones that you can not be deleted (two files only for me)

2. run sfc /scannow see if your windows file is ok

3. try again install devicemetadata (admin)

4. if able to install/extract..

5. run vantage.


if it is still not working...

4. if this is not extract folder.. (my case)

5. open device manager->system device->system interface foundation->uninstall device

6. reboot

7. run vantage. it will ask you to install.. so install the SIF

8. reboot

9. open device manager->system device->system interface foundation. makesure this here again/installed.

10. check if new folder is created in DeviceMetadataCache. if yes.. copy this folder to DeviceMetadataStore too.

12. reboot

13. run vantage. see if this work. (mine is ok here)


if still not work..

then 1803 is the best for you at this moment..



This worked for me also

Check out current deals!

Shop current deals

Top Kudoed Authors