cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bradrum
What's DOS?
Posts: 1
Registered: ‎11-30-2019
Location: DE
Views: 151
Message 1 of 3

P1 Gen Brightness not working in Linux

I can't set the brightness under hybrid mode graphics mode  in Fedora 31 and discrete graphics don't work at all.

 

I have UEFI firmware version 1.27,  I am running Fedora 31 with linux kernel version 5.3.12-300.fc31.x86_64. 

 

I compiled and installed the NVIDIA driver version 418.88 from their website and installed it per the instructions on this blog/site

https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/

 

I have also tried to install Ubuntu 19.10 with the same problem...no brightness controls.  

 

Is there any kind of an ETA on a fix for this issue?  I have seen other posts and just wanted chime in and say that I can't find a work around at all on linux.  My retinas hurt as I type this and I really can't use the display with full brightness. 

 

I have tried some work arounds like manually switching to the intel display profile and dimming the display using xrandr....and don't get very far as this seems to break when I turn on the night light mode.  It seems to ignore the xrandr settings when the laptop enters night mode.

 

Thanks

 

 

 

Highlighted
altendky
Fanfold Paper
Posts: 13
Registered: ‎11-13-2019
Location: US
Views: 112
Message 2 of 3

Re: P1 Gen Brightness not working in Linux

Akil-X
Paper Tape
Posts: 2
Registered: ‎12-04-2019
Location: IT
Views: 61
Message 3 of 3

Re: P1 Gen Brightness not working in Linux

Were you able to change the brightness in Fedora before the problem started? Or you simply installed Fedora and saw that you can't change the brightness?

Check out current deals!


Shop current deals