English Community

Datacenter Systems ManagementServer System Management
All Forum Topics
Options

3 Posts

05-04-2018

FI

4 Signins

46 Page Views

  • Posts: 3
  • Registered: ‎05-04-2018
  • Location: FI
  • Views: 46
  • Message 1 of 2

Patching esxi host with onecli

2018-05-04, 15:20 PM

Hi,

 

I am trying to patch SR630 host with esxi 6.5 with onecli but it seems to be rather tricky.

 

Everything else works except when I need to use --bmu switch, then I can't for the life of me figure out the correct syntax. Without --bmu switch I can apply updates, but that is needed for some of them.

 

I ran these commands:

 

./OneCli update acquire --mt 7x02 --ostype esxi6.5 --scope latest --dir /root/onecli/sr630/

 

./OneCli update compare --scope latest --bmc USERID:XXX@10.yy.yy.27 --esxi root:XXX@10.1yy.yy.27 --dir /root/onecli/sr630/

./OneCli update flash --esxi root:XXX@10.yy.yy.27 --comparexml /root/onecli/logs/OneCli-9295-20180504-164413/Onecli-update-compare.xml --bmc USERID:XXX@10.yy.yy.27 --sftp root:XXX@10.yy.yy.71:/root --dir /root/onecli/sr630/ -N --bmu --uselocalimg --output /tmp

 

And the result is

 

"Not found available OneCli in local dir
[ERROR]: Run preconfig failed!"

 

What does that error mean? It seems no matter what paths I try to use, it's always the same error. SFTP is reachable from port 6990.

Reply
Options

15 Posts

12-17-2017

GB

82 Signins

674 Page Views

  • Posts: 15
  • Registered: ‎12-17-2017
  • Location: GB
  • Views: 674
  • Message 2 of 2

Re: Patching esxi host with onecli

2018-05-08, 20:10 PM

Hello Jarnoa,

 

Thank you for posting on the forum.

 

Try to run the last command without

--dir

The --dir parameter is not used when the --comparexml parameter is specified

 

./OneCli update flash --esxi root:XXX@10.yy.yy.27 --comparexml /root/onecli/logs/OneCli-9295-20180504-164413/Onecli-update-compare.xml --bmc USERID:XXX@10.yy.yy.27 --sftp root:XXX@10.yy.yy.71 -N --bmu --uselocalimg --output /tmp

Please mark the question as answered if this helps.

 

Thank you.

I wish you a good day.

Please if my reply answer your question mark the thread as Solved.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete