English Community

Datacenter Systems ManagementServer System Management
All Forum Topics
Options

5 Posts

04-09-2019

IT

13 Signins

100 Page Views

  • Posts: 5
  • Registered: ‎04-09-2019
  • Location: IT
  • Views: 100
  • Message 1 of 10

System x3650 M3 7945 IMM does not send alert emails

2019-04-09, 12:55 PM

Hi all,

my System x3650 M3 7945 IMM does not send emails alerts.

My configuration is (I've tested it on a D-link network NAS and it is correct!):

 

 

When I click GENERATE TEST ALERT i see the Event Log event ID:

 

Index Sev Source Date/Time Call Home Event ID Text1
I
04/09/2019; 14:49:330x4000002800000000Management Controller Test Alert Generated by myname

 

BUT NOTHING HAPPENS! No emails were sent!

Can smeone help me?

Thank you.

Giorgio

Reply
Options

124 Posts

08-24-2016

CN

338 Signins

3245 Page Views

  • Posts: 124
  • Registered: ‎08-24-2016
  • Location: CN
  • Views: 3245
  • Message 2 of 10

Re: System x3650 M3 7945 IMM does not send alert emails

2019-07-18, 6:48 AM
You are using port 80 as SMTP port ,it's expected. 25 is mostly used port for smtp.

You have enabled authentication for smtp , is it necessary for your smtp server ? If yes, you need input correct user/password , if no, just disable that.

Have you created the user "test " on your mail server ? make sure it's created properly.

You can further check the log on mail server side to see what's the error to determine the issue.
Reply
Options

5 Posts

04-09-2019

IT

13 Signins

100 Page Views

  • Posts: 5
  • Registered: ‎04-09-2019
  • Location: IT
  • Views: 100
  • Message 3 of 10

Re: System x3650 M3 7945 IMM does not send alert emails

2019-10-04, 13:57 PM

---You are using port 80 as SMTP port ,it's expected. 25 is mostly used port for smtp.
my answer: Changed port to 25 (even if mail.smtp2go.com accepts port 80):

 

 

---You have enabled authentication for smtp , is it necessary for your smtp server ? If yes, you need input correct user/password , if no, just disable that.

my answer: smtp authentication is required for smtp server mai.smtp2go.com

User/password  are correct! I use them to send alerts in MEGARiad SM and I receive alerts!

 

---You can further check the log on mail server side to see what's the error to determine the issue.

my answer: on the mail server log no actiity is reported for IMM (totally empty!).

It seems that the IMM alert service doesn't even connect with the SMTP server!

 

Is it possible? How can I troubleshoot anymore?

Thank you.

 

 

Reply
Options

569 Posts

08-14-2018

US

549 Signins

10159 Page Views

  • Posts: 569
  • Registered: ‎08-14-2018
  • Location: US
  • Views: 10159
  • Message 4 of 10

Re: System x3650 M3 7945 IMM does not send alert emails

2019-10-04, 20:48 PM

Can you please let us know what level of firmare you are using on the IMM and UEFI/BIOS?

Reply
Options

569 Posts

08-14-2018

US

549 Signins

10159 Page Views

  • Posts: 569
  • Registered: ‎08-14-2018
  • Location: US
  • Views: 10159
  • Message 5 of 10

Re: System x3650 M3 7945 IMM does not send alert emails

2019-10-04, 20:53 PM

Please see the following retain tip that I found.  

 

https://www.ibm.com/support/pages/imm-level-yu0091k-smtp-alert-generated-system-ibm-system-x

 

Problem

When using the "Generate Test Alert" button on the Integrated Management Module (IMM) build YU0091K web interface, no alert will be sent if "System Alerts. System-Other" is not selected.

Resolving The Problem

 

Source

RETAIN tip: H203394

Workaround

This behavior is working as designed.

The alert type of "Generate Test Alert" determine as "System-Other", user needs the option to receive alert. The selection path is:

  IMM Control --> Alerts --> System Alerts --> System-Other

The received alert message as:

  Alert Text : Management Controller Test Alert Generated by USERID
Severity : 4
Type of Alert : System - Other
Date(m/d/y) : **/**/****
Time(h:m:s) : **:**:**

Contact : ***

Location : ****@**.***
IMM Text ID : SN# *******
IMM Serial Number : *******

 

Please let us know if you need additonal information. 

Reply
Options

5 Posts

04-09-2019

IT

13 Signins

100 Page Views

  • Posts: 5
  • Registered: ‎04-09-2019
  • Location: IT
  • Views: 100
  • Message 6 of 10

Re: System x3650 M3 7945 IMM does not send alert emails

2019-10-05, 11:03 AM

The workaround doesn't work:

 

My firmware levels:

 

Reply
Options

569 Posts

08-14-2018

US

549 Signins

10159 Page Views

  • Posts: 569
  • Registered: ‎08-14-2018
  • Location: US
  • Views: 10159
  • Message 7 of 10

Re: System x3650 M3 7945 IMM does not send alert emails

2019-10-06, 19:47 PM

Please also verify the DNS, and default gateway are setup properly. 

 

One other thing I would advise is to take a packet trace to see if anything is actually being transmitted or if the data is being sent to the wrong destination. 

Reply
Options

5 Posts

04-09-2019

IT

13 Signins

100 Page Views

  • Posts: 5
  • Registered: ‎04-09-2019
  • Location: IT
  • Views: 100
  • Message 8 of 10

Re: System x3650 M3 7945 IMM does not send alert emails

2019-10-09, 12:48 PM

DNS and gateway OK:

 

 

 

 

 

 

 

 

 

 

Packet trace is not possible because the ethernet interface used by IMM is not listed in the host operating system.

Reply
Options

569 Posts

08-14-2018

US

549 Signins

10159 Page Views

  • Posts: 569
  • Registered: ‎08-14-2018
  • Location: US
  • Views: 10159
  • Message 9 of 10

Re: System x3650 M3 7945 IMM does not send alert emails

2019-10-09, 15:07 PM

Depending on what type of switch you have please take a look at setting up  a port mirror. This is a very common way to take a trace. 

Reply
Options

1 Posts

08-04-2020

AF

3 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎08-04-2020
  • Location: AF
  • Views: 15
  • Message 10 of 10

Re:System x3650 M3 7945 IMM does not send alert emails

2020-08-04, 2:50 AM
Did you figure out what went wrong with your setup? I have a same problem.
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete