cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ingio
Fanfold Paper
Posts: 4
Registered: ‎04-09-2019
Location: IT
Views: 1,046
Message 1 of 9

System x3650 M3 7945 IMM does not send alert emails

Hi all,

my System x3650 M3 7945 IMM does not send emails alerts.

My configuration is (I've tested it on a D-link network NAS and it is correct!):

1.jpg2.jpg3.jpg

 

 

When I click GENERATE TEST ALERT i see the Event Log event ID:

 

Index Sev Source Date/Time Call Home Event ID Text1
I
04/09/2019; 14:49:330x4000002800000000Management Controller Test Alert Generated by myname

 

BUT NOTHING HAPPENS! No emails were sent!

Can smeone help me?

Thank you.

Giorgio

Lenovo Employee danielwang_SZ
Lenovo Employee
Posts: 88
Registered: ‎08-23-2016
Location: CN
Views: 505
Message 2 of 9

Re: System x3650 M3 7945 IMM does not send alert emails

You are using port 80 as SMTP port ,it's expected. 25 is mostly used port for smtp.

You have enabled authentication for smtp , is it necessary for your smtp server ? If yes, you need input correct user/password , if no, just disable that.

Have you created the user "test " on your mail server ? make sure it's created properly.

You can further check the log on mail server side to see what's the error to determine the issue.
ingio
Fanfold Paper
Posts: 4
Registered: ‎04-09-2019
Location: IT
Views: 288
Message 3 of 9

Re: System x3650 M3 7945 IMM does not send alert emails

---You are using port 80 as SMTP port ,it's expected. 25 is mostly used port for smtp.
my answer: Changed port to 25 (even if mail.smtp2go.com accepts port 80):

1.jpg

 

 

---You have enabled authentication for smtp , is it necessary for your smtp server ? If yes, you need input correct user/password , if no, just disable that.

my answer: smtp authentication is required for smtp server mai.smtp2go.com

User/password  are correct! I use them to send alerts in MEGARiad SM and I receive alerts!

2.jpg

 

---You can further check the log on mail server side to see what's the error to determine the issue.

my answer: on the mail server log no actiity is reported for IMM (totally empty!).

It seems that the IMM alert service doesn't even connect with the SMTP server!

 

Is it possible? How can I troubleshoot anymore?

Thank you.

 

 

Lenovo Staff
Lenovo Staff
Posts: 323
Registered: ‎08-14-2018
Location: US
Views: 263
Message 4 of 9

Re: System x3650 M3 7945 IMM does not send alert emails

Can you please let us know what level of firmare you are using on the IMM and UEFI/BIOS?

Lenovo Staff
Lenovo Staff
Posts: 323
Registered: ‎08-14-2018
Location: US
Views: 260
Message 5 of 9

Re: System x3650 M3 7945 IMM does not send alert emails

Please see the following retain tip that I found.  

 

https://www.ibm.com/support/pages/imm-level-yu0091k-smtp-alert-generated-system-ibm-system-x

 

Problem

When using the "Generate Test Alert" button on the Integrated Management Module (IMM) build YU0091K web interface, no alert will be sent if "System Alerts. System-Other" is not selected.

Resolving The Problem

 

Source

RETAIN tip: H203394

Workaround

This behavior is working as designed.

The alert type of "Generate Test Alert" determine as "System-Other", user needs the option to receive alert. The selection path is:

  IMM Control --> Alerts --> System Alerts --> System-Other

The received alert message as:

  Alert Text : Management Controller Test Alert Generated by USERID
Severity : 4
Type of Alert : System - Other
Date(m/d/y) : **/**/****
Time(h:m:s) : **:**:**

Contact : ***

Location : ****@**.***
IMM Text ID : SN# *******
IMM Serial Number : *******

 

Please let us know if you need additonal information. 

ingio
Fanfold Paper
Posts: 4
Registered: ‎04-09-2019
Location: IT
Views: 238
Message 6 of 9

Re: System x3650 M3 7945 IMM does not send alert emails

The workaround doesn't work:

2.jpg

 

My firmware levels:

1.jpg

 

Lenovo Staff
Lenovo Staff
Posts: 323
Registered: ‎08-14-2018
Location: US
Views: 219
Message 7 of 9

Re: System x3650 M3 7945 IMM does not send alert emails

Please also verify the DNS, and default gateway are setup properly. 

 

One other thing I would advise is to take a packet trace to see if anything is actually being transmitted or if the data is being sent to the wrong destination. 

ingio
Fanfold Paper
Posts: 4
Registered: ‎04-09-2019
Location: IT
Views: 144
Message 8 of 9

Re: System x3650 M3 7945 IMM does not send alert emails

DNS and gateway OK:

 

ip.jpg

 

 

 

 

 

 

 

 

 

Packet trace is not possible because the ethernet interface used by IMM is not listed in the host operating system.

Highlighted
Lenovo Staff
Lenovo Staff
Posts: 323
Registered: ‎08-14-2018
Location: US
Views: 99
Message 9 of 9

Re: System x3650 M3 7945 IMM does not send alert emails

Depending on what type of switch you have please take a look at setting up  a port mirror. This is a very common way to take a trace. 

Check out current deals!


Shop current deals