Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Datacenter SystemsSystem x - X6, M5, M4
All Forum Topics
Options

4 Posts

09-10-2019

Poland

9 Signins

77 Page Views

  • Posts: 4
  • Registered: ‎09-10-2019
  • Location: Poland
  • Views: 77
  • Message 1 of 4

IBM System x3250 M4 - server does not start, IMM2 is not loading, limited Ethernet communication

2019-09-10, 9:24 AM

Hello,
One of our servers (IBM System x3250 M4) broke down and does not start at all. The power on switch is not active, the fans do not start at all.

I have removed the cover and determined that the "IMM2 heartbeat LED" on the mainboard is flashing rapidly all the time, which should indicate that the IMM2 firmware does not load completely:

When the server is connected to power this LED flashes quickly to indicate that the IMM2 code is loading. When the loading is complete, the LED stops flashing briefly and then flashes slowly to indicate that the IMM2 if [sic] fully operational and you can press the power-control button to start the server.

(service manual, page 25)

I have connected an Ethernet cable to the LAN1 port on the mainboard. Pinging the server does work:

  

    64 bytes from 192.168.70.125: icmp_seq=392 ttl=64 time=0.500 ms
    64 bytes from 192.168.70.125: icmp_seq=393 ttl=64 time=0.500 ms
    64 bytes from 192.168.70.125: icmp_seq=394 ttl=64 time=0.503 ms

and there are some services available:

    [root@jonczyk ~]# nmap -A -p1-65535 192.168.70.125 -Pn

    Starting Nmap 6.40 ( http://nmap.org ) at 2019-09-10 08:42 CEST
    mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
    Nmap scan report for 192.168.70.125
    Host is up (0.00084s latency).
    Not shown: 65531 closed ports
    PORT     STATE SERVICE VERSION
    111/tcp  open  rpcbind 2 (RPC #100000)
    | rpcinfo:
    |   program version   port/proto  service
    |   100000  2            111/tcp  rpcbind
    |_  100000  2            111/udp  rpcbind
    121/tcp  open  ftp     vsftpd (before 2.0.8) or WU-FTPD
    427/tcp  open  svrloc?
    3900/tcp open  udt_os?
    MAC Address: 34:40:B5:XX:XX:XX (IBM)
    Device type: general purpose
    Running: Linux 2.6.X
    OS CPE: cpe:/o:linux:linux_kernel:2.6
    OS details: Linux 2.6.17 - 2.6.36
    Network Distance: 1 hop

    TRACEROUTE
    HOP RTT     ADDRESS
    1   0.84 ms 192.168.70.125

    OS and Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
    Nmap done: 1 IP address (1 host up) scanned in 69.53 seconds
    [root@jonczyk ~]#

but I can recover the server no further. Remote IPMI does not work and I am unable to log into the FTP server on port 121 (no password is accepted, I do not know the default password).

Before the server failed, there were some POST error messages concerning something with IMM, but I have no copy of these.

I tried and it didn't help:
    - switching the "BIOS boot backup jumper (JP 2)",
    - resetting the CMOS: removing the battery or switching the "Clear CMOS jumper (JP1)" and "ME recovery jumper (JP8)",
    - connecting a power supply from a desktop computer,
    - starting the server on one RAM module (there were 2 RAM modules in the server, I tried different memory modules).

Neither the "Microprocessor error LED" nor "System board error LED" are lit up on the mainboard. No capacitors are bulged.

Official service manual from Lenovo:
    https://systemx.lenovofiles.com/help/topic/com.lenovo.sysx.2583.doc/x3250_M4_2583_isg.pdf

Reply
Options

43 Posts

09-11-2015

China

58 Signins

538 Page Views

  • Posts: 43
  • Registered: ‎09-11-2015
  • Location: China
  • Views: 538
  • Message 2 of 4

Re: IBM System x3250 M4 - server does not start, IMM2 is not loading, limited Ethernet communication

2019-09-11, 1:33 AM

Hi Sir,

 

The password should been set to default after you reseat the CMOS.

You can try login to the IPMI with user USERID and default password PASSW0RD(It's zero,0, not O), then update the IMM firmware to latest, then check if problem persist.

If problem persist, you can try collect the IMM service data and upload for further investigation.

Reply
Options

4 Posts

09-10-2019

Poland

9 Signins

77 Page Views

  • Posts: 4
  • Registered: ‎09-10-2019
  • Location: Poland
  • Views: 77
  • Message 3 of 4

Re: IBM System x3250 M4 - server does not start, IMM2 is not loading, limited Ethernet communication

2019-09-11, 7:33 AM

Thank You for answer.

I am unfortunately unable to establish remote session with IPMI:

 

[root@jonczyk ~]# ipmitool  -vv -I lanplus   -A PASSWORD -U USERID -P PASSW0RD -H 192.168.70.125 chassis status

>> Sending IPMI command payload
>>    netfn   : 0x06
>>    command : 0x38
>>    data    : 0x8e 0x04


>> Sending IPMI command payload
>>    netfn   : 0x06
>>    command : 0x38
>>    data    : 0x8e 0x04


>> Sending IPMI command payload
>>    netfn   : 0x06
>>    command : 0x38
>>    data    : 0x8e 0x04


>> Sending IPMI command payload
>>    netfn   : 0x06
>>    command : 0x38
>>    data    : 0x8e 0x04


>> Sending IPMI command payload
>>    netfn   : 0x06
>>    command : 0x38
>>    data    : 0x0e 0x04


>> Sending IPMI command payload
>>    netfn   : 0x06
>>    command : 0x38
>>    data    : 0x0e 0x04


>> Sending IPMI command payload
>>    netfn   : 0x06
>>    command : 0x38
>>    data    : 0x0e 0x04


>> Sending IPMI command payload
>>    netfn   : 0x06
>>    command : 0x38
>>    data    : 0x0e 0x04

Get Auth Capabilities error
Error issuing Get Channel Authentication Capabilities request
Error: Unable to establish IPMI v2 / RMCP+ session
[root@jonczyk ~]#

Pinging works all the time. I had reset CMOS.

 

 

I am connecting to the server over Ethernet. Should we buy a serial cable and connect over RS232?

$ ipmitool -V
ipmitool version 1.8.18

I am trying to connect from CentOS7, with firewall disabled:

[root@jonczyk ~]# firewall-cmd --state
not running
[root@jonczyk ~]# 

enabling the firewall and adding appropriate ALLOW rules did not help. Wireshark shows there is no responce to IPMI probes.

 

 

[root@jonczyk ~]# nmap -A -sU  192.168.70.125 -Pn --reason

Starting Nmap 6.40 ( http://nmap.org ) at 2019-09-11 08:33 CEST
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
[...]
Nmap scan report for 192.168.70.125
Host is up, received arp-response (0.0010s latency).
Scanned at 2019-09-11 08:33:18 CEST for 1250s
Not shown: 954 closed ports
Reason: 954 port-unreaches
PORT      STATE         SERVICE        REASON       VERSION
7/udp     open|filtered echo           no-response
67/udp    open|filtered dhcps          no-response
111/udp   open          rpcbind        udp-response 2 (RPC #100000)
| rpcinfo:
|   program version   port/proto  service
|   100000  2            111/tcp  rpcbind
|_  100000  2            111/udp  rpcbind
113/udp   open|filtered auth           no-response
177/udp   open|filtered xdmcp          no-response
427/udp   open          svrloc         udp-response Service Location Protocol 2
623/udp   open|filtered asf-rmcp       no-response
767/udp   open|filtered phonebook      no-response
1049/udp  open|filtered td-postman     no-response
1101/udp  open|filtered pt2-discover   no-response
1761/udp  open|filtered cft-0          no-response
3343/udp  open|filtered ms-cluster-net no-response
3456/udp  open|filtered IISrpc-or-vat  no-response
3664/udp  open|filtered ups-engine     no-response
3703/udp  open|filtered adobeserver-3  no-response
5353/udp  open|filtered zeroconf       no-response
16430/udp open|filtered unknown        no-response
16573/udp open|filtered unknown        no-response
16939/udp open|filtered unknown        no-response
17487/udp open|filtered unknown        no-response
19075/udp open|filtered unknown        no-response
19120/udp open|filtered unknown        no-response
19789/udp open|filtered unknown        no-response
20082/udp open|filtered unknown        no-response
20146/udp open|filtered unknown        no-response
20389/udp open|filtered unknown        no-response
20409/udp open|filtered unknown        no-response
20423/udp open|filtered unknown        no-response
21060/udp open|filtered unknown        no-response
21104/udp open|filtered unknown        no-response
21261/udp open|filtered unknown        no-response
21282/udp open|filtered unknown        no-response
21318/udp open|filtered unknown        no-response
23781/udp open|filtered unknown        no-response
30718/udp open|filtered unknown        no-response
32771/udp open|filtered sometimes-rpc6 no-response
35777/udp open|filtered unknown        no-response
36458/udp open|filtered unknown        no-response
37393/udp open|filtered unknown        no-response
40724/udp open|filtered unknown        no-response
43514/udp open|filtered unknown        no-response
49161/udp open|filtered unknown        no-response
49205/udp open|filtered unknown        no-response
55544/udp open|filtered unknown        no-response
58419/udp open|filtered unknown        no-response
64727/udp open|filtered unknown        no-response
MAC Address: 34:40:B5:XX:XX:XX (IBM)
Too many fingerprints match this host to give specific OS details
[...]

Network Distance: 1 hop

TRACEROUTE
HOP RTT     ADDRESS
1   1.02 ms 192.168.70.125

NSE: Script Post-scanning.
NSE: Starting runlevel 1 (of 2) scan.
NSE: Starting runlevel 2 (of 2) scan.
Read data files from: /usr/bin/../share/nmap
OS and Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 1251.30 seconds
           Raw packets sent: 1685 (49.618KB) | Rcvd: 2104 (148.941KB)
[root@jonczyk ~]# 

 

Reply
Options

4 Posts

09-10-2019

Poland

9 Signins

77 Page Views

  • Posts: 4
  • Registered: ‎09-10-2019
  • Location: Poland
  • Views: 77
  • Message 4 of 4

Re: IBM System x3250 M4 - server does not start, IMM2 is not loading, limited Ethernet communication

2019-09-16, 6:16 AM

I hope BUMPing this thread won't be considered inappropriate.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms