Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Datacenter SystemsSystem x - X6, M5, M4
All Forum Topics
Options

31 Posts

07-14-2015

Taiwan,China

121 Signins

1109 Page Views

  • Posts: 31
  • Registered: ‎07-14-2015
  • Location: Taiwan,China
  • Views: 1109
  • Message 1 of 6

Notice: Lenovo XClarity Essentials (LXCE) may fail to get update packages from Lenovo website

2018-08-22, 8:25 AM

Problem Description

After September 21, 2018, Lenovo XClarity Essentials OneCLI / UpdateXpress / Bootable Media Creator (BoMC) are unable to download the systems update packages (SUPs) from the Lenovo Support Website.

 

This problem impacts Lenovo XClarity Essentials utilities (BoMC, OneCLI, UpdateXpress) downloading the Systems Update packages from Lenovo Support Website for all Lenovo systems.

 

Affected items

Lenovo XClarity Essentials OneCLI                                        2.2.0 and prior versions

Lenovo XClarity Essentials UpdateXpress                             2.2.3 and prior versions
Lenovo XClarity Essentials Bootable Media Creator           11.2.1 and prior versions
All Lenovo systems are affected. 
All IBM systems are NOT affected.

 

Root Cause
Lenovo Support Website update the CA (Certificate Authority). Lenovo xClarity Essentials utilities need to update the CA.

 

Solution

Fix for this problem is available in Lenovo xClarity Essentials with new releases. Please update as soon as possible.

 

  • OneCLI version 2.3.0, or later version

          https://datacentersupport.lenovo.com/solutions/lnvo-tcli

  • UpdateXpress version 2.3.0, or later version

          https://datacentersupport.lenovo.com/solutions/lnvo-xpress

  • Bootable Media Creator (BoMC) version 11.3.0, or later version

          https://datacentersupport.lenovo.com/solutions/lnvo-bomc

 

Admin note: Date corrected

Reply
Options

3 Posts

10-22-2018

Romania

9 Signins

142 Page Views

  • Posts: 3
  • Registered: ‎10-22-2018
  • Location: Romania
  • Views: 142
  • Message 2 of 6

Re: Notice: Lenovo XClarity Essentials (LXCE) may fail to get update packages from Lenovo website

2018-10-23, 11:11 AM

Hello,

 

My name is Robert, i tried to apply the last firmware updates for my x240m5 machine type=9532. I downloaded BOMC 11.4.0(rel date 22oct2018), the ISO image was succesfuly created, reboot host, boot with that ISO, everything normally until comparing version firmware, when I've received the next warning:

 

 Warning: The prerequesite firmware packages were not found in the working directory.

Update Target:

-lnvgy_fw_uefi_c4e138c-2.80_anyos_32-64

Prerequisite Packages:

-lnvgy_fw_imm2_tcoo18m-3.00_anyos_noarch

-lnvgy_fw_uefi_c4e108j-1.20_anyos_32-64

Download all the prerequisite packages into the working directory the try this action again.

If you are directed by qualified personnel to apply the update without the prerequesite, you may bypass this warning by selecting the check box then proceed ahead.

 

I've checked the "working" directory and those packages were already there.

Is it safe to ignore this warning and proceed anyway the update ?

 

Since I bought the x240 equipment I did not have troubles to update succesfully the firmware.

 

Thank you,

Robert

Reply
Options

31 Posts

07-14-2015

Taiwan,China

121 Signins

1109 Page Views

  • Posts: 31
  • Registered: ‎07-14-2015
  • Location: Taiwan,China
  • Views: 1109
  • Message 3 of 6

Re: Notice: Lenovo XClarity Essentials (LXCE) may fail to get update packages from Lenovo website

2018-10-24, 7:39 AM

Hi Robert,

 

Lenovo is working on the issue which is similar with yours.

 

Please feedback the file list under the subfolder "workingdir/update".

 

Thanks for your help.

Reply
Options

3 Posts

10-22-2018

Romania

9 Signins

142 Page Views

  • Posts: 3
  • Registered: ‎10-22-2018
  • Location: Romania
  • Views: 142
  • Message 4 of 6

Re: Notice: Lenovo XClarity Essentials (LXCE) may fail to get update packages from Lenovo website

2018-10-24, 7:55 AM

Hi Han,

Thank you,

 

The files under workingdir/update are: 

  • lnvgy_utl_lxce_ux_2.4.0_anyos_x86-64.tgz
  • lnvgy_utl_lxce_ux_2.4.0_anyos_x86-64.xml
  • lnvgy_utl_lxce_ux01i-2.4.0_anyos_anycpu.chg
  • lnvgy_utl_lxce_ux01i-2.4.0_anyos_anycpu.txt

Also, I attached a printscreen with "update" folder from ISO image.

 

Thank you

Robert.

 

Reply
Options

31 Posts

07-14-2015

Taiwan,China

121 Signins

1109 Page Views

  • Posts: 31
  • Registered: ‎07-14-2015
  • Location: Taiwan,China
  • Views: 1109
  • Message 5 of 6

Re: Notice: Lenovo XClarity Essentials (LXCE) may fail to get update packages from Lenovo website

2018-10-25, 6:39 AM

Hi Robert,

 

Thanks for providing the information. It can be fixed by following precedure.

 

Please remove all files in local working directory "workingdir\update" and re-run the Bootable Media Creator to acquire the working UpdateXpress 2.4.0 into the same directory.

 

Alternatively, download the zip file by the link and unzip to local working directory "workingdir\update".

 

Sorry for the inconvenience.

Reply
Options

3 Posts

10-22-2018

Romania

9 Signins

142 Page Views

  • Posts: 3
  • Registered: ‎10-22-2018
  • Location: Romania
  • Views: 142
  • Message 6 of 6

Re: Notice: Lenovo XClarity Essentials (LXCE) may fail to get update packages from Lenovo website

2018-10-25, 9:48 AM
Hi Han,
Thank you very much for your help,

It works!
I've updated successfully two hosts.
thanks!
Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms