Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

Datacenter SystemsSystem x - X6, M5, M4
All Forum Topics
Options

10 Posts

01-18-2017

United Kingdom of Great Britain and Northern Ireland

14 Signins

76 Page Views

  • Posts: 10
  • Registered: ‎01-18-2017
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 76
  • Message 1 of 18

UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than current?

2017-01-24, 9:53 AM

Dear All,

 

I have been setting up my new server (7915) and going through UXSP and all of the drivers to make sure that they are at their latest and greatest versions.

 

I came to the latest version of the uEFI firmware:

 

ibm_fw_uefi_vve152e-2.34_anyos_32-64

 

and UXSP says that it is dependent upon the following Firmware for the IMM2, so when I try to upgrade to it, I :

 

ibm_fw_imm2_1aoo58t-4.31_anyos_noarch

 

However, I currently have this version of IMM2 firmware installed in both the Primary and Backup firmwares, which, if I am right, is the latest and greatest version (6.00 > 4.31):

 

ibm_fw_imm2_1aoo76i-6.00_anyos_noarch

 

So... ...how do I get the latest and greatest firmware for the uEFI loaded if it is dependant upon the older IMM2 firmware?

 

Thanks in advance.

 

Kindest regards,

 

QuietLeni

Reply
Answer
Options

20 Posts

05-06-2015

Canada

24 Signins

193 Page Views

  • Posts: 20
  • Registered: ‎05-06-2015
  • Location: Canada
  • Views: 193

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-01-26, 22:27 PM

My apologies for the confusion, looking at the EFI documentation I don't see any issue updating straight from 1.76 to 2.34. Where are you seeing the IMM 4.31 dependency? Anything since 1.85 should be fine:

https://delivery04.dhe.ibm.com/sar/CMA/XSA/06o6e/0/ibm_fw_uefi_vve152e-2.34_anyos_32-64.txt

 

 

Reply

Replies(17)
Options

20 Posts

05-06-2015

Canada

24 Signins

193 Page Views

  • Posts: 20
  • Registered: ‎05-06-2015
  • Location: Canada
  • Views: 193
  • Message 2 of 18

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-01-25, 0:44 AM

Sounds like UXSP is sorting by date instead of version number, IMM2 FW forked and some clients prefer to remain on 2.x code while others prefer the latest features. 6.00 (1aoo76i) is indeed the latest as of today:
https://www-945.ibm.com/support/fixcentral/systemx/selectFixes?parent=System%20x3650%20M4&product=ibm/systemx/7915&&platform=All&function=all#IMM2

Reply
Options

10 Posts

01-18-2017

United Kingdom of Great Britain and Northern Ireland

14 Signins

76 Page Views

  • Posts: 10
  • Registered: ‎01-18-2017
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 76
  • Message 3 of 18

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-01-25, 10:54 AM
So??? What do I do? Do I just stick with the uEFI FW of 1.76 or install the 2.xx FW and possibly get into trouble?
Reply
Options

20 Posts

05-06-2015

Canada

24 Signins

193 Page Views

  • Posts: 20
  • Registered: ‎05-06-2015
  • Location: Canada
  • Views: 193
  • Message 4 of 18

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-01-25, 18:06 PM

If you're on ibm_fw_imm2_1aoo76i-6.00_anyos_noarch then you have the latest FW, all good!

Reply
Options

10 Posts

01-18-2017

United Kingdom of Great Britain and Northern Ireland

14 Signins

76 Page Views

  • Posts: 10
  • Registered: ‎01-18-2017
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 76
  • Message 5 of 18

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-01-25, 21:58 PM

Cyrus,

 

No, I *AM* on the latest firmware for IMM2 (6.00), but I am on v1.76 for the uEFI firmware which is *NOT* the latest firmware! The latest uEFI firmware is 2.x and how do I get onto this, if it is dependent upon the v2 IMM2 firmware?

Reply
Options

20 Posts

05-06-2015

Canada

24 Signins

193 Page Views

  • Posts: 20
  • Registered: ‎05-06-2015
  • Location: Canada
  • Views: 193
  • Message 6 of 18

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-01-25, 22:02 PM

May you post a screen shot from your IMM or the UXSPi scan?

Reply
Options

10 Posts

01-18-2017

United Kingdom of Great Britain and Northern Ireland

14 Signins

76 Page Views

  • Posts: 10
  • Registered: ‎01-18-2017
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 76
  • Message 7 of 18

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-01-26, 11:06 AM

Cyrus,

Here is a screenshot:

As you can see:

1) I have version 1.73 of the IBM uEFI Firmware installed.

2) I have IMM2 6.00 installed.

3) The latest, suggested, IBM uEFI Firmware is 2.34, but this is dependant upon 1a0058t (IBM uEFI Firmware 4.31).

 

How did this happen that the Latest IBM uEFI Firmware is dependant upon an older version of IMM2 and what am I supposed to do about thiis?

 

Reply
Answer
Options

20 Posts

05-06-2015

Canada

24 Signins

193 Page Views

  • Posts: 20
  • Registered: ‎05-06-2015
  • Location: Canada
  • Views: 193
  • Message 8 of 18

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-01-26, 22:27 PM

My apologies for the confusion, looking at the EFI documentation I don't see any issue updating straight from 1.76 to 2.34. Where are you seeing the IMM 4.31 dependency? Anything since 1.85 should be fine:

https://delivery04.dhe.ibm.com/sar/CMA/XSA/06o6e/0/ibm_fw_uefi_vve152e-2.34_anyos_32-64.txt

 

 

0 person found this solution to be helpful.

This helped me too

Reply
Options

10 Posts

01-18-2017

United Kingdom of Great Britain and Northern Ireland

14 Signins

76 Page Views

  • Posts: 10
  • Registered: ‎01-18-2017
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 76
  • Message 9 of 18

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-02-01, 17:28 PM

Cyrus,

 

I raised a call with IBM Support about this and they came back and told me this as well, so I have done it and the server seems to be OK now.

 

I think that this is the solution, however, UXSP still says that uEFI 2.34 is dependant upon version 4.31 of the IMM2. I would like to see UXSP 10.3 have this fixed for me and for others.

 

Kindest regards,

 

QuietLeni

Reply
Options

20 Posts

05-06-2015

Canada

24 Signins

193 Page Views

  • Posts: 20
  • Registered: ‎05-06-2015
  • Location: Canada
  • Views: 193
  • Message 10 of 18

Re: UXSP suggests an update for uEFI with a dependency on IMM2, but the package is older than curren

2017-02-01, 17:41 PM

Thanks for the suggestion, I'll pass it along to our tools team!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms