English Community

Datacenter SystemsSystem x - X6, M5, M4
All Forum Topics
Options

8 Posts

11-21-2020

TR

10 Signins

65 Page Views

  • Posts: 8
  • Registered: ‎11-21-2020
  • Location: TR
  • Views: 65
  • Message 1 of 12

x3250 M4 stuck at System Initializing

2020-11-21, 21:18 PM

I have an x3250 M4 server that stuck at System Initializing.

 

I tried different CPU, only 1 RAM, no HDD.

 

I can't access IMM via WEB interface but I can ping the IMM and I can connect the IMM via ASU and IPMI tool.

I checked the IMM settings via ASU and it is missing some settings like IMM.HttpPort. "set IMM.HttpPort 80" command returns "setting could not found". 

I think some of the IMM image is corrupt. 

 

"ipmitool -H 192.168.2.211 -U USERID -P PASSW0RD sdr list |grep IMM2" command returns "IMM2 firmware Failover | 0x00 | ok"  so it is using primary bank, server thinks IMM is ok.

 

I tried UEFI backup jumper, ME recovery jumper, Clear CMOS jumper but these did not solve the problem.

 

 

I think updating the IMM firmware or forcing it the use secondary bank will solve this problem. Is there a way to update the IMM or force it to use secondary bank without WEB interface ?

 

Thank you.

Reply
Options

590 Posts

08-06-2018

US

789 Signins

8614 Page Views

  • Posts: 590
  • Registered: ‎08-06-2018
  • Location: US
  • Views: 8614
  • Message 2 of 12

Re:x3250 M4 stuck at System Initializing

2020-11-22, 7:19 AM

Hi Sir,

 

May I ask what did you do for the server before it stuck?

Would you please refer the KB to reset BMC/IMM by command line interface or IPMI tool, and then restart the server. You also can find more information about IMM reset in the Integrated Management Module II User's Guide.

Reply
Options

8 Posts

11-21-2020

TR

10 Signins

65 Page Views

  • Posts: 8
  • Registered: ‎11-21-2020
  • Location: TR
  • Views: 65
  • Message 3 of 12

Re:x3250 M4 stuck at System Initializing

2020-11-22, 8:01 AM

Resetting BMC/IMM by IPMI tool did not solve the problem. Also I can't access the IMM via ssh or telnet. Open ports in IMM are 111, 121, 427 and 3900

 

I don't know what was done to server before it stuck.

Reply
Options

8 Posts

11-21-2020

TR

10 Signins

65 Page Views

  • Posts: 8
  • Registered: ‎11-21-2020
  • Location: TR
  • Views: 65
  • Message 4 of 12

Re:x3250 M4 stuck at System Initializing

2020-11-22, 13:17 PM

I connected "imm uart" port to the computer to see what is going. I attached a file which contains output of imm uart port 

 

 

Reply
Options

590 Posts

08-06-2018

US

789 Signins

8614 Page Views

  • Posts: 590
  • Registered: ‎08-06-2018
  • Location: US
  • Views: 8614
  • Message 5 of 12

Re:x3250 M4 stuck at System Initializing

2020-11-23, 3:34 AM

Hi Sir,

 

If the server cannot boot up to UEFI page and access IMM web page, you will bot flash firmware for the server.

  1. When you reset IMM2 by IPMI tool, did you try to ping the IMM2 IP to check if it is unreachable during reset and then getting a proper response again? After IMM2 reset, can you login the IMM2 web interface?
  2. Could you please double check the CPU and memory you installed are compatible with x3250 M4. According to the document - Memory module installation , the memory should be installed on the DIMM1.
  3. Is the system finally boot up? or is still stop on "system initializing"? Is there any Error LED indicator lights on?
  4. Did you try refer the In-band manual recovery method to boot up the server by UEFI recovery mode?
Reply
Options

8 Posts

11-21-2020

TR

10 Signins

65 Page Views

  • Posts: 8
  • Registered: ‎11-21-2020
  • Location: TR
  • Views: 65
  • Message 6 of 12

Re:x3250 M4 stuck at System Initializing

2020-11-23, 10:27 AM
  1. Yes, it is unreachable during reset, after 30-40 seconds it is responding pings again. After reset I cant reach IMM2 web interface, I did a port scan and port 80 is closed on IMM.
  2. I checked the cpu and memory compatibility. It is working before this memory and cpu. And i also tried another cpu and memory. Memory installed on DIMM1.
  3. I waited 3 hours and it is still stuck on system initializing. There isn't any Error LED indicator lights on.
  4. I tried the In-band manual recovery method to boot up the server by UEFI recovery mode. It did not help.

 

I found some settings in the IMM UART interface:  tftpboot, update, bootp. I think I can reflash the IMM using this but it asks "immv2-uboot.bin" and "immv2-uImage" files. Can you please provide me this files?

 

Thank you.

Reply
Options

590 Posts

08-06-2018

US

789 Signins

8614 Page Views

  • Posts: 590
  • Registered: ‎08-06-2018
  • Location: US
  • Views: 8614
  • Message 7 of 12

Re:x3250 M4 stuck at System Initializing

2020-11-24, 3:25 AM

Hi Sir

 

You can refer to x3250 m4 Integrated Management Module 2 (IMM2) Update and Readme file, UART interface update is not included in the IMM2 firmware update instruction.

According to your description and previous test, I assumed that is MB issue. I recommend to contact with local support team for further support.

How to open a support ticket for Lenovo Data Center products.

How to Locate a Repair Center or Service Provider

Reply
Options

8 Posts

11-21-2020

TR

10 Signins

65 Page Views

  • Posts: 8
  • Registered: ‎11-21-2020
  • Location: TR
  • Views: 65
  • Message 8 of 12

Re:x3250 M4 stuck at System Initializing

2020-11-24, 12:34 PM

Yes, I know that UART interface update is not included in the IMM2 firmware update instruction. I just need uboot.bin" and "immv2-uImage" files. If you give me that files, I can recover my server. Thank you.

Reply
Options

8 Posts

11-21-2020

TR

10 Signins

65 Page Views

  • Posts: 8
  • Registered: ‎11-21-2020
  • Location: TR
  • Views: 65
  • Message 9 of 12

Re:x3250 M4 stuck at System Initializing

2020-11-26, 7:51 AM

I'm waiting for your answer

Reply
Options

590 Posts

08-06-2018

US

789 Signins

8614 Page Views

  • Posts: 590
  • Registered: ‎08-06-2018
  • Location: US
  • Views: 8614
  • Message 10 of 12

Re:x3250 M4 stuck at System Initializing

2020-11-27, 1:53 AM

Hi Sir,

As I mentioned, the UART interface update is not included in the IMM2 firmware update. So we don't have "immv2-uboot.bin" and "immv2-uImage" files for you.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete