cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Creativesense
Fanfold Paper
Posts: 12
Location: GB
1,694 Views
Message 1 of 6

x3550 m5 2016 clean install from CD EFI boot error

Hi I wonder if someone could advise what probably a simple question,

 

I have decide to reinstall Server 2016 from a DVD since I wanted to use the Server Guide this time, to make it identical to another host. However it says that the 'app cannot run on this PC' when it gets to the installing the OS part of the deployment.

 

If I boot straight from the 2016 DVD (uefi) it comes up with a EFI error:

 

File: \EFI\Microsoft\Boot\BCD

Status: 0xc0000185

Info: the boot configuration data for your PC is missing or contains errors  --presumably this is referencing the old install that I’ve wiped off the raid.

 

Now the raid has been cleared rebuilt, cleaned repartitioned. I imagine I need to look at the Uefi boot options and clean out the refrence to the previous OS install?

 

I know the disc is good as I installed it from this disc originally. The diffreneces now are that the Bios and the firmware on the box have all been updated to the latest versions.

 

Cheers Chris

Lenovo Employee gtx
Lenovo Employee
Posts: 157
Location: JP
1,641 Views
Message 2 of 6

Re: x3550 m5 2016 clean install from CD EFI boot error

Hi,
Maybe try to load factory defaults of UEFI settings.

1. Press F1 key at system boot to enter UEFI menu.
2. There should be some text displayed like below.
Where it can modify and clear previous boot settings per 'Boot Manager' setting.
But to be simple and confident, I would recommend to just select 'Load Default Settings' and press Enter, wait a while till prompt comes back, then select 'Save Settings' and 'Exit Setup' to leave menu.
This only affects UEFI settings, so any IMM2 or ServeRAID settings will not be changed.

------------------------------------------
System Configuration and Boot Management
....
Boot Manager
....
Save Settings
Restore Settings
Load Default Settings
Exit Setup
------------------------------------------


By the way, this may not relate to original issue but just in case for reference.
When using ServerGuide for Windows 2016, it is different from that of Windows 2008.
ServerGuide for Lenovo x86 servers
https://support.lenovo.com/solutions/lnvo-guide

regards,

Creativesense
Fanfold Paper
Posts: 12
Location: GB
1,637 Views
Message 3 of 6

Re: x3550 m5 2016 clean install from CD EFI boot error

Hi GTX,

 

Many thanks for your reply,

I had tried loading the defaults before. I've been intouch with support following a diagnostics report they are dispatching an engineer out with a mainboard today.

The drive is not appearing in the hardware invetory.

I'll let you know how we get on.

 

Cheers Chris

Creativesense
Fanfold Paper
Posts: 12
Location: GB
1,613 Views
Message 4 of 6

Re: x3550 m5 2016 clean install from CD EFI boot error

Hi GTX,

 

The boards been replaced but there still seem to be issues as the drive has dissapeared. To this end I've been trying to install from USB. 

 

I’ve created a bootable USB with the server guide on it this works fine. However I’m having a problem getting it to locate the 2016 installation files.

 

I’ve spilt the install.wim file in half so it will fit on the FAT32 drive

Copied the entire contents of the Windows Server 2016 Std iso with the split wim to the folder:

SGDEPLOY\OS

 

Since that did not work I tired copying the contents of the \sources folder into:

SGDEPLOY\OS

 

That did not work either. Any advice on the above would be great.

 

Cheers Chris

Lenovo Employee gtx
Lenovo Employee
Posts: 157
Location: JP
1,605 Views
Message 5 of 6

Re: x3550 m5 2016 clean install from CD EFI boot error

Hi,


Hmm..... this is puzzling.
I would recommend to go back and confirm basics, just in case.
Some suggestions:

1. Make sure that system and option firmware are up to date.
Using BoMC tool will be helpful to update everything at once.
Download latest tool build from Web, and create a bootable media.
Bootable Media Creator (BoMC)
https://support.lenovo.com/documents/LNVO-BOMC

2. Try reset configuration just in case.
F1 UEFI: Load Defaults, and Save
F1 UEFI Storage Menu: Load Factory Defaults for ServeRAID, then Create new RAID Array once more
(If can detect HDD and configure RAID, then know storage subsystem working)

3. Re-download ServerGuide, just in case.
Please be careful the one supporting Windows 2016 is different from Windows 2008.
ServerGuide for Lenovo x86 servers
https://support.lenovo.com/solutions/lnvo-guide

4. If have problem booting from DVD drive, see if you can find a different DVD drive.

5. See if can boot directly from your Windows 2016 media and complete OS installation.  This can find if media and HDD are working.  Maybe find different OS media to try, like Windows 2012R2.

6. If have IMM2 advanced feature key enabled, try see if can use remote control and mount iso file (Windows 2016 media, etc.) to boot.

7. If any un-supported option device like PCI card installed, then once remove.  And simplify hardware to minimum configuration and try.

regards,

Creativesense
Fanfold Paper
Posts: 12
Location: GB
1,600 Views
Message 6 of 6

Re: x3550 m5 2016 clean install from CD EFI boot error

Hi,

 

it has had me scratching my head as well....

 

1. Make sure that system and option firmware are up to date.

- Yes this had been done before once the tool was availble to download again. Interestingly I had booted and installed from DVD sucessfully from both of my identical hosts before I had upgraded the firmware. 

 

2. Try reset configuration just in case.

- Yes done this a few times now both the UEFI and the Raid. The raid is working great.

 

3. Re-download ServerGuide, just in case.

- Checksum works out fine and its on a verifed disc.

 

4. If have problem booting from DVD drive, see if you can find a different DVD drive.

- I did swap the drives around the two hosts it didn't make much difference in booting from. However see below

 

5. See if can boot directly from your Windows 2016 media and complete OS installation.

- Yes i tried directly with the server guide and downloaded 2012 to try all with the same affect

 

6. If have IMM2 advanced feature key enabled.

This was my next idea if I couldn't get the USB to work. I haven't registered my license yet.

 

7. If any un-supported option device like PCI card installed, then once remove.

Only the supported hardware as supplied by Lenovo installed. Ideally I dodn't want to strip it down.

 

Anyway I was told by support to continue on the DVD path. Before trying to boot with the DVD I though id just put the media in again (server had booted the guide from USB) It picked the disc up and ran with the install all the way through.

 

So I rebuilt the other host to make it identical. however it would fail through the windows install, booting Server guide from the USB and reading 2016 from the DVD. It did this three times indetically in the same place so I swapped the DVD drive with the host I was originally having problems with and it worked first time.

 

So its likely to be a faulty DVD drive since this was swapped around twice although why the original host couldn't boot from the working drive or appear in setup I don't know. My advice would be to avoid an install by DVD if possible.

 

The new server guide does not prompt for core/ gui and installs GUI by default.

 

 

ALERT

Windows 2016 Server November Update
Issue on System x M5 and X6
Go to details
.

Top Kudoed Authors