English Community

ThinkPad NotebooksThinkPad T400 / T500 and newer T series Laptops Knowledge Base

Trouble connecting wifi onThinkPad T540p / W540 with Realtek Bluetooth


Some customers using ThinkPad T540p or W540 systems, equipped with Realtek Bluetooth/Wireless LAN combo card and running Realtek Bluetooth driver version 3.754.754.080913,  may experience wifi connectivity issues.  The system may appear to be connected, but a “No Internet” status may display at the Tray icon of the connection status.


This may occur under Windows 7, 8, and 8.1


An updated Bluetooth driver has been released and should resolve the symptoms.


If you are experiencing these symptoms, please install the updated driver available from our support site here.




If you are running a non-Windows OS, (Linux for example) and are encountering these drops, try disabling bluetooth and see if the symptoms change.  


Was this information helpful?

Yes No


HAF_schatzie36 On 2014-06-24, 20:22 PM

I have a similar problem on my Thinkpad E531 (Windows 7, Broadcom 1x1 11b/g/n half minicard adaptor--and also Microsoft Virtual WiFi Minicard Adapter--not sure why there are two wifi adapters). My wireless connection fails many times a day, and has since I bought the laptop NEW in February 2014. Sometimes, the connection status says it's connected when it isn't (signal strength excellent, etc), and sometimes I get the yellow bang symbol and it says "No Internet."  I usually have to shut the lid, wait a few seconds, then log back into windows and manually reconnect. And sometimes it happens AGAIN within a few minutes. The connection rarely lasts for more than an hour before I have to repeat this. I called Lenovo support and updated my BIOS and uninstalled and reinstalled the driver software, and I uninstalled Access Connections, and I changed my SSID and password. I changed the power settings for the wifi adapter. NOTHING WORKS. PLEASE, PLEASE HELP!! The problem seems to be getting more frequent. It's driving me nuts! Thank you so much. 

tburton62000 On 2014-07-15, 14:12 PM

With the recent Windows 7 updates (July 2014) Windows has disabled the driver for the Realtek Wireless on the T540p.  I can't seem to figure out how to inable this driver again and the driver installed is identified as the most recent.

jafmonteiro On 2014-11-08, 16:44 PM

I had the same problem yesterday, my wifi connection stopped working and even the wifi icon is not showing up. I have tried to download newer driver versions of realtek and intell, unsuccessfully.

cesare40 On 2014-11-24, 12:46 PM

I have a similar problem with my T540p (wiyh windows 8.1) on which, after some software updating now I can  use only ethernet solution. Realtek Bluetooth is not installed  (at least now) and looking at PC Setting -> Network -> Connections against Wi-Fi appears  "no connection". Cllicking on the Wi-FI icon the properties shown are: Intel Corporation - Intel(R) Dual Band Wireless-AC 7260; driver version; and than the phisical address i believe is not here of interest.

Any attempt to activate WI-FI from PC setting is useless: the attempt starts but do not succeds, whatever is the status of bluetooth (that do not use often and therefore is usually disabled).

fraletizia On 2015-02-21, 18:58 PM

I have the same problem with a Thinkpad L440. I have tried to contact the support service (the laptop is still in warranty) one week ago, but no reply so far. I have also tried to install the drivers suggested in the article, but the wifi still disconnects. Is it possible to receive any help on this issue? Thanks

charlesdiaz On 2015-03-05, 20:51 PM

Hello ... I bought a T540p 1 year ago and I had a lot of problems, specially with the Realtek Wireless LAN M.2 Adapter (Bluetooth is not working neither), it was working well in the last 3 months but I'm currently experiencing problems one more time. It stopped working with no reason (no updates or changes). On Device Manager, Networks Adapters tab for 2x2 11b/g/n Wireless LAN M.2 Adapter shows "Windows has stopped this device because it has reported problems. (Code 43)" 

I have tried all the different drivers versions from Lenovo Download section with the same result.

Wifi is not working at all.


Somebody can help ?

lucepete On 2015-04-10, 18:52 PM

I have the same issue as charlesdiaz. Please someone help. I've tried many many solution in the past 24 hours.

harryzh On 2015-09-25, 18:28 PM

I had this problem ("Windows has stopped this device because it has reported problems. (Code 43)") and tried installing updated driver, did not work.

But after installing system update from lenovo, the problem is fixed!

You can download ThinkVantage System Update from here:



lucepete On 2015-10-06, 13:13 PM


Thank you! Unfortunately, this didn't solve my issue. I'm open to other suggestion.




Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop