Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad; T61 and prior T series plus Other Legacy ThinkPads
All Forum Topics
Options

2 Posts

09-05-2008

Australia

9 Signins

59 Page Views

  • Posts: 2
  • Registered: ‎09-05-2008
  • Location: Australia
  • Views: 59
  • Message 1 of 8

SSD Patriot Warp V2 64gb & 128gb & Lenovo T61P - error 2100 hard disk failed initialisation

2008-10-02, 8:06 AM

Hi guys. I have recently purchased 2 SSD drives - 1x64gb & 1x128gb. I have the 64gb hooked up to the home pc and is running as the C:\ system drive. I wanted to hook up the 128gb drive to my notebook, but I keep getting an initialisation error (2100) - I have tried AHCI and Compatibility Mode, as well as look up various firmware upgrades and hdd firmware upgrade options via Lenovo.

 

I was just curious if anyone has had problems with this on there system, and if so, how did you overcome it. I have tried both drives on my notebook, both providing the same error, but both work on the desktop system.

 

I have a strong feeling it is to do with a firmware upgrade through Lenovo (ibm), as I have the most recent upgrade which is already a few months old... Hope to hear something good soon... Thnx guys in advance.

Reply
Options

1 Posts

10-31-2008

Denmark

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎10-31-2008
  • Location: Denmark
  • Views: 5
  • Message 2 of 8

Re: SSD Patriot Warp V2 64gb & 128gb & Lenovo T61P - error 2100 hard disk failed initialisat

2008-10-31, 8:34 AM
Hello everyone. Had the same problem Yesterday. Tried several times without luck. Then I read another thread on the Internet regarding this. It stated that there is a little inconsistency between the SSD SATA plug and the recieving plug in the laptop. I removed the IBM Disk bezel and put the 2 rubber guards directly on the disk and slipped it in. BEFORE this, I have put the SSD in an external USB HD Case and via Windows Diskmanager, deleted the partition on the drive. After putting it back in as described above it WORKED :-))) Please write back if anybody tries this and it works for them BR Jakob
Reply
Options

28 Posts

04-02-2009

melbourne, australia

193 Signins

605 Page Views

  • Posts: 28
  • Registered: ‎04-02-2009
  • Location: melbourne, australia
  • Views: 605
  • Message 3 of 8

Re: SSD Patriot Warp V2 64gb & 128gb & Lenovo T61P - error 2100 hard disk failed initialisat

2009-06-21, 18:47 PM

I have a W500 and a OCZ Summit and it also comes up with a error 2100 though the drive itself is just fine (works great as an external drive). i have updated w500 bios; no effect. it needs to go in the caddy else it can't be removed without opening top of the case. very tight fit with rubber rails makes it difficult to remove also. don't know what to do. did you put it in without the caddie?

PS I have been referred to  http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-63685 for a HDD-dedect and update utility. Maybe that is the way...?

Message Edited by antskip on 06-21-2009 12:09 PM
Reply
Options

5494 Posts

04-25-2008

United States of America

39826 Signins

762468 Page Views

  • Posts: 5494
  • Registered: ‎04-25-2008
  • Location: United States of America
  • Views: 762468
  • Message 4 of 8

Re: SSD Patriot Warp V2 64gb & 128gb & Lenovo T61P - error 2100 hard disk failed initialisat

2009-06-21, 19:36 PM

That Hard drive firmware update says:

 

This firmware update includes the fix for the case on a system with Windows Vista, that the system may display the following error message at each power on, and then cannot boot from the hard drive. "2100: Initialization error on HDD0 (Main hard disk drive)"

 

Does that sound like your problem?

USB-C: Just cos it fits don't mean it works.
I don't work for Lenovo. I'm a crazy volunteer!
Reply
Options

3 Posts

08-22-2009

Netherlands

5 Signins

31 Page Views

  • Posts: 3
  • Registered: ‎08-22-2009
  • Location: Netherlands
  • Views: 31
  • Message 5 of 8

Re: error 2100 SOLUTION

2009-08-22, 0:41 AM

On my Thinkpad X60 Tablet this error appeared to be caused by the PHYSICAL connection as Svaneberg mentioned!

 

I had the 2100 error, but immediately tried with removing the rubber sleeves and it worked, but unstable (I got the error again). Then I took the sleeves, end cut off the ends near the connectors (just 2 mm's) and re-applied them on the sides ad made sure the OCZ Vertex SDD I have was pushed firmly into the connector by the closing plate. Until now I had no problems anymore!

 

Han

Reply
Options

4 Posts

03-02-2010

morocco

11 Signins

42 Page Views

  • Posts: 4
  • Registered: ‎03-02-2010
  • Location: morocco
  • Views: 42
  • Message 6 of 8

Re: error 2100 SOLUTION

2010-03-02, 16:00 PM

hello i have the same problem on my IBM lenovo T60

ERROR 2100 : HDD0 initialization error (2)

ERROR expansion ROM not initialized- PCI on Motherboard

press ESC to continue

and then nuttin happen

i have a message :

cannnot boot from any device

the pc can't start

and when i put windows cd trying to format it and reinstall it

i have a blue screen ....

can someone please help my pc can no more start; and i cant format it ny suggestions??

Reply
Options

3322 Posts

07-31-2008

Pakistan

1715 Signins

151632 Page Views

  • Posts: 3322
  • Registered: ‎07-31-2008
  • Location: Pakistan
  • Views: 151632
  • Message 7 of 8

Re: error 2100 SOLUTION

2010-03-02, 21:06 PM

Hi haspac2,


Welcome to the forum!


Check out following links for ROM not initialized error:- 


http://forum.thinkpads.com/viewtopic.php?t=29472

http://digitalchunk.com/expansion-rom-not-initialized-pci-on-motherboard-t60.htm


As for HDD initialization error check following link:- http://www-307.ibm.com/pc/support/site.wss/MIGR-42321.html


To install Win XP, SATA AHCI needs to be changed to Compatibility mode in the BIOS for HDD. - Config - > SATA - > Compatibility. 


Hope it helps.

------------------------------------------------------------

Maliha (I don't work for lenovo)
ThinkPads:- T400[Win 7], T60[Win 7], IBM 240[Win XP]

IdeaPad: U350

Apple:- Macbook Air [Snow Leopard]
Did someone help you today? Compliment them with a
Kudos!
Was your question answered today? Mark it as an Accepted Solution
de.gif  Lenovo Deutsche Community   es.gif  Lenovo Comunidad en Español 
Visit my YouTube Channel

Reply
Options

4 Posts

03-02-2010

morocco

11 Signins

42 Page Views

  • Posts: 4
  • Registered: ‎03-02-2010
  • Location: morocco
  • Views: 42
  • Message 8 of 8

Re: error 2100 SOLUTION

2010-03-05, 14:23 PM

thank u maliha for your reply

i took a look at it

the error about LAN card didn't bother me

since my laptop could start

but with that 2100 error; my hard drive can't anymoe be reconized

it's deadly*

i just need to recover my data from it

i have 10 Giga of pictures in it

if anyone managed to do it please give me help

 

regards

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms