Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkBook NotebooksThinkBook Notebooks
All Forum Topics
Options

1 Posts

09-06-2021

Indonesia

2 Signins

15 Page Views

  • Posts: 1
  • Registered: ‎09-06-2021
  • Location: Indonesia
  • Views: 15
  • Message 1 of 2

SSD Didn't Appear on EFI BOOT Selection in BIOS (ThinkBook 14s Yoga i7-1165g7

2021-09-06, 6:14 AM

So guys, I'm currently facing an issue where 1 of my installed SSDs didn't appear on EFI BOOT Selection, yet IT'S READABLE in BIOS INFORMATION! As for the detailed information, here's the timeline I can trace:

1. Bought a new ThinkBook 14s Yoga with 512GB Hynix NVME SSD & Win 10 Pro onboard

2. Later, I added my WD 1TB NVME SSD on the 2nd available slot

3. At first, both are visible & readable on BIOS SETUP & BOOT MENU without any issues

4. I tried to install Windows 10 Pro on my WD SSD, yet NO DRIVES CAN BE FOUND due to Intel's VMD

5. I disabled the VMD & turn the AHCI controller ON, so I can proceed with the Win 10 Pro installation on my WD SSD & luckily it went smooth

6. I entered BIOS, turned on Intel VMD (to access my old Win 10 OS on Hynix SSD)

7. My laptop went to ENDLESS LOOP of BLUE SCREEN since my OLD Win 10 OS is somehow CORRUPTED (INACCESSIBLE_BOOT_DEVICE)

8. I went to BOOT SELECTION & then, I CAN'T FIND MY WD SSD (only USB drive & Hynix SSD are visible)

9. but the BIOS information confirmed both SSDs ARE INSTALLED (Hynix on 1st slot & WD on 2nd slot)

10. I can't also set boot selection order on my BIOS, since 1 of my SSDs isn't accessible

11. Thankfully, I can still boot to my WD SSD, by turning the VMD off & AHCI on

12. When I boot on my recently-installed Win 10 Pro (WD SSD), MY Hynix SSD IS READABLE on Windows Explorer

 

holy heck! I don't know that dealing with Tiger Lake can be this frustrating; previously I owned Yoga 6 R5 4560U, but everything isn't as complicated as this.. or maybe I'm just too clueless on nowadays' tech.. please, is anyone kind enough to explain what on earth happened to my laptop? I was expecting a smooth experience of working with a brand new laptop & not with this kind of whacked trouble 🤯

I assure you, THERE'S (likely) NO HARDWARE FAULTY, since I've tried to swap each SSD to a different slot, yet the issue still remain (my WD SSD DIDN'T APPEAR ON EFI SELECTION) & it looks like the issue has nothing to do with DUAL BOOTLOADERS (1 on my Hynix SSD & 1 on my WD SSD); I've also UPDATED MY BIOS to the latest, so.. I really don't have a clue what went wrong

 

note on no. 4: yes, at that time, I didn't know that you can just manually install IRST on my Bootable USB, so I turned off the VMD & installed the OS on my WD SSD

 

In case if you wondered why'd I even go to such extend to install the same OS on my 2nd SSD: because I need to wipe the data on my 2nd SSD (WD) if I want to MIGRATE The OS by using MiniTools Partition Wizard; copying the partition won't do the trick either & that's how I f*cked myself up

Reply
Options

1584 Posts

07-22-2021

United Kingdom of Great Britain and Northern Ireland

272 Signins

7550 Page Views

  • Posts: 1584
  • Registered: ‎07-22-2021
  • Location: United Kingdom of Great Britain and Northern Ireland
  • Views: 7550
  • Message 2 of 2

Re:SSD Didn't Appear on EFI BOOT Selection in BIOS (ThinkBook 14s Yoga i7-1165g7

2021-09-06, 10:37 AM

Hi

 

Disagree...

""7. My laptop went to ENDLESS LOOP of BLUE SCREEN since my OLD Win 10 OS is somehow CORRUPTED (INACCESSIBLE_BOOT_DEVICE)""

 

Mine did that also.

 

Takes a few runs at auto repair but gets there in the end.  YMMV.

 

I used Paragon and any other free tools from Western Digital.

 

CloneZilla is what I prefer.

 

 


----------------

Forum, Agin 'em?
Uniquely Neutral

IdeaPad 3 17ITL6

MTM:- 82H9CTO1WW
OS's W10 & LINUX

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms