cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
BGIL
What's DOS?
Posts: 2
Registered: ‎11-08-2019
Location: US
Views: 74
Message 1 of 3

ThinkBook 13s-IWL mouse freezes

Hello,

 

I have just bought a new ThinkBook 13s-IWL with Windows 10.

I am using a wireless USB mouse (by Microsoft).

The problem is that the mouse keeps freezing after couple of minutes of work. The cursor then stops moving. It returns only after several minutes. I am desperate.

 

Things I have already tried:

 

1. Replace USB dongle port - no change

2. Reaplce USB mouse completely - no change

3. Installing latest Windows update - no change

4. Uninstalling and reinstalling the mouse HID drviers - no change

5. Installing most recent drivers from Lenovo website - no change

 

I appreciate your assistance. Thank you!

Support Specialist
Posts: 68
Registered: ‎05-02-2019
Location: US
Views: 33
Message 2 of 3

Re: ThinkBook 13s-IWL mouse freezes

Hi @BGIL!

 

Welcome to Lenovo Community Forums.

 

Have you tried using a different mouse? Kindly observe if the mouse cursor will work when you use the touchpad and check if the  external mouse would be responsive again. To further isolate the issue, you may follow the troubleshooting steps below.

 

Hit the Windows button and from the Start Screen type "mouse." You want this one, not the "metro" or fullscreen mouse settings.

If you have the Lenovo or Synaptics drivers, select the UltraNav tab.

Then Settings > then  PalmCheck. Put it a few notches below Maximum.

 

Let us know if this helps.

 

Regards,



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

BGIL
What's DOS?
Posts: 2
Registered: ‎11-08-2019
Location: US
Views: 20
Message 3 of 3

Re: ThinkBook 13s-IWL mouse freezes

Thank you @Van_Lenovo!

 

I have tried to replace the mouse device but the problem was not solved.

 

I don't have UltraNav or Synaptics tab in the mouse settings so I can't change the PalmCheck setting.

 

Any ieda?

Check out current deals!


Shop current deals

Top Kudoed Authors