English Community

ThinkCentre DesktopsThinkCentre A, E, M, S Series Knowledge Base

M58 - Fan running constantly at 100%

Question

A few minutes after booting up the PC, the fan is constantly running at 100%.

Answer

Please refer to the diagram below when performing the following proceedure

 

ScreenShot221.jpg

 

  1. Power down system
  2. Remove power cord (power cable from PSU to AC) from power supply.
  3. Clear CMOS jumper in item #17
  4. Remove battery in item #25
  5. Hold power button for 5 seconds
  6. Replace power cord (power cable from PSU to AC)
  7. Power On then hold Power again to Power off
  8. Connect CMOS jumper back on Pin 1 & 2
  9. Replace the battery in item #25
  10. Power up (system beep twice)
  11. Press F1 for BIOS
  12. Set default to the BIOS
  13. Set time and date
  14. Press F10 to save BIOS settings
  15. Check if Fan is running at 100%

 

If after doing the step provided above and issue still persist. Do try the following.

 

Try moving the fan connector from the edge of the board which is near the SATA port to the one beside the BIOS battery.

 

2nd one is that you would need to send your system to the service center for them to check the thermal cable.

Was this information helpful?

Yes No

Comments

Username1024 On 2014-10-21, 22:03 PM

It does not say if you must take out the power chord after step 7. Does it mean to put the jumper back in when the power cord is connected. Is that safe?

 

Also what does it mean CLEAR CMOS JUMPER in step #3. Does this mean move it to the other pin on the strip of pins, or does it mean take it off the board altogether.

 

These are not good instructions. There is no polite way to say it. Sorry.

Username1024 On 2014-10-23, 16:54 PM

Ok. I have modified the procedure so that it works on an M57 6075 as well. The steps outlined above do not work for the M57. You need to use a slightly different power down technique.

 

See this link here.

 

http://forums.lenovo.com/t5/A-M-and-Edge-Series-ThinkCentre/Desktop-Fan-runs-constantly/m-p/1767323#M13364

moonliter On 2014-12-15, 5:16 AM

How about including fan speed control in the BIOS like any other decent computer manufacturer would for the past 20 years! **bleep**!

dannyph On 2016-07-31, 22:49 PM

Hi. After following the instructions above, my m58p wont boot up. Theres just the power light on, with fan constantly at 100%, then nothings happens. I have to press the power button for 5secs before it will turn off. Any advice? Pls help 

WeedMachine On 2016-09-20, 2:07 AM

I got the same problem. Try to make sure that your Ram is in correctly that fixed it for me.

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Delete