Showing results for 
Search instead for 
Did you mean: 
Posts: 17
Registered: ‎02-09-2013
Location: Trondheim, Norway
Views: 4,406
Message 1 of 4

ASUS GEFORCE GT640 not working with the latest M92p 2992-B3G BIOS

I've got a ThinkCentre M92p (2992B3G) that I bought over 6 months ago.

It's a pretty standard setup, and I haven't done anything to the hardware except upgrading it to 8GB of memory and adding a new SSD for my system drive. In addition I purchased an ASUS NVIDIA GT640 PCI-e video card as the default video card doesn't put out much performance for even the most casual of gamers. I'm running on Windows 8.1, with all updates installed. I've always been very tidy, so I've kept myself up-to-date with all the latest Windows Updates, and updates from the Lenovo System Update tool.

This setup worked great for several months, until one dreadful night where a new BIOS was presented by Lenovo System Update. I can't for the life of me remember the exact version number of that BIOS, but I do know it was released a week or two before the 14th February 2012. The change logs for Lenovo's BIOS updates doesn't include a release date, but I g

Either way; I download the BIOS update for Lenovo's websites, burned myself the ISO-image version, and went ahead with the flash as I've done many times before, even on this computer.

This is were my issues began; after the BIOS update I cannot for the life of me get any PCI-e video cards to work. Once the computer booted back up, the display was simply blank; not even a POST-message, and much less any display from the operating system itself.

With the PCI-e video card installed I can't the BIOS settings either. Therefore I have to remove the video card, make the necessary BIOS setting changes, and insert the video card again before booting.

Bottom line; my GEFORCE GT640 worked fine until the BIOS update, after which it doesn't work anymore.

Here's a few things I've tried so far;

  • I've tried both my GEFORCE GT640 and my RADEON HD640. No luck with either.
  • I've tried my GEFORCE GT640 in another rig. Runs just fine, so the video card isn't faulty.
  • I've tried my RADEON HD7750 in another rig. Runs just fine, so the video card isn't faulty.
  • I've tried four different monitors (two from BENQ, one from ASUS and one from DELL). It's not a monitor issue.
  • I've tried different video card settings in the BIOS (AUTO, PEG etc). No luck.
  • It's not a driver issue. I've tried booting both Windows 7 and Windows 8, and in both cases I've tried it with a variety of drivers installed (and not installed). Tried drivers both from Lenovo and NVIDIA's official driver packages. It's not a driver issue.
  • I've tried 3 different DVI-cables, a VGA cable and an HDMI cable. All work on other rigs, but not with the PCI-e card in the M92p.
  • Yes, I do upgrade my BIOS from a bootable CD, and no, I didn't brick the motherboard

The funny part to this story is .. when I contacted Lenovo Support, believing that my motherboard was fried.

They asked me to contact InfoCare, one of their sub-contractors, to help me replace the motherboard. On the 13th of February 2012 an on-site support technician from InfoCare came to replace the motherboard. After he replaced it, we tried it out my GEFORCE GT640 to see if the problem had been resolved; EUREKA! IT WORKED!.

However, the support technician insisted to update the BIOS before he left. At the time I didn't know the BIOS was the real issue, so i stupidly agreed. He did his job, and left. I didn't reboot the computer again before I brought it home that day; and what do you know? I got home, booted up the computer, and got the exact same problem I had earlier; black screen, as if the PCI-e video card wasn't even there.

That gave me the idea that the BIOS was to blame, so I began searching around on Google, Lenovo's Community Forum and so forth. That's when I found out that Lenovo had a reputation for white-listing certain WiFi extension cards, video cards and so forth. The only speculation as to why they did this was users saying that it was because only certain combinations of e.g. a motherboard and video card was not FCC-compliant.

What sucks with this is that it wasn't always this way; in the case of the M92p 2992-B3G that white-list was added with a BIOS update.

So why don't you just flash back to an older BIOS version?

Easier said than done; there is no earlier BIOS version.

Well, there are earlier versions, but they're no longer available to the public. I've dug around pretty much everywhere, and there's no downloads available anywhere, only the latest BIOS versions are available for download.

So unless you've got an old ISO-image lying around, or happen to have the .img files in your C:\SWTOOLS, then you're pretty much screwed.

Anyone got any ideas on how I can go further from here?

The only suggestion I've got so far is to replaced the motherboard with a new one, which likely has the factory BIOS. That's pretty much what I did when the on-site support technician helped me last, and that worked like a charm until he flashed the BIOS again.

Here's a few relevant posts you might want to review if you're up for it;



For the curious ones you'll find the BIOS change logs (up to 9SJ979USA) here;




If found an interesting reply to this post, where a user posted a link to a graphics card compatability matrix from July 2010, telling a M58p user that one of the video cards he wanted to purchase was not compatible with his machine type.


He also speculates that Lenovo only white-lists low-power graphics cards such as the Quadro NVS because of their low power consumption. Then again, he himself uses a card that's not on that compatability list (a GEFORCE 310) without any issues.


Is there an updated compatability matrix available, that also includes the M92p?




Could this problem been a result of LENOVO adding UEFI support to its M92p BIOS to comply with Microsoft's requirements for Windows 8?


If you check the specifications for the ASUS GEFORCE GT640, and scroll to the bottom of the page you'll see the following;


"* No native UEFI BIOS support, for UEFI BIOS, please download from ASUS technique support site. (The update tool only for ASUS MB.)"


Could this be the o'holy grail for my problem?


If this is the case, I am willing to purchase a new video card with native UEFI support (e.g. the SAPPHIRE RADEON R9 280), and see if that one might work.


Posts: 17
Registered: ‎02-09-2013
Location: Trondheim, Norway
Views: 4,315
Message 2 of 4

Re: ASUS GEFORCE GT640 not working with the latest M92p 2992-B3G BIOS

I can't seem to edit this post anymore, for some odd reason.


So here goes;


I found this post in NVIDIA's knowledge base;


When installing an after-market graphics card into a certified Windows 8 PC with UEFI enabled, the s...


The interesting parts in this post are as follows;


When an after-market graphics card is installed into a motherboard with UEFI enabled in the system BIOS, or if the system is a certified Windows 8 PC with Secure Boot enabled, the system may not boot.

UEFI is a new system BIOS feature that is provided on most new motherboards. A UEFI system BIOS is required in order for the Windows 8 Secure Boot feature to work. Secure boot is enabled by default on certified Windows 8 PCs.

In order to get the PC to boot with a graphics card that does not contain UEFI firmware, the end-user must first disable the secure boot feature in the system's SBIOS before installing the graphics card.

Note: Some system SBIOS's incorporate a feature called compatibility boot. These systems will detect a non-UEFI-enabled firmware VBIOS and allow the user to disable secure boot and then proceed with a compatibility boot. If the system contains a system SBIOS the supports compatibility boot, the user will need to disable secure boot when asked during boot process

This leads me to believe that the BIOS update that wrecked my setup was 9SKT58A/9SJT58A, which only contains one change;


"Adds support for updating BIOS from a WIN7 BIOS to a WIN8 BIOS".


I've just ordered a cheap UEFI-compatible GT640 from Gainward, so I hope I'll be able to try that out this weekend.



Posts: 17
Registered: ‎02-09-2013
Location: Trondheim, Norway
Views: 4,270
Message 3 of 4

Re: ASUS GEFORCE GT640 not working with the latest M92p 2992-B3G BIOS

The solution proved simple;


BIOS Update 9SKT58A/9SJT58A comes with UEFI-support to become Windows 8 compatible.


This means you'll also need a UEFI compatible graphics card, or a BIOS that'll support certain non-UEFI cards.


So you're out of luck; you'll likely need to purchase a new video card, and make sure it's UEFI compatible.


That's it. Hope this helps out future googlers.

Punch Card
Posts: 52
Registered: ‎06-27-2013
Location: Australia
Views: 2,647
Message 4 of 4

Re: ASUS GEFORCE GT640 not working with the latest M92p 2992-B3G BIOS

So I've just read this whole thread; and I commend you for your persistance in finally solving the issue! 


But it seems to me that the only reason for the issue was the"improved" BIOS offered by Lenovo, and seemingly auto acceptance by system update of that update...and if THAT is true...then I feel you were very hard done by having to go through all the steps and dramas you had to endure to finally solve your problem.


But I wonder why I see no interaction from anyone from Lenovo; no help tips to a workaround, or acknowledging that the problem was caused through their BIOS update. I know when I have had to update BIOS on other Lenovo PCs, and other brands as well, the manufacturer always seems to warn "not to use the update unless it specifically addresses an issue that you are having with your PC" or words to that effect...FWIW  my opinion is that the BIOS was faulty and should have been fixed/withdrawn/modified so that other users were not affected with this problem.


Kudos to you!!

Check out current deals!

Shop current deals

Top Kudoed Authors