cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
timmmah
Fanfold Paper
Posts: 6
Registered: ‎03-15-2010
Location: Louisville, KY
Views: 841
Message 1 of 3

Front USB Ports TC M700 and Windows 10

I have a TC M700 and can't seem to find the drivers for the front USB 3.0 ports on the tower chassis. I have installed all the chipset drivers I could find. Anyone out there had this issue?

 

Running Windows 10 Enterprise 64 bit

 

Thanks!

 

SeniorGuru
Posts: 2,089
Registered: ‎06-13-2013
Location: US
Views: 816
Message 2 of 3

Re: Front USB Ports TC M700 and Windows 10

There doesn't seem to be a Lenovo-provided driver for the M700 for USB support in Win10.  I believe that's because Win10 itself provides built-in USB 2.0/3.0 drivers and this would be sufficient to support the front and rear USB ports on the machine.  But I may be wrong.  However there ARE USB 3.0 drivers provided for the M700 for Win7 (and the USB 3.0 driver is from Intel), so this supports my hunch that it's not needed from Lenovo for Win10.  Intel must have provided its USB 3.0 driver to Microsoft to deliver as part of any Win10 install, and that's sufficient.

 

I assume you're saying your front USB ports don't work.  Do your rear USB ports work?  If the rear works but the front doesn't, sounds like a machine hardware issue, not a driver software problem.

 

Do you have any "other device" items shown in Device Manager, which would be the absolute indication there is hardware which is in the machine but currently not associated with proper drivers.  If so, if you right-click on the item to get Properties, then select the Details tab, and then click on the dropdown item to select "Hardware ID", and then COPY/PASTE the values presented here, this will precisely define the hardware needing the "missing driver". If you don't have any "other device", then no hardware is unsupported currently.

 

timmmah
Fanfold Paper
Posts: 6
Registered: ‎03-15-2010
Location: Louisville, KY
Views: 804
Message 3 of 3

Re: Front USB Ports TC M700 and Windows 10

Thanks for your reply and suggestions.

 

I opened the case and found that the cable connecting the front ports was not connected. It either came out during shipping or was never connected at the factory. I reconnected the cable and everything is working!

Check out current deals!


Shop current deals

Top Kudoed Authors