Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Serial Port
Posts: 61
Registered: ‎06-28-2008
Location: Raleigh / RTP
Message 11 of 14 (1,240 Views)

Re: Hi Speed USB Ports on M58e

Problem solved. But first, the background. 

 

I finally gave up and returned the computer to the distributor who supplied it to me. Their super techs worked on it for a while. Then I got an email that it was ready. When I got there, I plugged my USB drive into a port to make sure that the computer was, in fact, recognizing a high speed device. Sure enough, no warning. I checked Device Manager to see if there was an entry for Enhanced USB. Nope. Thinking that these super techs really knew their stuff, I brought it back home.

 

When I got it here, I tried to do an image of the hard drive. The USB port was dog slow. During dinner, it occurred to me what was going on. Sure enough, when I checked the properties on the USB controller in Device Manager, the bozos had checked the box to ignore any USB errors. They had not fixed the problem.

 

Remembering something I was told on this board, I decided to try one more thing. After I booted into the BIOS (one of the two machines had just had its BIOS flashed), I pressed F9 to reload the default values. I configured everything else the way I wanted it. When I rebooted into Windows, the enhanced driver loaded. Problem solved. 

 

It never occurred to me to set the BIOS to default values on a new computer. Let me recommend to anyone who buys a Lenovo computer, check to see if the "enhanced" USB driver is loading. If not, go into the BIOS, and reset it to the default values. Resetting the second computer solved the problem there, as well. Since these computers use Intel motherboards, it would not surprise me if the problem is not fairly widespread. 

 

I hope this thread helps someone. It has been a challenging problem to solve. pagroundhog, thanks again for your suggestions. Let me know if you have run into the problem I've described.

802.11n
Posts: 228
Registered: ‎10-19-2011
Location: PA
Message 12 of 14 (1,238 Views)

Re: Hi Speed USB Ports on M58e

[ Edited ]

Finally good news!  Glad to hear it is finally fixed!  However, the fix being realized by resetting your bios to default values would indicate there is something in the bios that controls those enhanced usb controllers. Anyway, congratulations and I hope you can (now) take a few minutes to enjoy your new PCs.

Serial Port
Posts: 61
Registered: ‎06-28-2008
Location: Raleigh / RTP
Message 13 of 14 (1,227 Views)

Re: Hi Speed USB Ports on M58e

[ Edited ]

The hardware is absolutely controlled by the BIOS. In this instance, whatever control the BIOS has on the enhanced ports was not being exerted. Resetting the BIOS to default values asserted that control. Apparently this problem is common at least with Lenovo computers because a guru on this forum is where I learned it. It just never occurred to me that the BIOS could be an issue since the computer was flashed with the latest and showed that it had the latest. Live and learn. It also never occurred to me that a brand now, out-of-the-box computer would need to have its BIOS reset to default values. 

 

The real give away was when the computer wanted to take forever to create an image of itself on an external drive. It became abundantly clear at that moment that the problem was at the hardware level and not in Windows since I booted to the imaging software disk. (Image for Linux by TerabyteUnlimited) Now that I reflect back over the years and think about the number of Lenovo computers that I have imaged, I can recall several of them that have taken a long time to image. Since it has never been my routine to flash the BIOS in a new computer, I'm sure that I have computers out there where the USB ports are not activated for high speed. That problem is now something I will immediately check on every computer, especially if it is an Intel/Lenovo.

Punch Card
Posts: 10
Registered: ‎05-24-2015
Location: US
Message 14 of 14 (187 Views)

Re: Hi Speed USB Ports on M58e

[ Edited ]

Sorry to bump such an old topic but had exact problem here with motherboard from M58e I recently acquired second-hand.  After updating to latest BIOS then installing both XP and W7 for testing, when plugging in USB 2.0 flash drive I received the error "this device could be faster if you plugged into Hi-Speed USB 2.0".  I know this chipset is supposed to have USB 2.0 on all ports.  I discover that only USB 1.x host controllers were installed in Device Manager.  No USB2 Enhanced (27CC) as there should be.  Tried everything, software and driver wise (installed Intel Chipset INF software).  Checked through BIOS looking for USB configuration, but it does not provide settings to enable/disable USB 2.0 (Hi-Speed) mode.

 

Finally, I cleared/reset CMOS, entered BIOS and loaded Optimal Defaults, Saved and Exit (using PS/2 keyboard with NO USB devices attached).  Voila!  USB2 Enhanced Controller detected and installed on next boot.

Top kudoed Authors