cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Havok
Paper Tape
Posts: 3
Registered: ‎06-16-2013
Location: Lady Lake, FL
Views: 3,238
Message 11 of 13

Re: rereRe: Lenovo M58 PCI Serial Port and PCI Simple communications controller drivers.

Hello

 

Question how can I get Windows 2003 R2 32 bit installed on a M58P AL5 I see that Richard got his OS installed and I wrote to him but have not got a reply back yet. I do know first hand that Windows 2008 & 2012 both install without any trouble I'm sure it is a driver problem but not sure on how to fix it.

 

As soon as it gets past the copying windows files and installing Windows it goes to the blue screen. I tried F-8 to install drivers and it states no floppy drive found.

 

Little help would be nice for the work around.

 

Thanks

 

Greg

Havok
Paper Tape
Posts: 3
Registered: ‎06-16-2013
Location: Lady Lake, FL
Views: 3,183
Message 12 of 13

Re: rereRe: Lenovo M58 PCI Serial Port and PCI Simple communications controller drivers.

Hello

 

I hope you can help me also, I got Windows 2003 installed at long last but can't find a file to install the  simple communications controller would it be possible for you to tell me how to install this driver?

 

Thank you for your time.

 

Greg

tacoma50
Paper Tape
Posts: 2
Registered: ‎02-02-2016
Location: USA
Views: 1,217
Message 13 of 13

Re: Lenovo M58 PCI Serial Port and PCI Simple communications controller drivers.

Solution Found for missing "PCI Simple Communicator Port" and "PCI Serial Port" drivers:
 
I have a Lenovo m58p ThinkCentre 6137-aus running windows 7 64bit
 
I reformatted the hard drive and reinstalled windows using my retail "windows 7 64bit with SP1" DVS
 
Then I noticed in device manager that these items where missing their drivers as there was a yellow exclamation point next to them:
 
 - PCI Simple Communicator Port
 - PCI Serial Port
 
This is what I tried: 
 I installed all the windows updates, no luck
 I tried all the stuff talked in this forum, no luck
 downloaded and installed various AMT and other drivers, no luck
 Used Intel's DRIVER UPDATE UTILITY to update my chipset, no luck  (https://downloadcenter.intel.com/download/24345/Intel-Driver-Update-Utility)
 updated my BIOS to 5ckt77aus 5/7/2012, then reinstalled w7, no luck
 
Here's what fixed it for me.
  reformat  hard dive
  reinstall windows, but this time don't use "w7 64b w/SP1", I used an older "windows 7 64bit" DVD that did not have SP1.
  after reinstall, everything was fine, the PCI ports where no longer flagged in device manager
   (actually I don't recall if the devices were fine just after the windows reinstall or after all the windows updates installed)
 even after installing SP1 it is still fine

Check out current deals!


Shop current deals

Top Kudoed Authors