English Community

ThinkCentre DesktopsThinkCentre A, E, M, S Series
All Forum Topics
Options

2 Posts

04-01-2016

ZA

3 Signins

29 Page Views

  • Posts: 2
  • Registered: ‎04-01-2016
  • Location: ZA
  • Views: 29
  • Message 1 of 3

Lenovo M91p Desktop not booting with new graphics card (Blank screen no BIOS)

2016-04-01, 9:29 AM

Hi all

 

I have recently bought a Lenovo M91p thinkcenter Desktop as an upgrade to my old i3 PC.

 

Old Spec is as follows:

  • Coolermaster Thunder 600W power supply
  • Intel DH55HC motherboard
  • i3 CPU
  • Radeon HIS HD 7950 Graphics card
  • 8GB RAM
  • 500GB HDD

I have transferred my old 500GB HD and Power supply to the new Lenovo desktop and everything booted fine.

Then I installed 2x 2GB extra into the Lenovo M91p (Making it 8GB), and upgraded the 500GB HDD to a 1TB.

 

So my new spec is as follows:

  • Coolermaster Thunder 600W power supply
  • Lenovo Q67 motherboard
  • i7 2600 3.4 Ghz CPU
  • 8GB RAM
  • 1TB and 500GB HDD

Everything Booted fine. Then I tried to install my old Graphics card (The Radeon HIS HD 7950 Graphics card). All i got was a blank screen, no beeps, no BIOS... Nothing.

At first, i thought my power supply wasn't enough... So i tested a 750W power supply in the pc. Still nothing.

Then I thought the motherboards BIOS was outdated... Updated it... Still nothing. I even tried updating the firmware of the graphics card. Nothing.

The graphics card definitely works because I tested it in my old machine and it worked 100%.

However, I took my graphics card to my supplier, and he tested it on another one of his PCs... Didn't work there either.

My PC's BIOS doesn't have support for secure boot, in case anyone wants to know.

I have run out of ideas now... Any one able to help?

 

Solved! See the solution
Reply
Options

4368 Posts

01-01-2012

US

8037 Signins

122228 Page Views

  • Posts: 4368
  • Registered: ‎01-01-2012
  • Location: US
  • Views: 122228
  • Message 2 of 3

Re: Lenovo M91p Desktop not booting with new graphics card (Blank screen no BIOS)

2016-04-01, 14:25 PM

There's a white list of graphics cards the BIOS will recognize. The HD 7950 is a 180w card, well in excess of what the factory power supply can provide for (and the case/fans sufficient cooling for), and is not one that Lenovo would provide BIOS support for.

 

Use the search engine above to see what cards other owners have successfully used in their M91p.

__________________________________________________________________________
I do not work for Lenovo. I do not respond to Private Messages for help, your questions should be posted in the appropriate forum where the information exchange may help others. If I helped you, click the 'Thumbs up' button, if solved, the 'Accept as solution'.

0 person found this solution to be helpful.

This helped me too

Reply
Options

14 Posts

01-17-2016

GB

61 Signins

461 Page Views

  • Posts: 14
  • Registered: ‎01-17-2016
  • Location: GB
  • Views: 461
  • Message 3 of 3

Re: Lenovo M91p Desktop not booting with new graphics card (Blank screen no BIOS)

2016-04-19, 14:10 PM

Running with EVGA GeFoce GTX 750 Ti here with no issues on Win10.  Power supply is Cosiar CX430.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete