cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Kenducis
Paper Tape
Posts: 1
Registered: ‎01-04-2018
Location: GB
Views: 829
Message 1 of 1

Lenovo M92p won't boot and no output with GPU

Hello. I recently bought a used Lenovo M92p. It booted just fine and recognized my GPU with no issues, but the BIOS had a password so I had to reset the CMOS. After that it booted to bios but my display remained black. I tried plugging it to motherboards display port but still no image. So I tried unplugging everything and booting with one ram stick and it booted to bios. After putting it back I understood that the issue was GPU. As soon as I plugged in the GPU it won't display anything. I tested it on another PC and the GPU was fine(it's a Quadro 2000D if it helps) so I tried my other spare GPU's including GT 210 but the same result. So I ignored the need for GPU and tried booting it without. All of my installation USB's ended up with winload.exe and winload.efierrors(tried to boot both UEFI and Legacy) and all of my DVD's just got stuck at Windows logo and wouldn't even display the loading circle or any error message. I am stuck. I tried to download multiple ISO's from multiple sources with no luck. I have heard that Lenovo motherboards come with some sort of security stuff that can prevent it from booting but I have no clue what it is and how it works. Please help since I have ran out of ideas. Thanks

Check out current deals!


Shop current deals

Top Kudoed Authors