Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Punch Card
Posts: 6
Registered: ‎08-20-2009
Location: Singapore
0 Kudos

Lenovo Trust Key Error

As per subject, about a month back i've ran a system update on my ThinkCentre A60 9631-AD5 running on windows vista business edition. Immediately after the installation a reboot was prompted hence i rebooted the com. But to my horror once after start up a error msg was stated usbkey.dll was not found. However i am still able to enter windows after i click onto OK on the error msg box. But 2 more similar error msg box countinued to pop out and i have to click ok at least twice on both boxes before windows goes any further.


Apparently nothing much is wrong with the system am still able to use it as per normal. I've also tried to uninstall the Lenovo trust key program via the  control panel but was unable to do so as similar error box pops out saying something missing on the usbkey.dll. Have tried to do a system restore but was unsuccessful too. Well a month has past and this error is finally driving me nuts till i had to post this msg hoping someone here could help me with this issue. Thanks in advanced.

Punch Card
Posts: 6
Registered: ‎08-20-2009
Location: Singapore
0 Kudos

Re: Lenovo Trust Key Error

help anyone ??? i really do not wish to do a reformat