Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Paper Tape
Posts: 5
Registered: ‎05-04-2012
Location: Bay Area, CA
0 Kudos

Line In device unavailable in Recording Devices even though works

This is a ThinkCentre M58p (6137) desktop. I am working with software that detects available recording devices and it does not detect Line In because Windows is reporting as "currently unavailable". It shows the driver is loaded correctly and I have ensured I have the latest audio driver (2009) off the drivers page. It also only sees the Microphone jack on the front and not the one on the back. I ran through the Windows (Win 7, 64-bit) audio diagnostic which said nothing. I'm having similar problems on Win 7, 32-bit and Vista 64-bit machines with same hardware. To make things worse, sometimes it will show one device and sometimes another. Actually having audio playing through Line In does not change the problem. Any suggestions are very welcome. Thanks.

Posts: 955
Topics: 3
Kudos: 80
Solutions: 65
Registered: ‎01-05-2010
Location: INDIA
0 Kudos

Re: Line In device unavailable in Recording Devices even though works

Hello shiftgeek,


Kindly roll back the audio driver and uninstall it from the device manager after this restart the system


Download the audio driver and install it then check.

After this the audio setting should come to default



Best Regards,


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!