cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
YGRIG
Token Ring
Posts: 23
Registered: ‎12-24-2017
Location: RU
Views: 1,341
Message 1 of 11

M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

I have got a ThinkCentre M83 SFF Pro Type 10AN-S02E00 that has been working for three years on the original BIOS from the year 2014, probably version FBKT74A or so. This week I moved to Windows 10 and decided to also update BIOS to the latest version, since FBKTB4A "added Win10 support" according to changes.txt, and also there has been important security fixes regarding Intel ME, so I downloaded the latest version FBKTCLA and run the update.

The problem is, I know there are two parts in updating the BIOS on these systems (I also got an M93p Tiny), and in my case the first part (afudos.exe imagefb.rom /p /r) runs OK (erasing,updating and verifying main block), but the second part (afudos.exe imagefb.rom /defans /capsule /b /n /r /sp) fails right before erasing giving me

15 - Error: Secure Flash function is not supported on this platform

and after that no reboot and no second part of the update.

error_15_bios_update.jpg

After this my system boots OK and BIOS version is reported as FBKTCLA with BIOS date 11/17/2017, but

  • boot block is FB72A
  • embedded controller is FBCT13A
  • CPU microcode is 306C3_00000017 (08/16/2013)
  • ME version is 9.0.20.1447
  • UEFI diagnostic tool is v. 02.09.09
  • Intel VBIOS version 1030

So I got the newest BIOS, VBIOS and newest UEFI diagnostic tool but still got old boot block (should be FBCLA), EC (should be FBCT32A), CPU microcode (should be 306C3_00000021 05/10/2016) and ME firmware (should be 9.1.41.3024)

The system works and I have no problems with my Windows 10 install, luckily this BIOS update failure did not brick the system, but I am stuck with vulnerable version of Intel Management Engine. My M93p Tiny 10AB-0011US received the same BIOS updates over the years and now at the same latest version, but the updates were done every few months or so. Maybe the 3 year leap in BIOS construction messed something up.

It does not feel like a big problem, but any failure updating BIOS is rather scary and probably should be fixed.

bundies522
Punch Card
Posts: 11
Registered: ‎11-25-2018
Location: US
Views: 793
Message 2 of 11

Re: M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

It appears that Lenovo has been totally silent on this issue. And you're not the only one. Other threads turn up in a similar search for this error, but Lenovo has not commented on any cause or suggested any fix.

 

I ran into this issue and it's causing some trouble for me as well. The issue is still persistent 1 year later, yet no comment.

bundies522
Punch Card
Posts: 11
Registered: ‎11-25-2018
Location: US
Views: 766
Message 3 of 11

Re: M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

Hey there, I wanted to reply to let you know that I believe I found a solution to your issue:

 

https://forums.lenovo.com/t5/ThinkCentre-A-E-M-S-Series/M93p-Tiny-BIOS-FBKTD2A-is-broken-bad-BIOS-up...

 

In your scenario, since you have identified that you have Boot Block version FB72A, you will need to start from the 72 BIOS in recovery USB maintence mode, then go to 74 from in Windows, then D2 in Windows.

 

https://download.lenovo.com/pccbbs/thinkcentre_bios/fbjy72usa.exe

https://download.lenovo.com/pccbbs/thinkcentre_bios/fbjy74usa.exe

https://download.lenovo.com/pccbbs/thinkcentre_bios/fbjyd2usa.exe

 

Since this issue has been ongoing for a whole year and you have not received any response, please considering not buying a Lenovo product ever again. I've made my decision after this experience.

nofxman
Paper Tape
Posts: 4
Registered: ‎01-07-2019
Location: FR
Views: 621
Message 4 of 11

Re: M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

Hi,

 

Thank you for all the messages.

 

In my scenario, i have identified that i have Boot Block version FB71A.
So if i understand, I will need to start from the 71 BIOS in recovery USB maintence mode, then go to 74 from in Windows, then D2 in Windows.

 

But

https://download.lenovo.com/pccbbs/thinkcentre_bios/fbjy71usa.exe

 

is no available

 

So please which version, i need to download?

Thank you in advance

bundies522
Punch Card
Posts: 11
Registered: ‎11-25-2018
Location: US
Views: 609
Message 5 of 11

Re: M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

 

In my scenario, i have identified that i have Boot Block version FB71A.
So if i understand, I will need to start from the 71 BIOS in recovery USB maintence mode, then go to 74 from in Windows, then D2 in Windows.

 

But

https://download.lenovo.com/pccbbs/thinkcentre_bios/fbjy71usa.exe

 

is no available

 

So please which version, i need to download?


You may need to do a little bit of trial and error, but I would try flashing either one release older or one release newer in maintenance mode.

 

I would try upgrading to 72 first, and if that doesn't put them on the same boot block/main block then I would do a downgrade.

https://download.lenovo.com/pccbbs/thinkcentre_bios/fbjy72usa.exe

 

56 seems to be the closest available downgrade: https://download.lenovo.com/pccbbs/thinkcentre_bios/fbjy56usa.exe

 

 

nofxman
Paper Tape
Posts: 4
Registered: ‎01-07-2019
Location: FR
Views: 588
Message 6 of 11

Re: M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

Thank you for answering,

Everything was perfect.

 

I installed fbjy74usa,  fbjyd2usa and the last fbjyd4usa

 

But after I tried to update EC with utility you have provided, and bricked the computer. ( I used the command SPIW0323.exe FBCT32A.bin /V 32A to not reflash the whole BIOS and the computer has freeze)

Do you have any solution?Now, I have only black screen and nothing more Smiley Sad

Your utility is only for fbjyd2usa?

 

Thank you for your help !

bundies522
Punch Card
Posts: 11
Registered: ‎11-25-2018
Location: US
Views: 580
Message 7 of 11

Re: M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

My first question: When you say black screen, when does the black screen occur? Do you not see anything when you press the power button? Do you see a Lenovo logo? Do you see a Windows boot logo but nothing else?

 

You shouldn't have needed to do the manual EC firmware flash, that was only for a rare EC flash failure with the "32A" controller firmware in older packages. Even so, I'm not sure how it could have rendered your system unbootable.

 

However, I encountered a black screen once as well. You should be able to recover from it by doing a maintenace mode flash from USB of the latest BIOS you successfully installed. So in your case, that would be D4.

 

1. Download the D4 setup onto another computer and extract it.

2. Inside of the folder where you extracted the BIOS, look for the IMAGEFB.ROM file.

3. Format a USB flash drive as FAT32. Copy the IMAGEFB.ROM file from the extraction folder to the root of the flash drive.

4. Shut down the computer. Open it up, move the CLR CMOS jumper to the recovery position.

5. Plug the flash drive with the ROM file on it into the system, then power it on. The system will beep a few times, flash the Main Block, and then turn off. When it's turned off. Remove the flash drive, and move the CMOS jumper back to the original position.

6. Close up the system and power it on. It will say invalid configuration. Press F1 to enter setup. You should now see the BIOS revision and boot block are the same version. Scroll to the Exit tab, save config and exit.

 

Also, after you flash, make sure you enter the BIOS and verify that the main block and boot block are the same after this. You may also want to have a look at the EC firmware version to see what it says. Make a note of this.

 

Once you exit and boot into Windows, assuming your boot block is D4, I would re-run the Flash.cmd from the D4 bios to make sure that the full bios flashes including the EC from the latest package. You will not need to run the SPIW0323 utility separately

nofxman
Paper Tape
Posts: 4
Registered: ‎01-07-2019
Location: FR
Views: 569
Message 8 of 11

Re: M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

Thank you for helping me Smiley Happy

 

When you say black screen, when does the black screen occur? Directly, at the boot , when i turn on the computer.

Do you not see anything when you press the power button?No nothing

Do you see a Lenovo logo?No

Do you see a Windows boot logo but nothing else? No windows logo , only black screen.

 

Step 2  : I extracted USB Drive UEFI BIOS Flash Package FBKTD4A , copy  IMAGEFB.ROM .  I need to create a bootable usb key or it is automatic when i copy the file?

 

Step 5 : There is no beep, no sound, and nothing on the screen.

 

Thank you

bundies522
Punch Card
Posts: 11
Registered: ‎11-25-2018
Location: US
Views: 564
Message 9 of 11

Re: M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

Step 2  : I extracted USB Drive UEFI BIOS Flash Package FBKTD4A , copy  IMAGEFB.ROM .  I need to create a bootable usb key or it is automatic when i copy the file?


As long as the flash drive is formatted FAT32, you don't need to do anything else to it. As long as it contains IMAGEFB.ROM the system will read it when the jumper is in the maintenance mode position.

 

If it still won't read it, I'm not sure what else the problem could be, as long as you did everything correctly.

nofxman
Paper Tape
Posts: 4
Registered: ‎01-07-2019
Location: FR
Views: 558
Message 10 of 11

Re: M83 SFF fails to flash the latest BIOS (error 15 - Secure Flash)

Ok, i will try again !

You spoke about the manual EC firmware flash, please what i need to do to exactly?

 

Thank you

Check out current deals!


Shop current deals

Top Kudoed Authors