Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
What's DOS?
Posts: 1
Registered: ‎04-29-2012
Location: Australia
0 Kudos

M91 p video driver

Hi all,


System update does not pick up Video drivers after re-imaging the machine. I am imaging the machines with WIndows XP. This is random and I have not been able to come up with a logical solution for this one.


Is anyone having any similar issues with these machines. 



Retired Employee
Posts: 2,836
Registered: ‎03-20-2012
Location: Malaysia
0 Kudos

Re: M91 p video driver

Hi Pjain,


I can't say that i have faced the same issues as you did, but one of my co-workers had more or less the same issue as you did with his personal M91. He had his machine imaged to XP aswell and upon trying to update the drivers through windows update, the drivers was just not responsive. However i did suggested to go to the lenovo support site directly and downlod the drivers there. Next thing you know it working as good again.


I would suggect you do the same, by goting to this link :, Worth checking it out in the long.


Do let let me know how it turns and maybe i can try to look further in to this.






Posts: 293
Topics: 2
Kudos: 16
Solutions: 10
Registered: ‎02-01-2012
Location: Inda
0 Kudos

Re: M91 p video driver

System update does not pick up the video driver after re-imaging the system, To diagnose, I would suggest you to please update the Video driver and also update the Bios of your system from the below mentioned web link.


After this, please restart the system and check if the issue resolved.



Thanks & Regards,


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!