Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkCentre DesktopsThinkCentre A, E, M, S Series
All Forum Topics
Options

5 Posts

09-16-2015

New Zealand

5 Signins

46 Page Views

  • Posts: 5
  • Registered: ‎09-16-2015
  • Location: New Zealand
  • Views: 46
  • Message 1 of 1

M93p Tiny : Win10 Audio Drivers DTS HD / Dolby TrueHD / Bitstream

2015-09-16, 12:07 PM

Didnt even check this before upgrading to Win10, but does the M93p tiny even support DTS HD and Dolby TrueHD ?

 

I am using a DP > HDMI which shouldnt cause an issue but have tested with  HDMI > HDMI. Here is the long story.

 

The DP interface appears to be using some Microsoft High Definition Audio Device driver for the audio and only shows DTS Audio, Dolby Digital and Dolby Digital Plus, however lists the correct bit depths and sample rates for the HD formats which happens to be 'more' than my other PC that can do DTS HD MA and DD TrueHD.

 

Disabling the Microsoft driver disables the entire playback device, which is the same output receiver device as my other PC. just to say that both M93p tiny and my normal PC are going through the same amplifier to the same flat panel.

 

When pulling the cable from the PC that can do full HD audio and plugging into the m93p tiny, there is no audio going to the amp at all, picture is fine. Plug back into original PC and audio works fine. indicator m93p tiny audio problems.

 

As when using the DP, the HDMI when using the realtek HD Audio driver pushes all audio out to the internal speaker inside the m93p tiny box :) the flat panel receiver (passing through my amp) says its not plugged in, clearly it is and picture is showing, just no sound.

 

so i went to Lenovo site and installed the latest Win10 audio drivers and codecs.

no changes

went to the Realtek site and downloaded their latest drivers from june???

no changes

 

checking the Intel HD display drivers, it is definitely seeing the flat panel fine through the amp.

tried updating these with the correct version HD Graphics 4600. downloaded win10 package from last week, the latest. said it didnt recognize the hardware.

ran the Intel drivers detect utility, and its results were 'customised computer manufacturer driver installed'...

 

so this looks like a Lenovo issue now? the intel site thankfully takes me to the Lenovo site to download the driver, updated yesterday?

ran installer and says it didnt recognize the hardware

 

so... install the Lenovo hardware detector tool, detects me as M93p 10AB000KUS which i agree with.

sends me to download the same graphics package which of course fails to install.

the Lenovo system update tool prompted me to install a bunch of unrelated softare which i declined.

 

Conclusions

HD Audio drivers are broken. The Microsoft drivers that automatically install somehow only partially work and only with DP, not HDMI.

Either this is a Lenovo issue or it is an Intel HD Graphics 4600 driver issue, or both.

 

Anyone have any ideas or solutions?

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms