cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Xray
Paper Tape
Posts: 3
Registered: ‎09-12-2013
Location: United States
Views: 67,672
Message 1 of 11

M93p and ACPI Drivers for Windows 7

Hello All,

 

Our firm is starting to incorporate the Lenovo Tiny Model M93p (Type 10AB) into our Windows 7 deployment process using MDT 2012.  We've run across the ubiquitous "Unknown Device" message in Device Manager.  The hardware ID is ACPI\LEN4001.

 

There was a similar problem with the M92p models, and the ACPI Driver for that model was found here: http://support.lenovo.com/en_US/downloads/detail.page?DocID=DS029250

 

I tried the usual starting point: http://support.lenovo.com/en_US/detail.page?DocID=PD027573 to look for a similar driver for the M93p, but so far, I've had no luck.

 

Has anybody run into the same problem that I'm seeing?  If so has it been addressed or do we just have to wait?

 

Thanks,

Rex

Community SuperMod
Community SuperMod
Posts: 5,462
Registered: ‎06-26-2008
Location: US
Views: 67,665
Message 2 of 11

Re: M93p and ACPI Drivers for Windows 7

Good day and welcome to the community.

 

Your model's Driver Matrix: http://support.lenovo.com/en_US/downloads/detail.page?&DocID=DS035533 may be helpful.

 

While I don't see a specific "ACPI" item listed, looking at the readme for the Lenovo Application Interface item:

http://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkcentre_drivers/c1acp21us17.txt

and comparing it to the M92p driver description from your link, makes me think it may be what you're seeking.

 

Hope this helps a bit.


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKTRMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.

I am not a Lenovo employee.

Xray
Paper Tape
Posts: 3
Registered: ‎09-12-2013
Location: United States
Views: 67,652
Message 3 of 11

Re: M93p and ACPI Drivers for Windows 7

Hello Sarbin,

 

Thank you very much.  That was quite helpful.  It is exactly what I was looking for.  I also appreciate your extremely prompt reply.  Top notch.

 

Thanks once again.

Rex

 

Community SuperMod
Community SuperMod
Posts: 5,462
Registered: ‎06-26-2008
Location: US
Views: 67,646
Message 4 of 11

Re: M93p and ACPI Drivers for Windows 7

You're quite welcome. Glad I was able to help.

Best of luck with your deployments!

 

Cheers.


Community GuidelinesSearchPrivate MessagingENDEESPTRUUACZ-SKTRMoto
PM requests for individual support are not answered. If a post solves your issue, please mark it so.

I am not a Lenovo employee.

HeavyChevy3500
Paper Tape
Posts: 3
Registered: ‎09-16-2013
Location: Minnesota
Views: 67,529
Message 5 of 11

Re: M93p and ACPI Drivers for Windows 7

Are you using WinPe to pull the image? 

 

did you have any issues with the usb dropping the connected devices in WinPE? What drivers did you use?

Xray
Paper Tape
Posts: 3
Registered: ‎09-12-2013
Location: United States
Views: 67,516
Message 6 of 11

Deployment Tools

Hello HeavyChevy,

 

Yes, I am using WinPE for image deployment, but no I am not experiencing any USB issues.  I am using the drivers that are referenced in Sarbin's link to the Driver Matrix: http://support.lenovo.com/en_US/downloads/detail.page?&DocID=DS035533.

 

I don't know if this would make a difference, but I am using MDT 2012 Update 1: http://www.microsoft.com/en-us/download/details.aspx?id=25175

 

and I am also using WinPE 4.0.  This might make the difference because WinPE 3.0 shipped with the WAIK for Windows 7 whereas WinPE 4.0 comes with the Windows ADK (Windows Assesment and Deployment Kit which is the successor to WAIK).  You can find it here: http://msdn.microsoft.com/en-us/library/windows/hardware/hh825420.aspx

 

Good luck.

lsadeploy
What's DOS?
Posts: 1
Registered: ‎10-28-2013
Location: des moines
Views: 66,291
Message 7 of 11

Re: Deployment Tools

I also am using MDT 2012 Update 1 with WinPE 4 and am also trying to deploy the m93p.  Are you haveing hte same issue where it gets stuck on trying to parition the drive?  i did a F8 disk part and i can see the SSD.  I ended up changing the controller from ACHI to IDE and that fixed the problem but I want to be able to use ACHI, has anyone ran into this issue?

 

Thanks.

WaleedZM
What's DOS?
Posts: 1
Registered: ‎09-15-2014
Location: canada
Views: 49,772
Message 8 of 11

Re: M93p and ACPI Drivers for Windows 7

Actualiy this not work to me , Las this I did download the SCCM packadge and I scan the device from it and it work ,if you have win7 on the machin still have to use the driver for win 8.1 to fix it

 

http://support.lenovo.com/ca/en/products/desktops-and-all-in-ones/thinkcentre-m-series-desktops/thin...

 

thanks

spardee
Paper Tape
Posts: 4
Registered: ‎01-19-2015
Location: Pennsylvania
Views: 41,275
Message 9 of 11

Re: M93p and ACPI Drivers for Windows 7

Can you PLEASE update the links for the drivers? I really need this driver.
spardee
Paper Tape
Posts: 4
Registered: ‎01-19-2015
Location: Pennsylvania
Views: 41,274
Message 10 of 11

Re: M93p and ACPI Drivers for Windows 7

Honestly, I don't want the Lenovo Power Manager either.. that is what the Windows Power Settings control panel item is for.....

Check out current deals!


Shop current deals

Top Kudoed Authors