cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frankf9nz
Paper Tape
Posts: 4
Registered: ‎08-05-2008
Location: Seneca Il
Views: 1,428
Message 1 of 3

No drivers after recovery

Well, it's been a fun day.  After getting no replies to my posting about the drivers that wouldn't load, I decided to reload the OS from the RNR partition.   Of course F11 didn't work, so I had to fix the MBR with that little diskette DOS program.   Then the reload proceeded OK until I had to "activate" XP.    After 45 minutes on the phone with Microsoft, I was able to get that done.  Neither the 9 blocks of numbers nor the 5 blocks of alpha-nums worked.  Finally!   I have XP running, but wait!   I still can't connect to the internet.  A visit to Device Manager tells me I now have FIVE devices with big yellow ?'s where before I only had four.   There is no IBMTOOLS directory.    So, back to the downloaded .exe files on a CD-R, and shortly I have several sub-dirs that contain .inf files that are supposed to be for the integrated Intel ethernet controller, the vga controller, the integrated sound, and another one that escapes me right now.    Surprisingly the sound driver was gobbled right up by that device, but the others are still driverless, and I am internet-less - as well as peering at a mini sized screen display.   I thought the RnR thing was supposed to restore the drivers - isn't it?   HELP.

 

 

 

 

netnubar
802.11n
Posts: 163
Registered: ‎04-27-2008
Location: australia
Views: 1,400
Message 2 of 3

Re: No drivers after recovery

Hey Frank,

 

OK. Usually, once you've downloaded the various packages (you've got em on CD) and extracted the contents of each to their designated folders, you'll still have to click on setup (in each of the folders) so that each of the drivers can be correctly installed. From your description above and your earlier post, it isn't clear that you've done this.

 

So, the process would be:

1. download package from the 'Downloads and drivers' page for your specific machine (I understand yours are on CD);

2. launch executable so that the contents can be extracted into a folder (this does not necessarily have to be the IBMTOOLS directory, but a new folder will or should be created);

3. launch setup.exe (usually) in each new folder created.

 

Message Edited by netnubar on 08-08-2008 12:25 AM
Lenovo Employee shumpert
Lenovo Employee
Posts: 131
Registered: ‎11-27-2007
Location: US
Views: 1,387
Message 3 of 3

Re: No drivers after recovery

The previous advice posted is spot on.

 

But I just wanted to also say something about what's happening with your system.  Typically when you see these kinds of errors (need to activate, no drivers/apps loaded, etc) after a recovery it means that the recovery was interrupted before it could install all of the packages for your system.  This results in a system with nothing more than the the default Windows OEM software and a lot of uninstalled packages (aka compressed files) on the hard drive.

 

What we typically do in the lab in these instances is do the recovery again and leave it alone once it boots into windows the first time.  A total recovery of the system using cds takes anywhere from 1-2hrs depending on the system and the amount of data being transferred.  For a recovery from the rescue partition its a little bit less (no need to copy from slower cds/dvds).

_____________________________
Ed Shumpert
Service Operations Manager
NA Service & Support

Check out current deals!


Shop current deals

Top Kudoed Authors