Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkCentre DesktopsThinkCentre A, E, M, S Series
All Forum Topics
Options

2 Posts

11-21-2019

Hungary

4 Signins

92 Page Views

  • Posts: 2
  • Registered: ‎11-21-2019
  • Location: Hungary
  • Views: 92
  • Message 1 of 1

Power Management setting problem with Ethernet card I217-LM

2019-11-21, 13:39 PM

Dear Community,

 

I could configure the desktop to response the Wake on Lan Magic Packet, but I cannot set the Wake On Pattern Match feature. I think the driver has a bug and I cannot find a workaround for this!

 

When I try to enable the "Allow this device to wake the computer" feature (@ Control Panel / Device Manager / Network Adapter / Inter(R) Ethernet Connection I217-LM / Properties / Power Manager). I can see three checkboxes. When all three are unchecked, then first is in enabled state, other two are disabled. This means that when I DO NOT ALLOW for the computer to completely turn off the device, then I'm not able to let this device to turn on the computer. It makes no sense! Then when I check the first checkbox, then the second become enabled. So when the desktop is allowed cut off the electricity to card after shut down, it is allowed to wake it up! :) I checked and the LAN Link LED is off in this state (so maybe I'm allowed to wake it up (in theory), but I can not :) )

 

  

 

I can only enable the Wake-on-magic-packet feature if I first I check all three checkboxes and then I uncheck the first one. So definitely there is a bug, but there is a workaround to it.

 

If I set some other settings (Enable: Advanced / Wake on Magic Packet; Uncheck(!): Control Panel / Power Options / Choose what the power button does / Turn on fast startup) as well I'm able to wake up this desktop from hibernated or shutdown state nicely!

 

Stage #2: I would like to wake up the PC when TCP SYN initiated. For this I have to turn on the Wake on Pattern Match feature, meanwhile uncheck the "Only allow a magic packet to wake the computer". And this is what I cannot achieve. When I leave the Power Management tab I can get the uncheck-check-check state or the uncheck-unchek-unchek state, but not the unchek-check-unckec state. Or when finaly I reach this state and I reboot, it become modified for some reason.

 

Do anyone has an idea what should I set to get the "Allow this device to wake the computer" checked and keep the "Only allow a magic packet to wake the computer" unchecked.

 

How can I report this issue? I would like to see this fixed...

 

What is more if in Advanced tab of this device I Enable the Wake on Pattern Match property I cannot set which pattern I would like to use (IMHO these should be set: NetBIOS Name Query; TCPv4 SYN; TCPv6 SYN; IPv6 Neighbor Solicitation).

 

Thanks for everone!

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms