Support in other languages: 
Showing results for 
Search instead for 
Do you mean 
Welcome to the Lenovo Community

Welcome to the Forums!

Welcome to Lenovo's Peer-to-Peer Discussion Community!
Please note our guidelines. How to register and login and Community FAQs.
Shape the Future of PCs

Help Lenovo Shape the Future of PCs

Take the ownership survey. Share your ideas with our product team
Community Spotlight

Visit the Lenovo Blogs!

Check out the ThinkPad Time Machine
Visit the Community Spotlight Blog
Windows  10

Are you ready for Windows 10?

Get to know Windows 10
Visit the Windows 10 Support Center
Paper Tape
Posts: 3
Registered: ‎09-01-2010
Location: Jacksonville, FL
0 Kudos
Accepted Solution

Problems adding RAM to M58p

I have a M58p 3484-Y2S with 2x 2gb sticks of RAM running Win7 x64.  I purchased 2x 2gb sticks of RAM to add. When I add the RAM, I get the Memory Error beep (1-3-3-1).  I've tried booting with just one of the new sticks, or both new sticks with the same results. I doubt I was shipped two bad sticks of RAM. It seems as if it's the wrong RAM, but it seems to be right.


Computer: M58p 3484-Y2S

New RAM: Crucial 2GB 240 Pin DIMM DDR3PC3-10600 UnBuffered; model # CT25664BA1339


Lenovo's recommended RAM:


RAM I purchased:


Any idea what's going on here?

Paper Tape
Posts: 3
Registered: ‎09-01-2010
Location: Jacksonville, FL
0 Kudos

Re: Problems adding RAM to M58p

Turns out the problem was the subset of RAM. Curcial specified the 'generic' part we needed. However, specifically, the motherboard only supports the 16-chip style of ram -- 8 chip on each side of the board.
Blue Screen Again
Posts: 3
Registered: ‎06-05-2014
Location: USA
0 Kudos

Re: Problems adding RAM to M58p

After many hours of frustration I just came across your post.  I'm hoping this is the solution to my M58 RAM upgrade as well.  I'm curious what RAM module ended up working.  Was there a Crucial module that worked or was there another mfr?


Thanks for any advice.

Fanfold Paper
Posts: 6
Registered: ‎06-26-2014
Location: USA
0 Kudos

Re: Problems adding RAM to M58p

I had a similar issue when I purchased and installed an additional 4gb of ram, from my parts vendor.

I got post errors (beep codes)  The modules aren't oem, but they are a reliable and competent parts vendor.

They only sell memory and hard drives and they said they were compatible, plus the last 2gb stick I bought form them worked fine. So I called them.


It turned out that I just needed to update the bios to support more than 4gb,now my m58p 7220 has 8gb and it works fine.


If you'd like a link to my vendor and the modules I used, message me and I'll dig up the receipt and send you a link to the vendor (4gb cost me like 40 bucks I think) the bios update is easy to find on this site, I'm sure you'll have no trouble there.



``All parts should go together without forcing. You must remember that the parts you are reassembling were disassembled by you. Therefore, if you can't get them together again, there must be a reason. By all means, do not use a hammer.'' -- IBM maintenance manual (1925)