cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ambrougham
Paper Tape
Posts: 1
Registered: ‎12-20-2010
Location: UK
Views: 1,050
Message 1 of 1

S50:8183-CTO with new SATA HDD and having problems installing Win2K

I'm in the process of replacing an old and very well used IBM 8182 machine with a similar set-up using the smaller and more convenient 8183.  The object is to have a multi-boot system with MSDOS/Win98, Win2K, WinXP plus at least 1 flavour of Linux available primarily for test and evaluation purposes. Everything worked just fine on the 8182 as it has also done with various other systems I've used in the samer way over the years but the 8183 is being more than a bit of a nuisance to get sorted !

What I generally do is attach the HDD to another system to prepare it first so that it's already partitioned/formatted as well as having copies of all the OS CDs/DVDs plus all relevant drivers and applications available on it when subsequently fitted  in the target system. After that it's just a case of installing each OS in the 'right' order and installing the relevant drivers/applications as required. I've done this loads of times before and never had any problems at all until now.

With the 8183, MSDOS/Win98(FE) and WinXP(SP3) are not a problem.  They both install just fine and all relevant drivers also install without any issues at all. However, Win2K(SP4) which would normally be installed prior to WinXP will not install and repeatedly fails during setup.  When the 8183 first reboots after setup has initially examined the hardware and prepared for installation it subsequently falls over because whilst it can obviously access the HDD in general and the system partition (1st partition, drive C: ) in particular to boot/run it doesn't then appear to be able to find what will ultimately be the Win2K boot partition (2nd partition, drive D: ) or presumably any of the other partitions that are already on the HDDwhen trying to 'start' Win2K before continuing with the installation.  

The HDD is a 1TB WD drive connected to a SATA port. A Liteon DVD-RW drive is connected to the other SATA port and both standard IDE (PATA) ports are unused. Partition 1 is primary and active 20GB FAT32 for all the installation/driver files etc. and MSDOS/Win98. Partition 2 is 20GB primary NTFS for Win2K. Partition 3 is 40GB primary NTFS for WinXP. An extended partition contains several logical drives with an assortment of FAT, FAT32, NTFS and other formats.

I'm guessing that the issue with Win2K setup is that it hasn't found and installed the 'right' driver(s) for the HDD interface(s) in the 8183 or simply hasn't detected them and/or the HDD sensibly at all. Either way I don't seem able to get setup to proceed any further than the 1st reboot after which I should be able to select the partition to install Win2K and continue with the installation. It just falls over with the dreaded "inaccesible boot device" blue screen and a system halt.  I am aware of HDD and SATA driver issues in general with Win2K setup so in the absence of finding something that appeared to be a suitable Intel ICH5 driver floppy to provide Win2K setup (using F6 after the 1st reboot) I even tried adding the standard Intel driver files to the copy of Win2K CD files (using the OEM pre-install drivers and unattended install procedure) but am still getting absolutely nowhere I'm afraid Smiley Sad

Am I completely missing the bleedin' obvious here or does anyone have any bright ideas as to how I can get a fully legal copy of Win2K installed using the data from a standard CD as oposed to an IBM specific install disk ?  It's clearly not a BIOS issue or a fundamental problem with the HDD and how it's prepared etc. because it's only Win2K that's having some problem or other with the 8183 and/or the HDD !

Check out current deals!


Shop current deals

Top Kudoed Authors