English Community

ThinkCentre DesktopsThinkCentre A, E, M, S Series
All Forum Topics
Options

3 Posts

12-10-2008

UK

4 Signins

30 Page Views

  • Posts: 3
  • Registered: ‎12-10-2008
  • Location: UK
  • Views: 30
  • Message 1 of 9

SATA Controller M58 7373

2008-12-10, 15:46 PM

Hi All,

 

I create and maintain all the images at work for our IBM pc's. I use one main image which boots on 98% of the models we have. The image was built on an old Netvista, I added mass storage drivers, but think I am missing something to do with sata controllers, as I also have to change the T series laptops to operate in SATA compatability mode. However the new M58 model 7373 is causing me some problems. It will sometimes boot to sysprep, then when it restarts it will fail to find the operating system I am stuck in the intel boot agent. I then go into the bios and change the settings for SATA devices. If I change the options for Native mode from Automatic to enabled, then change SATA AHCI from enabled to disabled it will boot. on the next restart it will fail, change those options again, it will start.... or will fail while starting windows. I assume this is a problem with drivers for SATA AHCI, I dont full understand it though. Can I slip stream my drivers in to my exsisting image?

 

Any help would be greatfully received!!

 

Thanks

Chris

Reply
Options

3 Posts

12-10-2008

UK

4 Signins

30 Page Views

  • Posts: 3
  • Registered: ‎12-10-2008
  • Location: UK
  • Views: 30
  • Message 2 of 9

Re: SATA Controller M58 7373

2008-12-11, 11:22 AM

Just one further point to this if I may....

 

If I make a new image on a sata pc, with the ahci drivers in it and all the mass storage drivers etc... will this boot on an older pc? I assume yes? Just that im sure I read that if I build a pc on a non ahci pc that I cant boot it on an ahci pc... or will sysprep take care of this?

 

thanks

Reply
Options

2 Posts

12-30-2008

USA

3 Signins

12 Page Views

  • Posts: 2
  • Registered: ‎12-30-2008
  • Location: USA
  • Views: 12
  • Message 3 of 9

Re: SATA Controller M58 7373

2008-12-30, 18:37 PM

Hello,

 

Not sure if you found your answer yet, but we are running into the same issue with our M58p model 7483. One thing I found was that when you disable AHCI in the BIOS, it recognizes the HDD as an IDE drive after one reboot, not as an AHCI drive, and the IDE drive is excluded from the startup sequence in the BIOS. The PC at least boots consistently after adding the IDE drive to the startup sequence, but this is sort of a crude workaround.

 

I would still like to know if Lenovo has a XP compatible SATA driver available for these systems. I don't like the idea of having to disable AHCI in the BIOS, reboot, and then add the IDE drive to the startup sequence for each new M58p we receive. We did not have to do anything like this for the M57p's that we have been using. I have a support call in with Lenovo, so I'll post back if I hear anything, but any help towards a smoother solution would be appreciated.

 

Thanks,

 Jared

Reply
Options

3 Posts

12-10-2008

UK

4 Signins

30 Page Views

  • Posts: 3
  • Registered: ‎12-10-2008
  • Location: UK
  • Views: 30
  • Message 4 of 9

Re: SATA Controller M58 7373

2009-01-05, 11:00 AM

Hi Jared,

 

I did eventually realise that turning off AHCI makes the pc recognise the HDD as an IDE device not SATA and this isnt included in the boot sequence, it did take a while for me to spot that though!

 

I havent spent much more time on this since I found the above and I automated the drivers install, however I need to look at it more! If you get any info from Lenovo, if you could post up here that would be great!

 

Thanks

Reply
Options

1 Posts

01-12-2009

Switzerland

2 Signins

13 Page Views

  • Posts: 1
  • Registered: ‎01-12-2009
  • Location: Switzerland
  • Views: 13
  • Message 5 of 9

Re: SATA Controller M58 7373

2009-01-12, 16:13 PM

Hi @all

 

Did anyone find out, how to solve that issue?

I ve got the same problem, using an m58 6239 using winxp.

 

kushkof

 

 

Ok now I got it, after I change the AHCI parameter I have to add the IDE disk in the startup sequnce.

Message Edited by kushkof on 01-12-2009 08:24 AM
Reply
Options

2 Posts

12-30-2008

USA

3 Signins

12 Page Views

  • Posts: 2
  • Registered: ‎12-30-2008
  • Location: USA
  • Views: 12
  • Message 6 of 9

Re: SATA Controller M58 7373

2009-01-12, 19:03 PM

Hello,

 

I did receive some follow-up from Lenovo and they provided a working SATA driver for us:

 

http://www-307.ibm.com/pc/support/site.wss/MIGR-70696.html

 

We were able to add that to our boot CD image to avoid having to make BIOS changes to every system we load. These drivers also worked for loading the OS from a generic XP CD using the F6 method. Lenovo support also mentioned that they can change BIOS options for custom models, so you can order M58's with AHCI disabled and the IDE devices in the startup sequence if you want.

 

Hope this helps anyone who might still be having issues.

Message Edited by Jared on 01-12-2009 11:03 AM
Message Edited by Jared on 01-12-2009 11:05 AM
Reply
Options

1 Posts

01-14-2009

Omaha, Nebraska USA

13 Signins

90 Page Views

  • Posts: 1
  • Registered: ‎01-14-2009
  • Location: Omaha, Nebraska USA
  • Views: 90
  • Message 7 of 9

Re: SATA Controller M58 7373

2009-01-14, 20:32 PM

Hrm. I'm having the same issues with AHCI on our new M58p workstations (2609-A1U). I'm able to boot and install my images with the AHCI disable as Jared has explained, but I'm trying to build a new image with using the new SATA drivers, but when I have AHCI enabled (and add them to the boot sequence) and the boot from the XP disc, I still get the BSOD screen about not being able to find a boot device (can't remember the exact error message, but looked it up when I first started to have this issue).

 

To shorten up my post, the new SATA drivers didn't help me. I'm still having to revert to having AHCI disabled. Any other suggestions?

 

 - Jon

Message Edited by jhemphill on 01-14-2009 12:33 PM
Message Edited by jhemphill on 01-14-2009 12:33 PM
Reply
Options

1 Posts

01-26-2009

Germany

2 Signins

13 Page Views

  • Posts: 1
  • Registered: ‎01-26-2009
  • Location: Germany
  • Views: 13
  • Message 8 of 9

Re: SATA Controller M58 7373

2009-01-26, 10:10 AM

Ok, we got the same problem, but solved it. Our m58 and m58p models are running with XP now without any additional drivers.

 

1. BIOS --> ATA Drivers Setup --> AHCI disabled

2. StartUp--> StartUp Sequence--> delete Floppy

3. StartUp-->StartUp Sequence --> add IDE HDD

 

Just adding IDE HDD does not work for us. Don`t know why, but now its working fine. Hope i could helped you.

 

s0ki

 

ps: sorry for my bad English

Reply
Options

1 Posts

06-23-2009

Portugal

6 Signins

29 Page Views

  • Posts: 1
  • Registered: ‎06-23-2009
  • Location: Portugal
  • Views: 29
  • Message 9 of 9

Re: SATA Controller M58 7373

2009-06-23, 9:45 AM

thanks s0ki,

I was about to commit myself a suicide, I have 29 Lenovo M58 machines to downgrade to XP SO and did not know how to do it.

 

Tugas

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save