cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Patlover1983
Fanfold Paper
Posts: 9
Registered: ‎08-15-2014
Location: Netherlands
Views: 1,450
Message 1 of 10

ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch

Hello there,

 

I have (for the first time) a problem with my Lenovo ThinkCentre E73.

 

I recently updated the BIOS (it was one of the initial versions and had some issues) to the latest version. I use a KVM (Keyboard Video Mouse) switch. This KVM switch has some USB inputs (for keyboard, mouse, USB stick or whatever) and the USB part is based on a (switchable) USB HUB. But when i connect my USB keyboard to this HUB, the Lenovo BIOS doesn't recognize it (keyboard does'nt work, and the Lenovo shows error 0211, no keyboard connected. The KVM itself isn't faulty, in Windows everything worked fine. Also the previous used BIOS version has no problems with the KVM and works fine also. There where no changes made in the hardware setup.

 

When i plug my keyboard directly into the Lenovo the BIOS recognized it. When i use a simple (non powered) USB hub and plug my keyboard in, the BIOS doesn't detect is again. So it looks like the new BIOS has some issues with USB hubs. Not only my keyboard would be detected, also USB memory sticks are not visible by the boot manager.

 

Can anybody help me, or can Lenovo made a change to the new BIOS version so i can use my KVM again into the BIOS? Thank you!

Community SeniorMod
Community SeniorMod
Posts: 3,487
Registered: ‎12-31-2011
Location: US
Views: 1,437
Message 2 of 10

Re: ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch

I'm curious if you get the same result on a front USB port (I'm assuming the hub was connected to the rear.) 

__________________________________________________________________________
I do not work for Lenovo. I do not respond to Private Messages for help, your questions should be posted in the appropriate forum where the information exchange may help others. If I helped you, click the 'Kudos' button, if solved, the 'Accept as Solution'.
Patlover1983
Fanfold Paper
Posts: 9
Registered: ‎08-15-2014
Location: Netherlands
Views: 1,429
Message 3 of 10

Re: ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch

Hello BiggAl,

 

Just tried out the front USB ports (both), but they give the same results, the BIOS doesn't recognized the KVM and also not the USB hub.

Highlighted
Community SeniorMod
Community SeniorMod
Posts: 3,487
Registered: ‎12-31-2011
Location: US
Views: 1,415
Message 4 of 10

Re: ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch

Do you know if your Chipset driver is at the latest level ?    If you're not sure, rerun the driver install. 

__________________________________________________________________________
I do not work for Lenovo. I do not respond to Private Messages for help, your questions should be posted in the appropriate forum where the information exchange may help others. If I helped you, click the 'Kudos' button, if solved, the 'Accept as Solution'.
Patlover1983
Fanfold Paper
Posts: 9
Registered: ‎08-15-2014
Location: Netherlands
Views: 1,379
Message 5 of 10

Re: ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch

Thank you helping me out, BiggAl!

 

I'm not sure what you mean with Chipset drivers. I think you mean the Windows chipset drivers, but i do not see what this has to do with the BIOS. Can you explain me the relationship between the drivers and the BIOS?

Community SeniorMod
Community SeniorMod
Posts: 3,487
Registered: ‎12-31-2011
Location: US
Views: 1,366
Message 6 of 10

Re: ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch

The Intel chipset works with the Intel processor, and provides the USB communications among other functions.   Problems with USB are sometimes related to the chipset drivers.  

 

Since you upgraded the BIOS, you may need to upgrade the chipset drivers to keep everything working together.  There maybe more troubleshooting needed, but the next logical step to to negate this driver.   Your drivers can be found at Lenovo support, enter your model number, drivers, chipset, your OS.  

 

__________________________________________________________________________
I do not work for Lenovo. I do not respond to Private Messages for help, your questions should be posted in the appropriate forum where the information exchange may help others. If I helped you, click the 'Kudos' button, if solved, the 'Accept as Solution'.
Patlover1983
Fanfold Paper
Posts: 9
Registered: ‎08-15-2014
Location: Netherlands
Views: 1,348
Message 7 of 10

Re: ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch

Hello,

 

I just updated the Chipset drivers but, exactly what i expected, the keyboard connected to the USB hub and/or KVM switch still doesn't work in the BIOS menu and bootup select menu.

 

What to do now?

Community SeniorMod
Community SeniorMod
Posts: 3,487
Registered: ‎12-31-2011
Location: US
Views: 1,338
Message 8 of 10

Re: ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch


@Patlover1983 wrote:

 

.. the keyboard connected to the USB hub and/or KVM switch still doesn't work in the BIOS menu and bootup select menu.

 


How do you mean the 'BIOS menu and bootup select menu' ?    Do they work with Windows ? 

__________________________________________________________________________
I do not work for Lenovo. I do not respond to Private Messages for help, your questions should be posted in the appropriate forum where the information exchange may help others. If I helped you, click the 'Kudos' button, if solved, the 'Accept as Solution'.
Patlover1983
Fanfold Paper
Posts: 9
Registered: ‎08-15-2014
Location: Netherlands
Views: 1,333
Message 9 of 10

Re: ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch

Hello,

 

With the BIOS menu i mean the menu that that told you all the information about the PC and where you can make changes like UEFI or legacy BIOS etc. You get this menu when you hit F1 directly after turn on the PC. WIth the startup menu i mean the menu that you will get when you hit F12 after turn on the PC. In this menu you can choose from which drive the PC will startup (like the internal harddisk, DVD drive or USB stick). When using a USB hub or my KVM switch, the startup menu also doesn't detect devices that where plugged into the KVM switch.

 

Just to find things out: i have another ThinkCentre E73 (with an i5 cpu) and i flashed this also to the latest BIOS version. It also shows the same problems. So i think it's a bug in the BIOS firmware?

 

Within Windows (7 Ultimate on the i3 and 10 Home on the i5) everything work fine, with or without the KVM switch.

 

Community SeniorMod
Community SeniorMod
Posts: 3,487
Registered: ‎12-31-2011
Location: US
Views: 1,328
Message 10 of 10

Re: ThinkCentre E73 New BIOS doesn't recognize USB HUB and/or KVM switch

So everything is fine in Windows.   It's only during BIOS setup, the keyboard, through a hub, is not working.   

 

I completely misunderstood your question.   My apologies. 

 

I can only speak for myself, but the few times I need to go into the BIOS on my systems, I connect a wired USB keyboard (the keyboard my Lenovo originally came with) directly to a front port of the system.    The reason being is that I use wireless keyboards, and they do not come active quickly enough to F1 break into the BIOS setup.   I do not have to disconnect the wireless keyboard receiver -- both keyboards can be attached, and are active at the same time.   

 

 

 

__________________________________________________________________________
I do not work for Lenovo. I do not respond to Private Messages for help, your questions should be posted in the appropriate forum where the information exchange may help others. If I helped you, click the 'Kudos' button, if solved, the 'Accept as Solution'.

Check out current deals!


Shop current deals

Top Kudoed Authors