cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
robkn
Fanfold Paper
Posts: 11
Registered: ‎02-02-2018
Location: US
Views: 626
Message 31 of 37

Re: Failed uEFI / BIOS update M92p. Is there any hope?

I know how upsetting this can be. See posts 3, 5, 7 and 8 as regards to what worked for me. It's been a while since I had the problem, thus I don't recall all the details, but I believe I had to follow the instructions in the Maintenance Manual exactly. I have since done one more eUFI update using the CD iso and it went OK. (I'm a little scared to try another one since you have reported this problem, though....)

 

As far as an earlier version, if you scroll down to the 'Addidtional Information' section of the following web page, the version from July '18 appears to still be available. That is the one I last installed successfully and am running. (Note that Lenovo's web pages seem to be very laggy to load at the moment...)  If you can't get the file there let me know. I have a copy and we can try to find a way to get it to you.

 

https://pcsupport.lenovo.com/us/en/products/DESKTOPS-AND-ALL-IN-ONES/THINKCENTRE-M-SERIES-DESKTOPS/T...

Techhit
Paper Tape
Posts: 2
Registered: ‎06-29-2019
Location: NZ
Views: 375
Message 32 of 37

Re: Failed uEFI / BIOS update M92p. Is there any hope?


@yockfu wrote:

I have the M92P Tiny desktop and was able to recover from a failed BIOS update using a USB drive.

 

After trying all the solutions from multiple threads on this forum, this is what worked for me:

Download Rufus and format USB drive with FreeDOS

Download ISO from this link: https://support.lenovo.com/us/en/solutions/ht077504

Extract ISO to USB drive - overwrite ALL files

Move CMOS jumper from 1-2 to 2-3

Disconnect HDD - leave the speaker connected

Insert USB drive into USB 2.0 port on the back (the black colored USB port, not the blue ones, labeled 5)

Power on M92P

You should hear two loud beeps, followed by two (fainter) beeps that repeat

A screen should be displayed that the BIOS is being updated

The M92P will auto power down when completed
Disconnect power, move jumper back, reconnect everything

Power on!

 

I also did the above again, except with the newest BIOS version, and everything worked great!

 

Thank you to all for the assitance from these forums.

Jason

 

 

 



Thanks for this solution.  Saved me from having to buy a  new motherboard or going to buy some blank CDs.  Created an account on these forums just to say thanks.

 
 
yockfu
What's DOS?
Posts: 2
Registered: ‎01-03-2019
Location: US
Views: 357
Message 33 of 37

Re: Failed uEFI / BIOS update M92p. Is there any hope?

You’re very welcome.  I’m happy it worked for you!!

jakatz
What's DOS?
Posts: 1
Registered: ‎11-02-2019
Location: US
Views: 151
Message 34 of 37

Re: Failed uEFI / BIOS update M92p. Is there any hope?

After upgrading a perfectly working M92p Tiny (type 3237) from Windows 7 to Windows 10, I went to the Lenovo driver portal for the latest drivers, all of which installed through Windows except the BIOS which kept failing without an error code.  I found the ht077504 predecessor to this post, which led me to download the 9SJ979USA M92p BIOS ISO and burn to a CD.  I opened the Tiny, moved the CMOS reset jumper, unplugged the hard drive, plugged the CD drive into the only black USB connector in the back and plugged in the VGA monitor (no keyboard or mouse connected).  When I powered it up, the VGA screen lit, I watched the firmware get copied from 0 to 100 percent and the computer shut off when finished.  I unplugged the CD drive, replaced the disk drive cable, moved the CMOS jumper back and connected the keyboard and mouse.  When I plugged in the power, the fan and power light immediately started, but nothing else was working (mouse was not lit, no keyboard response, VGA light stayed amber).

 

I found and read this entire post and believe I have tried every combination of what is here, including locating and trying the same CD procedure with the newer 9SJ99CUSA M92p BIOS, and using RUFUS to FreeDOS format a 4 Gb USB stick and WinRAR to extracted and copy the files from both the 9SJ979USA and 9SJ99CUSA ISO files (one first, then the other), with the CD drive or USB plugged into the black USB connector on the back, the disk drive detached and the CMOS jumper in the reset position.  In every attempt, regardless of whether the CD or USB stick is plugged into the black USB connector, when I connect the power, the power light immediately lights and fan spins, the CD or USB stick blinks a few times, then absolutely nothing happens (while waiting up to 5 minutes) and the VGA monitor never turns from amber to green.  The only other sign of life is if the CMOS jumper is in the reset position (I believe I’m correct as there is no 1,2,3 markings on the system board) and everything is disconnected (no monitor, keyboard, mouse, disk drive or boot device), the M92p sounds two soft beeps every five seconds.

 

Everyone before me seems to have found a way to resuscitate their computer, so I am hoping someone has a suggestion for me.  Thanks in advance.

 

Highlighted
IIVQ
What's DOS?
Posts: 2
Registered: ‎11-03-2019
Location: NL
Views: 119
Message 35 of 37

Re: Failed uEFI / BIOS update M92p. Is there any hope?

I have tried to update my M73 10B5's update via the ISO to USB stick method.
This semi-bricked my machine. the first time I tried this, I got something like "Disk DOS booting", then the monitor went to standby and I heard two beeps.
I (stupidly) rebooted the computer at that time.

Since then, I have had either of the following happen:

  1. The USB stick or the ISO DVD with the latest image is in the machine while booting:
    The pc starts up (I hear fan) and after about 10 seconds I hear no beeps. The monitor doesn't come on (no signal) - both on displayport and VGA
  2. The USB stick of ISO DVD is NOT in the machine while booting:
    Same as above, except that the 2 beeps repeat every 5 to 15 seconds (the time varies)

I have tried the following:

  • Confirm the ISO DVD works by booting it in my own pc (non-lenovo, fails with BIOS size not matching <- this is good because it shows the DVD is bootable)
  • Reset the CMOS by putting the jumper on pin 2-3, rebooting, waiting for 10 secs or so, putting it on pin 1-2. This has had effect, because I had the bios setting to not boot up on power cycle.
  • Try the CMOS jumper on pin 2-3 with the DVD in there (it is doing something, double beep only once), and leaving the PC for 15 minutes, then rebooting with the CMOS jumper on pin-1-2.
  • Pull out the HD battery, shorting the terminals and putting it in there.
  • Completely disassemble the motherboard (including CPU and RAM and blow it off with compressed air, then reassembling it, to see if a loose connection caused something

This all has had no effect at all, I still have no display at all and have the choice of either 2 beeps with a BIOS update medium or 2 beeps, repeating without a BIOS update medium.

 

I am a bit out of options.
My gut feeling says I should check the RAM, but I don't have a pc that takes (or can donor) DDR3, and I'm not investing the €29 for the cheapest DDR I can get, as then it would be saner to get a raspberry pi 4.

But if anyone has any hints as what I can try, I would be grateful.

IIVQ
What's DOS?
Posts: 2
Registered: ‎11-03-2019
Location: NL
Views: 98
Message 36 of 37

Re: Failed uEFI / BIOS update M92p. Is there any hope?

I write "I hear no beeps" but I mean "two beeps" - when the USB stick or Bios update DVD is in the pc.
I have since also tried one firmware older (994) which also comes with a USB stick update, but also no avail.
mariushdu
Fanfold Paper
Posts: 6
Registered: ‎01-08-2018
Location: RO
Views: 84
Message 37 of 37

Re: Failed uEFI / BIOS update M92p. Is there any hope?

Can u put here that old 994? i need old bios for m92p, i have problem with 2 dimm's Smiley Happy

Check out current deals!


Shop current deals

Top Kudoed Authors