cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jf63
Fanfold Paper
Posts: 8
Registered: ‎07-17-2015
Location: US
Views: 4,500
Message 1 of 12

ThinkCentre M81: new Nvidia card, getting blank (black) screen (Win 10, GT 1030, graphics, driver)

I had a Geforce GT1030 video card in my M81 and each time it booted up, would go to black screen or go to black screen before finishing booting to Win10.  Ive actually tried several different Geforce cards with same results.  I took out card and used onboard video with no problem.  Gonna try ATI cards but seems like an issue with M81 and Geforce driver set.  I have even tried messing with bios settings to no avail. Anyone else experienced this?   Thank you!!

 

Mod:  edited the Subject line to expand the problem description

jf63
Fanfold Paper
Posts: 8
Registered: ‎07-17-2015
Location: US
Views: 4,489
Message 2 of 12

Re: M81 and Nvidia drivers

ok, a little more digging found a nvidia compatability list for win7 thru 8.1 but not for 10. interesting part is that i believe a lot of these cards use the same geforce experience drivers.
Community SeniorMod
Community SeniorMod
Posts: 3,632
Registered: ‎12-31-2011
Location: US
Views: 4,489
Message 3 of 12

Re: M81 and Nvidia drivers

Gt 1030 works with M91 and M90p (however, M81 does use a different Chipset than M91, Q65 vs. Q67.)   Are you at the latest BIOS, if not, update using CD ISO only (since you're running unsupported Win 10.)   Otherwise, it could be issue with Win 10, since there are no Win 10 drivers for the Chipset, and the processor is not supported. 

 

You'll have worse luck with a AMD card, search this forum for the many threads of newer AMD cards not being backward compatible with older ThinkCentres. 

 

Edit:  it appears that the BIOS is recognizing it (so not the AMD card problem), but some configuration issue. 

__________________________________________________________________________
I do not work for Lenovo. I do not respond to Private Messages for help, your questions should be posted in the appropriate forum where the information exchange may help others. If I helped you, click the 'Kudos' button, if solved, the 'Accept as Solution'.
jf63
Fanfold Paper
Posts: 8
Registered: ‎07-17-2015
Location: US
Views: 4,417
Message 4 of 12

Re: M81 and Nvidia drivers

Have done some more playing around.  Tried the GT-1030 card, tried the GTX-1050 card with the same results.   What happens is, on cold boot the card works fine using windows drivers, but as it boots and the nvidia driver kicks in, the screen goes black but there is some back light on plus the monitor power light stays blue and dont go to yellow meaning it is still seeing a signal from the video card.  i see that win10 is unsupported but pc came as a refurb with win10 x64 pre installed.  tried the amd card and see what you mean by worse, no display at all....period!  going crazy and all i need is a pci-e gpu with 2gb ram on it, i wouldnt think that would be so tuff!  saw where the gtx-1050 is compatible with this m81 with windows 8 but guess not for win 10.  HELP!!!!  thanks!

Community SeniorMod
Community SeniorMod
Posts: 3,632
Registered: ‎12-31-2011
Location: US
Views: 4,409
Message 5 of 12

Re: M81 and Nvidia drivers

This solved the same issue on an IdeaCentre:    Try disabling Secure boot, and enabling Legacy boot in the BIOS and see if that will show the Windows display.  (Failing that, try restoring the BIOS default settings.)  Thx. 

__________________________________________________________________________
I do not work for Lenovo. I do not respond to Private Messages for help, your questions should be posted in the appropriate forum where the information exchange may help others. If I helped you, click the 'Kudos' button, if solved, the 'Accept as Solution'.
jf63
Fanfold Paper
Posts: 8
Registered: ‎07-17-2015
Location: US
Views: 4,394
Message 6 of 12

Re: M81 and Nvidia drivers

I'll double check those when i get home but i know ive reset the bios but ill check the boot and going to try a couple other things.  As to the M81 not supporting Win10, i found a system update here https://pcsupport.lenovo.com/us/en/products/desktops-and-all-in-ones/thinkcentre-m-series-desktops/t...  for Win10 that the readme says supports all Thinkcentre's (among others).  going to try that and see if it takes it.  what are your thoughts on that?  Thanks!

jf63
Fanfold Paper
Posts: 8
Registered: ‎07-17-2015
Location: US
Views: 4,374
Message 7 of 12

Re: M81 and Nvidia drivers

Well that was a bust, no change, im out of possible solutions, brain is fried!  Can anyone recomend a PCI-e 2gb graphics card that WILL run in this M81 with Win10 Pro x64?  Thanks!

jf63
Fanfold Paper
Posts: 8
Registered: ‎07-17-2015
Location: US
Views: 4,363
Message 8 of 12

Re: M81 and Nvidia drivers

ok, one more thing to add.  I also have an M81 at work that I just setup and it is working fine with the GT-1030 card.  The only differences between the systems is mine is 10 pro x64 and at work it is 10 pro x86 so I'm guessing there is probably something in one of the x64 microsoft update that is causing it but I'm not going to uninstall all update to find out.

jf63
Fanfold Paper
Posts: 8
Registered: ‎07-17-2015
Location: US
Views: 4,305
Message 9 of 12

Re: M81 and Nvidia drivers

Got it fixed!  I totally cleaned out the latest drivers i was using and installed driver version 378.49 dated 1-17 and that did the trick!!

Community SeniorMod
Community SeniorMod
Posts: 3,632
Registered: ‎12-31-2011
Location: US
Views: 4,011
Message 10 of 12
Moved:

Re: ThinkCentre M81: new Nvidia card, getting blank (black) screen (Win 10, GT 1030, graphics, driv

Check out current deals!


Shop current deals

Top Kudoed Authors