Showing results for 
Search instead for 
Do you mean 
Paper Tape
Posts: 5
Registered: ‎05-01-2012
Location: NC
Message 1 of 5 (548 Views)

USB devices receive power but don't work after windows loads

A have a Thinkcentre a70z with windows 7 pro 32 bit that recently stopped working. It's never been in a production environment so I'm 99% sure it's not virus related. I'd rather not wipe it back to default becuase there is some modded / licensed software installed on it that I can't reinstall - I would have to schedule an outside vendor to come in and reinstall it.


USB devices are recognized and receive power but after windows loads they stop functioning (they don't work in safe mode, either). USB works fine in bios, ubuntu, and any other non-windows environment. I am able to remote into the computer, in device manager the USB devices are detected but have driver issues. The process fails when attempting to update the drivers. I tried restoring to a point a couple weeks in the past, installing a new chipset package, and removing a certain windows update that some random forum post said may be the culprit but the issue persists.


I would appreciate any and all help with this!


Begin Irritated Rant

I'm hoping this community can help since the extended warranty we bought for this product hasn't done much beside waste my time. After troubleshooting the issue for a couple days I called Lenovo support who sent a tech out with a new motherboard. The tech saw what I saw (not a motherboard or hardware issue) and said all he can do is order me some recovery disks since it's probably a windows issue. He calls in for the disks, gives me a new ticket number, and leaves with the new motherboard still in the box. About an hour later I get a call from Lenovo asking how I want to pay for the discs ("What do you mean, pay for them?"). Long, pointless conversation (and a third ticket number) later another person from Lenovo said they can send me discs but only after we troubleshoot it together on the phone. At this point the machine is in a different location without internet access so I ask for a phone # to call back after I get the machine accessible. I set the machine back up in my office, call the # back and am told the case is on warranty hold and the warranty department would call me back within the hour to resolve it. That was a couple hours ago. Lenovo support is usually pretty great but I am really irritated with this case.

End Irritated Rant

Posts: 955
Topics: 3
Kudos: 82
Solutions: 66
Registered: ‎01-05-2010
Location: INDIA
Message 2 of 5 (521 Views)

Re: USB devices receive power but don't work after windows loads

Hello adotmhc and welcome to community,


I understand as you do not want to reinstall the Windows the program settings and data.


Kindly uninstall USB drivers from device manager then install Intel Chipset Device Software for Windows 7 (32-bit and 64-bit)


You can also take the reference from the mentioned below web link.


If the issue persist then update the BIOS and check.


Flash UEFI BIOS update (Flash from operating system version)




Flash UEFI BIOS update (CD ISO image version)



Best Regards,


Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution".! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow @LenovoForums on Twitter!

Paper Tape
Posts: 5
Registered: ‎05-01-2012
Location: NC
Message 3 of 5 (507 Views)

Re: USB devices receive power but don't work after windows loads

Thank you for the welcome and the advice but none of these solutions worked. For the record the first update option didn't work but the second one did.

Paper Tape
Posts: 5
Registered: ‎05-04-2012
Location: Bay Area, CA
Message 4 of 5 (488 Views)

Re: USB devices receive power but don't work after windows loads

I'm working with USB devices and learning as I go. Before trying to update the drivers, did you uninstall what was there? If you connect the device, does it show up in Device Mgr? If so, right-click and select to Uninstall. Then disconnect and reconnect the device with Windows booted (booting with the device connected is a different ball game). Problems can arise from the USB device itself. There is a lot of handshaking going on between the hardware and the OS. If the devices show connected before Windows boots I believe they are responding to the power detected on the port, but they aren't actually enumerated. To have them show up properly in Device Mgr. they have to enumerate. It is also possible to see them in Device Mgr. and not  be able "talk" to the device. Try changing ports (which you probably have done) and uninstalling the driver (specific to the port) as above. On the Lenova machines I'm using the USB ports are all 500 mA, but some are high-speed and some are medium-speed. I'm not sure if this could make a difference. Check out this site for great info:

Paper Tape
Posts: 5
Registered: ‎05-01-2012
Location: NC
Message 5 of 5 (473 Views)

Re: USB devices receive power but don't work after windows loads

I appreciate your advice. The devices were showing up in device manager, and I did try uninstalling all usb before reinstalling them. I also tried a few different usb devices including mice, keyboards, laser scanners, sig pads, etc in all the different ports. I ended up having to wipe the machine back to default (everything works now) and am working with the vendor to get all the custom software reinstalled. 

Top Kudoed Authors