English Community

ThinkCentre DesktopsThinkCentre A, E, M, S Series
All Forum Topics
Options

33 Posts

04-22-2016

US

60 Signins

335 Page Views

  • Posts: 33
  • Registered: ‎04-22-2016
  • Location: US
  • Views: 335
  • Message 1 of 4

Video Output over Display Port works on Lenovo Thinkcentre M92p but not on M93p.

2019-01-26, 21:58 PM

I have been using a Display Port to HDMI Cable with my M92p for a long time now to connect to my 2 Philips Monitors. I now wanted to connect my M93p the same way and I'm now struggling to do so. I just cant get a signal out through Display Port no matter what I do neither in Bios nor on Windows. And on the PC side, my Monitors are not recognized at all. As my setup works with the M92p, the cable and Monitor are OK I guess. Why does M93p fail? Apart from VGA, the Display Ports are the only other Option. I read that M92p has DIsplay Port Version 1.1. and M93p Version 1.2: https://forums.lenovo.com/t5/ThinkCentre-A-E-M-S-Series/M93P-Displayport-1-1-or-1-2/td-p/2174499

 

But I also read that Cable wise this schouldn't make any difference.

 

https://en.wikipedia.org/wiki/DisplayPort#Overview

 

WHats the problem here? WHy is Display Port Output not working on M93p while it does work on M92p?

Reply
Options

3776 Posts

12-11-2015

US

4347 Signins

48912 Page Views

  • Posts: 3776
  • Registered: ‎12-11-2015
  • Location: US
  • Views: 48912
  • Message 2 of 4

Re: Video Output over Display Port works on Lenovo Thinkcentre M92p but not on M93p.

2019-01-27, 0:31 AM

As long as you have a decent quality Display Port cable(s), the cable should support versions 1.1, 1.2 and 1.2A, and since it is working on on the M92p, I would rule it out.    My guess would be that it is display driver related. 

 

  • Is there a splitter involved?   
  • Which OS are you running, is it the same on both?
  • Do you have an discrete video card installed, or are you using the built in Intel HD Graphics 4400/4600
  • Which video driver version are you using, and have you tried an older/newer version, or tried using the Microsoft Basic Display Adapter driver?

 

Best of luck,

 

 

 

Reply
Options

33 Posts

04-22-2016

US

60 Signins

335 Page Views

  • Posts: 33
  • Registered: ‎04-22-2016
  • Location: US
  • Views: 335
  • Message 3 of 4

Re: Video Output over Display Port works on Lenovo Thinkcentre M92p but not on M93p.

2019-01-27, 10:24 AM

No SPlitter.

WIndows 10 the exact same version.

I downloaded the latest VGA Driver from lenovo. I don't have an older version. I ruled out a driver issue becouse the Display Port doesn't even work in Bios on the M93p while it does work on Bios Level on the M92p.

I don't have a dedicated GPU isntalled in the M93p. If I had one, I wouldn't need to use the M93p's DIsplay Port.

I just find it strange that one of the key hardware features of the PC is unusuable.

RIght now I can only use the VGA port for Video Output. This huge step backwards from M92p to M93p baffles me.

Reply
Options

1 Posts

05-09-2020

US

1 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎05-09-2020
  • Location: US
  • Views: 5
  • Message 4 of 4

Re:Video Output over Display Port works on Lenovo Thinkcentre M92p but not on M93p.

2020-05-09, 19:22 PM

Hi. I wanted to ask if this ever got resolved because im having kind of the same issue. Thank you

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete