cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
eja124
Fanfold Paper
Posts: 5
Registered: ‎12-29-2018
Location: GB
Views: 314
Message 1 of 8

thinkcentre no audio through HDMI or display port

Hello, 

I have recently purchased a thinkcentre m710, i had an issue with windows in the first week which lead to me restoring the pc.

After setting the computer back up again i am having an issue with no audio being played through the hdmi or the display port connections out of the back of the pc. the internal speakers work fine but are too quiet to hear for what i want to use it for. 

I have triend installing the audio and graphics drivers again but no luck. 

If there is anything i can try please let me know Smiley Happy 

(when i connect the speakers through the audio jack in the front of the pc sound works as expected, just doesnt seem to work through any display adapter.)

image 1: device manager

Image 2: device manager with hidden devices shown 

image 3: sound manager

 

Thanks in advance

 

 

SeniorGuru
Posts: 2,225
Registered: ‎06-13-2013
Location: US
Views: 293
Message 2 of 8

Re: thinkcentre no audio through HDMI or display port

Your screenshots show that there is no NVidia graphics card in Device Manager.  And that's also where HDMI Audio is supported, through the HD Audio Driver installed through the NVidia graphics package.  Your "sound" shows only Realtek, when it also should show NVidia HD Audio.

 

What model M710 do you have (tower, SFF, tiny)?  And do you have a discrete NVidia graphics card in the machine?  The M710 doesn't have HDMI on the motherboard, that would be on the NVidia graphics card.  And the DisplayPort conenctors on the motherboard are from the Intel HD Graphics, but unless you have an Intel driver package installed that includes Intel HD audio driver you won't be getting any audio out from DisplayPort.  The fact that there is no Intel HD Audio driver shown in Device Manager tells me you don't have the proper Intel driver installed as well.

 

So... can you take a picture of the back of your machine, so that we can see if you have a graphics card in the top expansion slot? 

 

Did you fool around in the BIOS, setting the graphics option to IGD instead of AUTO or PEG?  If you force IGD then that means you don't want to use the NVidia card even if it's physically installed, so you won't get anything out HDMI (neither audio nor video).

 

You say you've asked a friend to install audio and graphics drivers.  What driver packages are you using?  Audio delivered out over HDMI is handled by NVidia, not Intel, because the motherboard only has Displayport.  It's the discrete NVidia graphics card where HDMI is supported.  And while audio out over DisplayPort is supported, it needs the proper Intel HD Audio driver, not a Realtek driver.

 

Please clarify your machine configuration, if you have an NVidia card, and what driver packages you've attempted to use, and what you have your BIOS set to for Config -> Display.

eja124
Fanfold Paper
Posts: 5
Registered: ‎12-29-2018
Location: GB
Views: 286
Message 3 of 8

Re: thinkcentre no audio through HDMI or display port

Hello, 

thank you for getting back to me, 

Much apreicated. 

attached is the image of the back of the PC, i have the "tiny" model

all drivers have been downloaded from the lenovo website and i have also used the driver update tool (5) but in my past experiance i am awear that lenovo arent great when it comes to some drivers for some computers. (on there website there arent any nvida drivers avaliable)

 

I have not been into the bios. i can have a look into the bios if you think that would help? 

Kind regards,

 

SeniorGuru
Posts: 2,225
Registered: ‎06-13-2013
Location: US
Views: 277
Message 4 of 8

Re: thinkcentre no audio through HDMI or display port

There's another current thread in the forum on almost the identical issue you're asking about.

 

See my latest post at the bottom of that thread where I mention the mysterious disappearance of the Intel Graphics/Audio driver from the Lenogo driver download page for the M710q.  Oddly, it only provides a download for the Nvidia Graphics driver but I didn't know the M710q offered NVidia graphics hardware.  I thought it was all Intel HD Graphics.

 

Anyway, in my post I provide links to the Intel Downloads page for a somewhat newer (from Dec 2018) version of the graphics/audio driver package than the one Lenovo was providing as of yesterday but which has now disappeared for some reason, from October 2018.

 

I would think it's worth trying the latest driver package available from Intel as the release notes show that it is applicable to the Intel HD Graphics 630 in the M710q.  And it includes the needed Display Audio Driver.

 

eja124
Fanfold Paper
Posts: 5
Registered: ‎12-29-2018
Location: GB
Views: 274
Message 5 of 8

Re: thinkcentre no audio through HDMI or display port

Hi, 

okay thank you Smiley Happy 

i will have a look into this give it a try and let you know how i get on, 

regards

eja124
Fanfold Paper
Posts: 5
Registered: ‎12-29-2018
Location: GB
Views: 253
Message 6 of 8

Re: thinkcentre no audio through HDMI or display port

Hello, 

Thank you so much! 

I have uninstalled my intel graphics driver which I instelled from lenovo and then installed the one from the intel website for my processor! 

amazingly this time intel display audio display driver has been installed and audio out of display port and hdmi port is not fully working. 

looks like the lenovo website graphics download doesnt include the display audio for some reason. 

Thank you so much for your help! much apreciated.Smiley Very Happy

Kind regards,

SeniorGuru
Posts: 2,225
Registered: ‎06-13-2013
Location: US
Views: 249
Message 7 of 8

Re: thinkcentre no audio through HDMI or display port

New information on the other related thread now explains that there seems to be a problem with the Win10 1809 update, which broke Intel HDMI audio that was previously working properly under 1803.  This pertains to the Intel driver obtained from the Lenovo site for the M710q.  Actually, for some reason the Intel driver link is now missing from the M710q download page but it still is present for the M910q, and the driver package is identical.

 

Apparently, backing out the sysytem from 1809 to 1803 brought back HDMI audio... with the very same latest Lenovo-provided Intel driver package.  Works with 1803, doesn't work with 1809.

 

If you now say that you've gone ahead and installed the VERY LATEST driver package downloaded from Intel directly and that magically it now works, it might be that they (i.e. Intel) have actually corrected whatever was wrong in the earlier dirver (that Lenovo certified) as far as incompatibility with 1809.  The older Lenovo package apparently needs updating as well, in order to be compatible with 1809 as well.

 

Are you at 1809?  Or 1803?

 

eja124
Fanfold Paper
Posts: 5
Registered: ‎12-29-2018
Location: GB
Views: 246
Message 8 of 8

Re: thinkcentre no audio through HDMI or display port

ah okay, 

my build is 1809 biut i upgraded from 1903 shortly after purchasing, this update is what bricked the computer and lead to me reinstalling a fresh install of windows 10 1809 build into the PC which had been working fine appart from the display audio issue.

regards

Check out current deals!


Shop current deals

Top Kudoed Authors