Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: 11e (Windows), 13, E and Edge series Laptops
All Forum Topics
Options

2 Posts

02-07-2013

New Caledonia

3 Signins

21 Page Views

  • Posts: 2
  • Registered: ‎02-07-2013
  • Location: New Caledonia
  • Views: 21
  • Message 71 of 115

Re: E420 motherboard problems

2013-02-07, 23:34 PM

Yet another dead E420. 4 months out of warranty.  I own  4 current Thinkpads (E420, T420, W500, T61) and have a couple of T60s laying around I don't use anymore.  I think after this experience, I'll be looking at something else.  I'm thinking of getting a Macbook and putting Windows on it.  

 

BAD Lenovo.  You CANNOT put the Thinkpad name on garbage!

Reply
Options

3 Posts

04-02-2012

Omaha, Nebraska

3 Signins

17 Page Views

  • Posts: 3
  • Registered: ‎04-02-2012
  • Location: Omaha, Nebraska
  • Views: 17
  • Message 72 of 115

Re: E420 motherboard problems

2013-02-12, 22:27 PM

Update as I posted regarding this 2 time before. Now all my units are out of warranty. Have sent 5 in for exact same cause. Now I have 2 more out for same reason and can't justify sending in for repair.

 

Beware and do not buy the edge series and even consider any of the products for Lenovo if they can't admit a problem and at least offer a solution. Even an upgrade option to another model would be acceptable. As for my company with about 100 users between laptop and desktops, we'll never consider Lenovo again.

 

Who knows maybe someday I'll be a CIO at a company with the purchasing power of 10,000+ units. And you guessed it. Lenovo will not be a consideration.

Reply
Options

2 Posts

08-15-2012

Stanford, California

2 Signins

15 Page Views

  • Posts: 2
  • Registered: ‎08-15-2012
  • Location: Stanford, California
  • Views: 15
  • Message 73 of 115

Re: E420 motherboard problems

2013-02-22, 0:36 AM

Exactly the same... very disappointing.. my e420 was 1 year 2 months old (and unfortunately, just out of warranty).. im not planning to get it repaired.

Reply
Options

1 Posts

03-14-2013

Maryland

1 Signins

23 Page Views

  • Posts: 1
  • Registered: ‎03-14-2013
  • Location: Maryland
  • Views: 23
  • Message 74 of 115

Re: E420 motherboard problems

2013-03-14, 15:07 PM

Same issue here, purchased 4 E420 laptops a little over a year ago for a client and 2 of the 4 have gone up in the last few months.  No power light, totally dead.  Out of warranty.  This is sad and frustrating.  I thought it was a very unlikely coincidence before googling this and finding the issue on the forum.  Makes me rethink my almost exclusive use of Lenovo products.

Reply
Options

1 Posts

04-02-2013

Knoxville, TN

7 Signins

19 Page Views

  • Posts: 1
  • Registered: ‎04-02-2013
  • Location: Knoxville, TN
  • Views: 19
  • Message 75 of 115

Re: E420 motherboard problems

2013-04-02, 19:07 PM

The problems crept up so slowly and always seemed to point to other hardware and/or software issues. During the warranty period and under the guidance of Lenovo Tech Support, I tried restoring to factory settings, restoring to a new hard drive, just installing windows from a retail disk without any Lenovo software, tried different RAM. The startup/wakeup problems and blue screens persisted and worsened. The laptop, now 90 days out of warranty is useless as it sits. I just called Lenovo Out of Warranty Parts at 1-877-719-0841. I was quoted $935 for the 04W6588 Motherboard. Call them for yourself if you're up for a good laugh. CDW-G has it listed online at $618.44 - still more than a new laptop. Apparently the "s" in e420s stands for "sucker". Never again, Lenovo.

Reply
Options

11 Posts

12-10-2012

Bulgaria

9 Signins

107 Page Views

  • Posts: 11
  • Registered: ‎12-10-2012
  • Location: Bulgaria
  • Views: 107
  • Message 76 of 115

Re: E420 motherboard problems

2013-04-30, 14:05 PM
Hello Folks,

If there is someone who sells his dead lenovo e420s, please let me know.

I need 1 or 2 dead motherboards.

You can contact me on my email: alper_ismail (at) hotmail (dot) com

Thank you in advance
Reply
Options

11 Posts

12-10-2012

Bulgaria

9 Signins

107 Page Views

  • Posts: 11
  • Registered: ‎12-10-2012
  • Location: Bulgaria
  • Views: 107
  • Message 77 of 115

Re: E420 motherboard problems

2013-05-14, 10:02 AM

Finally E420s motherboard REVIVED / FIXED / REPAIRED !!!

 

After serious efforts and wasting substantial amount of cash and time (and lotsss of reading :).... ) I have managed to revive my Lenovo E420s motherboard . Even I have contacted WISTRON company the one designing and manufacturing the MB for LENOVO. I asked them for the electrical schematic for this MB but as you can guess NO SUCCESS.

 

On my previous posts I have asked if there are folks who want to sell their faulty motherboards and the reason was simple, wanted to test and see if they have the same issue but.......... no one was interested in selling faulty E420s MB.

 

Here are the specs of my Lenovo E420s:

CPU: Intel iCore 5 2nd generation

RAM: 16GB, 2 x 8GB

Video: Intel 3000HD

SSD: 64GB msata, MyDigitalDiscount BulletProof

HDD: 500GB, Hitachi 7mm, 5400rpm

2nd HDD: SATA caddy with 1TB 9.5mm (DVD was replaced with an HDD caddy)

 

Anyway, let us get to the problem first and then to the solution:

 

- PROBLEM (the one that I had)

 

Whilst the laptop was perfectly working it suddenly powered/went off for no reason (the same as you pull the power cord from a DESKTOP PC). When I tried to power up, the first couple of times of pushing the power button did not work but I was persistent and after of couple of more pushes the laptop powered up, lucky me :). The interesting thing here was LENOVO power management gauge (green battery gauge on the bottom right corner next to system tray) was indicating that laptop is connected to the power adapter but the battery was draining/discharging. I was just watching how the battery is depleting till it was fully empty and the laptop went off and never powered up again.

There was no indication at all for anything - NO RED LIGHT on the dot of "i" and the green LED next to the power jack was off even though the power adapter was connected to the laptop. BTW this green LED indicates if your laptop is charging the battery.

 

 

here i am gonna skip the all the non senses that i have done in order to get my laptop working again and go straight for the solution. All the images (only 3 images ;) ) are uploaded on my dropbox and you can download them from there.

 

Here is the link: https://www.dropbox.com/sh/3o1njwwgvfjho2n/ma8fpW7wKt

 

- Solution:

 

1. You have to disassemble the laptop and to take out the system board or for shortly MB.
 Please remove all the components from the MB. You have to end up only with bare MB with components which are soldered on it. you can keep the cpu and gpu and the cooling assembly on. Refer to the image named top_MB_e420s.jpg

 

2. On the bottom side of the MB there is one connector with 5 pins which provides the POWER for the MB. The cable connected to this connector is coming from the POWER JACK of the laptop in our case this is the 20V voltage power source from the power adapter. Have a look at image bottom_MB_e420s.jpg the yellow square.

 

3. NEXT to this connector there are 2 small chips with 8 pins. These 2 chips are MOSFET transistors (both of them are same part number) and they are acting as a SWITCH or with other words as a POWER SOURCE SELECTOR. To visualize how these 2 MOSFETs are connected have a look at Fig.1 on this webpage: "http://www.eetimes.com/design/power-management-design/4012528/Fundamentals-of-designing-with-MOSFET-power-switches". No harm will be done if you want to read the whole article as well. Please check image named "bottom_MB_e420s.jpg" red rectangular.

 

4. After measuring these 2 MOSFETs with multimeter I have established that one of them was gone / faulty. Here is the MOSFETs part number: FDS6675BZ - this is P-channel 30V 11A. You can get 6pcs from ebay for only USD 3-4.

Here I would recommend to replace both MOSFETs. DO NOT replace only the faulty one. For more information you can refer to the datasheet of the MOSFET. Refer to image named "bottom_MB_e420s.jpg" for locating the MOSFETs.

 

PLEASE BE AWARE MOSFETS ARE VERY SENSITIVE TO STATIC ELECTRICITY. IF YOU GOING TO DO DESOLDERING AND SOLDERING BY YOURSELF PLEASE WEAR ANTISTATIC WRIST STRIP or TAKE NECESSARY ANTISTATIC PRECAUTIONS.

 

So for my case scenario these MOSFETs were the problem by replacing them everything worked just fine with no problem at all. I left the laptop running for 48 hours no problem observed, I have restarted it couple of times with no issues as well and reinstalled the OS.

 

I have another faulty E420s MB and the MOSFETs there are with the following part numbers: AO4407A. As you can guess the problem with this MB is the same - one of the MOSFETs is gone. This MOSFET is identical to the above mentioned and you can interchange this one with the above mentioned MOSFET. Please refer to the datasheet to check the most important parameters Id, Vd, Rds.

This MB have not fixed yet due to blowing a small SMD resistor 0.01ohm ohm and now I cannot find this SMD resistor. I f you can help me find this resistor from somewhere will appreciate very much.

 

On my dropbox public folder I have uploaded the location of the BIOS chip as well. It is only for your information.

 

So, I hope this will help most of you to revive your Lenovo E420s laptop and start using it again.

 

If this info helped you to revive your e420s I will appreciate your donation to recover some of the cash that i have wasted to repair this MB.

 

you can donate to my paypal here is the email:xxxxxxxxxxxxxxxx

 

If you have any questions feel free to contact me on the same email will try my best to help you all.

 

Thank you!

 

And Good Luck!

 

p.s.

 

I have just added and the hardware service manual from lenovo for e420s. this will help you to disassemble and assemble your laptop. ;)

 

Moderator Note; e-mail address removed. Posting an e-mail address is inviting spam, better to use the forum's private message function.

Reply
Options

11 Posts

12-10-2012

Bulgaria

9 Signins

107 Page Views

  • Posts: 11
  • Registered: ‎12-10-2012
  • Location: Bulgaria
  • Views: 107
  • Message 78 of 115

Re: E420 motherboard problems

2013-05-15, 10:16 AM

Hi,

 

I am very happy to confirm that the second Lenovo E420s laptop was fixed as well. I have managed to find a 10ohm smd resistor and replace both MOSFETs and wow now the laptop is flying :smileyvery-happy:

 

So far all is good.

 

Good luck.

Reply
Options

18 Posts

06-02-2011

Australia

480 Signins

1049 Page Views

  • Posts: 18
  • Registered: ‎06-02-2011
  • Location: Australia
  • Views: 1049
  • Message 79 of 115

Re: E420 motherboard problems

2013-05-15, 21:28 PM

At least some hope!

Would anyone know where in the motherboard are the mosfets in an Edge E420 (not E420S)?

I'm going to do some diagnosing on my own but would be great if someone with more electronics knowledge could have a look at it and point us to the right direction.

Reply
Options

11 Posts

12-10-2012

Bulgaria

9 Signins

107 Page Views

  • Posts: 11
  • Registered: ‎12-10-2012
  • Location: Bulgaria
  • Views: 107
  • Message 80 of 115

Re: E420 motherboard problems

2013-05-15, 22:26 PM

@ not4us

 

Hi not4us,

 

can you take pictures of your MB - top and bottom side. I might be able to help you to locate them.

 

you can send them to my email address which you can get from here: https://www.dropbox.com/sh/3o1njwwgvfjho2n/ma8fpW7wKt

 

cheers

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms