English Community

ThinkPad NotebooksThinkPad: 11e (Windows), 13, E and Edge series Laptops
All Forum Topics
Options

33 Posts

01-11-2010

US

61 Signins

478 Page Views

  • Posts: 33
  • Registered: ‎01-11-2010
  • Location: US
  • Views: 478
  • Message 21 of 25

Re: Replace WiFi card in E485

2019-01-30, 19:20 PM
 wrote:

 

GRUB_CMDLINE_LINUX="ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1 iommu=soft pcie_aspm=off amdgpu.dc=1 amdgpu.aspm=0"

 

You don't need to specify amdgpu.dc=1 for any Vega GPU. It's always enabled for Vega and won't even work without display core (dc). Why are you disabling amdgpu.aspm by the way?

 

ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1

Is that the key part which fixes blutooth? Sounds like something Lenovo need to fix in the UEFI.

Reply
Options

10 Posts

01-04-2019

ES

29 Signins

212 Page Views

  • Posts: 10
  • Registered: ‎01-04-2019
  • Location: ES
  • Views: 212
  • Message 22 of 25

Re: Replace WiFi card in E485

2019-01-30, 19:39 PM

Maybe amdgpu.dc=1 is not necessary now since it's enabled by default in the newest kernels.

The parameters ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1 are needed to make the screen (or perhaps the GPU or perhaps X) and the SD card reader work. They aren't the key part to fix Bluetooth.

I only posted the settings that work in my computer which I found out reading here and there and by trial and error.

And yes, the UEFI must be fixed. It's stated and proven in this forum topic.

Reply
Options

25 Posts

01-03-2019

AU

43 Signins

300 Page Views

  • Posts: 25
  • Registered: ‎01-03-2019
  • Location: AU
  • Views: 300
  • Message 23 of 25

Re: Replace WiFi card in E485

2019-01-31, 1:49 AM

Hi all

 

For those with intel bluetooth issues, i have posted a thread over at intel raising the issue.

It might be good if you could add to the conversation as it might be fixed alot quicker.

 

https://forums.intel.com/s/question/0D50P00004DCumVSAT/intel-9260ngw-dual-band-bluetooth-50-80211ac-no-bluetooth-in-linux?language=en_US

 

Thanks

Reply
Options

2 Posts

05-24-2019

DE

2 Signins

64 Page Views

  • Posts: 2
  • Registered: ‎05-24-2019
  • Location: DE
  • Views: 64
  • Message 24 of 25

Re: Replace WiFi card in E485

2019-05-24, 23:17 PM

Hi there,

 

I have replaced my WiFi with a 9260 as well. But my throughput is really bad. Only 20-30MByte/s from a fileserver and the same throughput checked with netio. The network connection says 866MBit and I am just 2m away from my router. My wife gets around 60-70MByte/s with her older Clevo notebook and a 7260 card.

 

Has anybody else these issues or some tips how to increase these values? I am on Windows 10 pro btw and have already doublechecked the antenna connectors.

 

Theoretically both the 9260 and my router support 160MHz bandwith which should result in 1,73Gbit. But the 9260 is only using 80MHz.

Reply
Options

1 Posts

08-01-2020

AU

2 Signins

5 Page Views

  • Posts: 1
  • Registered: ‎08-01-2020
  • Location: AU
  • Views: 5
  • Message 25 of 25

Re:Replace WiFi card in E485

2020-08-01, 14:36 PM

i have an AMD processor on laptop, i am trying to replace the card but on amazon says AC 9260 does not support amd processor. Just wondering what processor you have in your laptop.

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete