Welcome to our peer-to-peer forums, where owners help owners. Need help now? Visit eSupport here.

English Community

ThinkPad NotebooksThinkPad: 11e (Windows), 13, E and Edge series Laptops
All Forum Topics
Options

3 Posts

03-07-2021

United States of America

3 Signins

20 Page Views

  • Posts: 3
  • Registered: ‎03-07-2021
  • Location: United States of America
  • Views: 20
  • Message 1 of 5

ThinkPad E470 (Win10Enterprise) HDMI port suddenly stopped working

2021-03-07, 17:15 PM

Hello! Trying to figure out an issue that spontaneously appeared on my E470 a couple days ago. It's had no problems with HDMI connectivity in the two or three years I've used it previously, but now it won't connect no matter what I do. Looking at Windows Settings > Display, no additional monitor is detected when I have a monitor plugged into the HDMI port.

 

I've tried the following:

 

  1. Rebooting the computer.
  2. Using three different HDMI cables of varying lengths and quality.
  3. Verifying that the external monitor works by plugging another device into it. (It does.)
  4. Selecting "Detect" in Windows Settings > Display > Multiple Displays.
  5. Installing all available Windows and Lenovo updates.
  6. Uninstalling the Intel HD Graphics 620 device from Device Manager and removing its drivers, then re-installing drivers from Intel.
  7. Attempting to use the "Hardware Diagnostics" offered by this page on Lenovo's website, though it seems like this doesn't actually do anything and the scan never competes.

 

Is there anything else I've missed here? Any other troubleshooting options?

Reply
Options

2104 Posts

01-08-2021

Philippines

144 Signins

10650 Page Views

  • Posts: 2104
  • Registered: ‎01-08-2021
  • Location: Philippines
  • Views: 10650
  • Message 2 of 5

Re:ThinkPad E470 (Win10Enterprise) HDMI port suddenly stopped working

2021-03-08, 22:15 PM

Hello NAFuture,

 


Welcome to Lenovo Community

 

I suggest that you go to BIOS, load default settings, then save nd exit.
Make sure BIOS is up to date thru the support site.

Try uninstalling the display driver, completely remove it from the system. Then go to the support site and install a fresh copy of the driver.
Update us how it goes

 


Regards, 
Lorenzo_Lenovo



Did someone help you today? Press the star on the left to thank them with a Kudo!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.

Follow us @LenovoSupport on Facebook and Twitter!

Reply
Options

3 Posts

03-07-2021

United States of America

3 Signins

20 Page Views

  • Posts: 3
  • Registered: ‎03-07-2021
  • Location: United States of America
  • Views: 20
  • Message 3 of 5

Re:ThinkPad E470 (Win10Enterprise) HDMI port suddenly stopped working

2021-03-09, 18:11 PM

@ Lorenzo_Lenovo wrote:

I suggest that you go to BIOS, load default settings, then save nd exit.
Make sure BIOS is up to date thru the support site.

Try uninstalling the display driver, completely remove it from the system. Then go to the support site and install a fresh copy of the driver.
Update us how it goes

 

Thanks Lorenzo! Unfortunately I tried everything you've suggested here and nothing seems to have changed.

Reply
Options

4252 Posts

08-02-2018

Singapore

837 Signins

21919 Page Views

  • Posts: 4252
  • Registered: ‎08-02-2018
  • Location: Singapore
  • Views: 21919
  • Message 4 of 5

Re:ThinkPad E470 (Win10Enterprise) HDMI port suddenly stopped working

2021-03-12, 20:59 PM


Any changes made or any updates installed before the issue came up? Can you send a screenshot of the BIOS version and  OS version under the system information? 

 


Jwes_Lenovo



Did someone help you today? Press the thumbs-up icon below to thank them.!
If you find a post helpful and it answers your question, please mark it as an "Accepted Solution"! This will help the rest of the Community with similar issues identify the verified solution and benefit from it.


Using Browser Search to find your answers in Lenovo and Moto Community

Reply
Options

3 Posts

03-07-2021

United States of America

3 Signins

20 Page Views

  • Posts: 3
  • Registered: ‎03-07-2021
  • Location: United States of America
  • Views: 20
  • Message 5 of 5

Re:ThinkPad E470 (Win10Enterprise) HDMI port suddenly stopped working

2021-03-12, 23:48 PM

@ Jwes_Lenovo wrote:


Any changes made or any updates installed before the issue came up? Can you send a screenshot of the BIOS version and  OS version under the system information? 

 

No major changes that I'm aware of, but it's possible there could have been a Windows update.

 

As a note, I tried booting from a live USB of Ubuntu and wasn't able to detect an HDMI connection from there either, so I suspect this is might be a hardware defect.

 

Here's the system info:

 

Reply
Forum Home

Community Guidelines

Please review our Guidelines before posting.

Learn More

Check out current deals!

Go Shop
X

Save

X

Delete

X

No, I don’t want to share ideas Yes, I agree to these terms

Most Liked Authors

(Last 7 days)

View All